A/C Electrical Problem - Need help ASAP (please and thank you) - Diesel Place : Chevrolet and GMC Diesel Truck Forums
 
Home Forum Market Place Garage Tuning Library DTC Tool Register Vendors
Go Back   Diesel Place : Chevrolet and GMC Diesel Truck Forums > Speciality Forums > Electrical
Register FAQ Forum Rules My Replies My Threads Mark Forums Read Advertise

Electrical Discuss anything related to OEM & aftermarket electrical devices including: stereos, speakers, video, batteries, starters, the body control module, lighting, etc.

DieselPlace.com is the premier Duramax Diesel Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools
Old 08-26-2015, 05:20 PM   #1 (permalink)
OldCotton
Sparkplug Hunter
 
Join Date: Aug 2015
Posts: 1
iTrader Score: 0 reviews

A/C Electrical Problem - Need help ASAP (please and thank you)

Hey Yall,
Ive been this forum on and off for sometime, but Ive recently developed a problem with my trucks electrical system that has stumped me.


I have a 1996 Chevrolet K1500 wiith 6.5 TD.

My AC compressor went bad so I went and bought a refurbished unit at my local store. (1st mistake, should have bought new). Well I got it back to where a was working on the truck and we installed the compressor, replaced condenser, vacuumed the lines, and added PAG and R134. Well the AC worked GREAT for about 2 days and then the clutch seized and locked up as I was driving down the highway. The compressor got very hot and internal parts of the ac clutch melted. (it smelt awful). Well after removing it, I took it immediately back where it was purchased. They took it apart and said it was a defect in the compressor and gave me another compressor again refurbished. Well I went and reinstalled, vacced, everything all over again, but this time the compressor will not turn on. I even tried jumping the high power sensor on passenger side by the condenser to jump the compressor on. Nothing I could do would get ac compressor to turn on. Now I have checked and double checked everything and i have found that there is no power to the high pressure compressor switch/plug on the back of the compressor itself , there is also no power going to the clutch plug/on the top of the compressor by the pulley. There is power however going to the high pressure switch by the condenser on the passenger side, and there is power going to low pressure switch. I replaced the AC relay under the hood, but it had no effect. I then checked all of the connections of the 4 prong ac relay in the fuse box, and there is power missing to half of the AC relay prongs.

What could cause the AC relay to not get power?\

Also I dont know if this is related but sure for about 6 months the horn would only work intermittently, now it also does not seem to work...not if relay is bad havent replaced/checked yet.


Thank you for any help you can give me!

-Cotton

Offline  
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 08-26-2015, 05:30 PM   #2 (permalink)
OkDually
Administrator
 
OkDually's Avatar
 
Join Date: Jul 2013
Location: N.E. Oklahoma
Posts: 13,845
iTrader Score: 0 reviews

DieselPlace.com Lifetime Premium Member

Quote:
Originally Posted by OldCotton View Post
Hey Yall,
Ive been this forum on and off for sometime, but Ive recently developed a problem with my trucks electrical system that has stumped me.


I have a 1996 Chevrolet K1500 wiith 6.5 TD.

My AC compressor went bad so I went and bought a refurbished unit at my local store. (1st mistake, should have bought new). Well I got it back to where a was working on the truck and we installed the compressor, replaced condenser, vacuumed the lines, and added PAG and R134. Well the AC worked GREAT for about 2 days and then the clutch seized and locked up as I was driving down the highway. The compressor got very hot and internal parts of the ac clutch melted. (it smelt awful). Well after removing it, I took it immediately back where it was purchased. They took it apart and said it was a defect in the compressor and gave me another compressor again refurbished. Well I went and reinstalled, vacced, everything all over again, but this time the compressor will not turn on. I even tried jumping the high power sensor on passenger side by the condenser to jump the compressor on. Nothing I could do would get ac compressor to turn on. Now I have checked and double checked everything and i have found that there is no power to the high pressure compressor switch/plug on the back of the compressor itself , there is also no power going to the clutch plug/on the top of the compressor by the pulley. There is power however going to the high pressure switch by the condenser on the passenger side, and there is power going to low pressure switch. I replaced the AC relay under the hood, but it had no effect. I then checked all of the connections of the 4 prong ac relay in the fuse box, and there is power missing to half of the AC relay prongs.

What could cause the AC relay to not get power?\

Also I dont know if this is related but sure for about 6 months the horn would only work intermittently, now it also does not seem to work...not if relay is bad havent replaced/checked yet.


Thank you for any help you can give me!

-Cotton

Go through All Grounds using the reference thread here:https://www.dieselplace.com/forum/63-...d-grounds.html

__________________
1996 K3500 6.5L,( "F" Eng #141 cast block) 5 speed manual, crewcab, dually longbed: 208,000mi.
Diamond Eye 4" Turbo Back Exhaust w/2.5" Flo-Pro Crossover
AirDog II DF165 w/ tank sock delete - XDP
TD-Max boost controller - Kennedy Diesel
OPS extension hose - Leroy Diesel
Glow Plug Harness- PT Wiring Solutions
Glowshift Maxtow EGT,Boost, Fuel gauges
Boost & Fuel Pressure Bolts - Leroy Diesel
2/0 Battery Cable Upgrade - PT Wiring Solutions
PMD w/#9 resistor and Re-Location Kit, mounted to bumper - Leroy Diesel
GM-5 Turbocharger
4.10 gear ratio
OptiLube summer + Formula


Proud member #1039 of The 3500 Dually Club

Online   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Diesel Place : Chevrolet and GMC Diesel Truck Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

PLEASE READ! You must check your email inbox for the confirmation link to complete registration. Please check your spam box if you do not see the email in your inbox.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in


Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fuel problem..need help asap JSmitty53 Duramax First Generation: 2001-2004 (LB7) 19 11-23-2011 03:33 PM
problem..asap SPUDNIK Duramax First Generation: 2001-2004 (LB7) 10 11-22-2009 09:11 PM
fuel problem help asap 02blackchrome Duramax First Generation: 2001-2004 (LB7) 13 02-12-2009 02:12 PM
u0101 problem NEED HELP ASAP capflya Allison OEM 14 01-12-2009 01:43 PM
Help! Tranny problem? ASAP! cmkworm Allison OEM 14 01-29-2007 03:05 PM


All times are GMT -4. The time now is 12:10 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
SEO by vBSEO 3.6.1
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Shoutbox provided by vBShout v6.2.1 (Lite) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
© AutoGuide