Diesel Place : Chevrolet and GMC Diesel Truck Forums

Diesel Place : Chevrolet and GMC Diesel Truck Forums (https://www.dieselplace.com/forum/)
-   Electrical (https://www.dieselplace.com/forum/76-speciality-forums/81-electrical/)
-   -   Alternator overcharging? (https://www.dieselplace.com/forum/76-speciality-forums/81-electrical/765882-alternator-overcharging.html)

07DuramaxLBZ4x4 08-25-2015 08:50 AM

Alternator overcharging?
 
Is it possible for the alt to over charge. I just had to replace the original batteries and someone said overcharging could have made batteries go bad. I checked the charging voltages this morning and it was at 14.7 which does seem high but is it overcharging? I do have a bad number 8 glow plug if that may have something related. The batteries also did have some acid coming from the vents and were pretty hot.

diesail 08-25-2015 09:20 AM

Yes you can overcharge a battery and the symptoms you describe are from overcharging. When you say the batteries where hot and had acid coming from the vents, is that the new batteries or the old? If you have cell that goes bad you will see the same symptoms, but if you see this with the new batteries than they are overcharging.

TiredFarmer 08-25-2015 09:26 AM

You can have the alternator tested. Nowadays the voltage regulator is integrated into them.

07DuramaxLBZ4x4 08-25-2015 09:49 AM

Thank you for the quick response. No this has not happened with the new batteries. The biggest question would be is 14.7 volts overcharging? I have the edge in sight and it monitors system voltage. It usually stays between 14.0 and 14.2 but has spiked to 14.7 for around a minute or so. Again thank you for the quick responses.

diesail 08-25-2015 09:57 AM

It was climbing to 14.7 because it was trying to put a charge into a bad battery. It can go that high right after startup but if it stays there for extended periods there is an issue, in your case it was likely trying to charge a battery with a bad cell.

07DuramaxLBZ4x4 08-25-2015 10:07 AM

Interesting. It was climbing to 14.7 with the new batteries installed. Would it be possible that the number 8 glow plug which is bad is draining one of the batteries? So when I start the truck up it is trying to recharge that battery?


All times are GMT -4. The time now is 08:05 PM.

Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
SEO by vBSEO 3.6.1
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Shoutbox provided by vBShout v6.2.1 (Lite) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
© AutoGuide