Service Trailer Brake System - Diesel Place : Chevrolet and GMC Diesel Truck Forums
 
Home Forum Market Place Garage Tuning Library DTC Tool Register Vendors
Go Back   Diesel Place : Chevrolet and GMC Diesel Truck Forums > Speciality Forums > Electrical
Register FAQ Forum Rules My Replies My Threads Mark Forums Read Advertise

Electrical Discuss anything related to OEM & aftermarket electrical devices including: stereos, speakers, video, batteries, starters, the body control module, lighting, etc.

DieselPlace.com is the premier Duramax Diesel Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools
Old 06-08-2009, 03:54 PM   #1 (permalink)
PJDuramax
Diesel Student
 
PJDuramax's Avatar
 
Join Date: May 2009
Location: YYC
Posts: 41
iTrader Score: 0 reviews

Service Trailer Brake System

I have had this twice now. First time when I hooked up my trailer this message came on. I took to the dealer and they replaced a fuse and relay. I then hooked up again and it worked for a while. Just hooked up again the the same message comes up. I put an electric jack on the front of the trailer and installed a standard batter inside the trailer so it would have enough juice to work the jack. Is there something that might be feeding back to the relay and causing it to blow? I have not taken my truck back to the dealer yet, but would like to get some ideas to see if the battery I put in is causing the problem. I also was reading here that they do not have charging for the extra battery, this will be my next thing to do as it looks simple enough. Any answers would be appreciated.

Offline  
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 06-08-2009, 04:06 PM   #2 (permalink)
Charlie B
Diesel Boss
 
Charlie B's Avatar
 
Join Date: Feb 2006
Location: Northern,Alabama
Posts: 1,224
iTrader Score: 0 reviews

I do not know what year youe truck is but on my 04 there is a wire for charging the battery in the trailer and one for the electric brake. Have you got it wired properly? Also the battery in the trailer should be charged prior to hooking it up to the truck. The truck will maintain a good trailer battery but it will not charge a dead battery without blowing fuses. Charlie

Offline   Reply With Quote Quick reply to this message
Old 06-08-2009, 04:17 PM   #3 (permalink)
PJDuramax
Diesel Student
 
PJDuramax's Avatar
 
Join Date: May 2009
Location: YYC
Posts: 41
iTrader Score: 0 reviews

Charlie, sorry it is a 09 and the truck had the GMC trailer package on it and a new cargo mate trailer. The battery that I put in was also fully charged and new.
Offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 06-08-2009, 04:51 PM   #4 (permalink)
signguy
Diesel Head
 
signguy's Avatar
 
Join Date: Jun 2006
Location: CA & AZ
Posts: 736
iTrader Score: 0 reviews

It has been my experience this message pops up when the electrical plug from the trailer has an intermittent connection in one of the lines-
__________________
2016 LTZ DRW 4x4
Desert Toys, Guns, Horses...

Proud Dually Club Member #563
Offline   Reply With Quote Quick reply to this message
Old 06-08-2009, 07:52 PM   #5 (permalink)
Shasta
Diesel Boss
 
Shasta's Avatar
 
Join Date: May 2007
Location: Colorado, and sometimes New Mexico, Idaho, Tennessee and Washington D.C.
Posts: 1,295
iTrader Score: 0 reviews

And you do have to hook up a wire under the hood if you want to charge your trailer battery through the 7-way.

Go here if you need instructions:

https://www.dieselplace.com/forum/sho...d.php?t=234764

Are you plugging in the trailer with the truck ignition off? You need to do that for the computer to see the trailer properly.

If you are doing that I would agree that you have a connection problem in the 7-way that is causing the message.
__________________
2003 GMC 2500 Ext Cab 4X4. Great truck, should have kept it instead of buying the lemon...

2006 GMC 3500 CC 4X4 Steel Grey, Pewter Leather, Bone Stock - GONE TO LEMON LAND!!

2008 GMC LMM 3500 CC 4X4 Deep Blue Metallic - everything except NAV Thanks GM. (Hope all the ground wires are tight on this one!!) Great truck but time to move up.

2012 Chevrolet LML 3500 CC 4X4 Blue Granite LTZ
Offline   Reply With Quote Quick reply to this message
Old 06-08-2009, 09:03 PM   #6 (permalink)
johnray13
Clutch
 
Join Date: Apr 2009
Location: Chantilly, Virginia
Posts: 74
iTrader Score: 0 reviews

I was getting that message occasionally when it was really raining. I taped the crap outta the splice behind the bumper 7 way and haven't gotten it since.
__________________
2008 LMM Crew cab
Black ext / grey leather int
Duramax / Allison
Firestone Airbags
Offline   Reply With Quote Quick reply to this message
Old 06-09-2009, 09:42 AM   #7 (permalink)
PJDuramax
Diesel Student
 
PJDuramax's Avatar
 
Join Date: May 2009
Location: YYC
Posts: 41
iTrader Score: 0 reviews

I usually have the truck running when I back up and then plug in. I will try plugging it in when turned off. Will the message clear then? Or will I have to take the truck in again?
Thanks for your replies.
Offline   Reply With Quote Quick reply to this message
Old 06-16-2009, 11:06 AM   #8 (permalink)
PJDuramax
Diesel Student
 
PJDuramax's Avatar
 
Join Date: May 2009
Location: YYC
Posts: 41
iTrader Score: 0 reviews

Looks like the fuse was blown. I will replace and see if the message is cleared then. If not then back to the dealer we go.
Offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Diesel Place : Chevrolet and GMC Diesel Truck Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

PLEASE READ! You must check your email inbox for the confirmation link to complete registration. Please check your spam box if you do not see the email in your inbox.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in


Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
abs light and service trailer brake system??? jrmsoccer32 Electrical 6 11-14-2011 09:11 PM
Service Trailer Brake System on DIC WTF?? rcpd34 Electrical 18 02-14-2008 08:22 AM
Service Trailer Brake System Message mark8040 Electrical 9 12-12-2007 11:36 AM
ABS, Brake light and Service trailer brake system lights 01Cummins Fourth Generation Duramax Electronics/Tuners 7 10-01-2007 12:19 AM


All times are GMT -4. The time now is 01:03 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
SEO by vBSEO 3.6.1
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Shoutbox provided by vBShout v6.2.1 (Lite) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
© AutoGuide