charging issues with battery isolator - Diesel Place : Chevrolet and GMC Diesel Truck Forums
 
Home Forum Market Place Garage Tuning Library DTC Tool Register Vendors
Go Back   Diesel Place : Chevrolet and GMC Diesel Truck Forums > Speciality Forums > Medium Duty Trucks
Register FAQ Forum Rules My Replies My Threads Mark Forums Read Advertise

Medium Duty Trucks Discuss GM Kodiak/Topkicks, 4500/5500 & up medium duty engine & all associated components.

DieselPlace.com is the premier Duramax Diesel Forum on the internet. Registered Users do not see the above ads.
Like Tree3Likes
  • 1 Post By batshtcrzy527
  • 2 Post By batshtcrzy527

Reply
 
LinkBack Thread Tools
Old 01-22-2020, 06:12 PM   #1 (permalink)
batshtcrzy527
Diesel Rookie
 
Join Date: Sep 2016
Location: OH
Posts: 35
iTrader Score: 0 reviews

charging issues with battery isolator

The truck is a 05 c5500 with dual alternators and originally 3 batteries. i pulled one battery out and have been going like that for about 2 years now. now the truck is over charging or not charging at all. if i remove the "exictor" wire off of the isolator then i get no charge. not even at the battery terminal on the back of either alternator. with the excitor hooked up i get 22volts and both battery terminals on the isolator and the alternators as well.

what i would like to do would be take the isolator out of the equation completely. i dont need it for what im doing with the truck. i just cant figure out how to do that. what does the excitor do? is it like grounding a field terminal on an old alternator? and why dont the alternators pump out any voltage at all without it hooked up.

the excitor has battery voltage on the wire with the key on engine off.

with the engine on the excitor stays battery voltage while the alternator terminals and both battery terminals on the isolator go to 22 volts.

one alternator is brand new and the other was bench tested and passed.

i cant seem to find the answers anywhere and im out of ideas of what to test and how to test it.

if ive forgotten anything ive tried i will add it to the list. or if anyone has any other ideas then i will test it and let you know the results

thanks in advance

__________________
2005 c5500 with the dual alternator package
Offline  
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 01-23-2020, 12:53 PM   #2 (permalink)
Ron Nielson
Diesel Pro
 
Ron Nielson's Avatar
 
Join Date: Aug 2009
Location: Berryton, KS
Posts: 2,402
iTrader Score: 0 reviews

I'll start by saying I don't know THE ANSWER to your problem, but I have a suggestion as to how you might find the answer.

Start by removing 2 of the 3 batteries from the electrical circuitry, leaving just one in the circuit and see if this appears to be normal and what you would expect. if so, then remove that battery and attach a different battery and test again. Then see if you're ok with just this battery. If so, try the third and do the same testing. If all OK, hook up 2 of the batteries and see if ok, then try another pair, then the 3rd pair. Somewhere along the way you will find the condition that identifies your problem. The fact that you have 22 volts on your system sounds like there is some conditiion that causes the batteries to be in series (pos to neg), not parallel (pos to pos, neg to neg), but I would also be suspect of the isolator.

__________________
Ron Nielson

2008 2500HD LT CCLB/Ally. Line-X, B&W Companion, MaxLoader Springs, Edge Insight CTS, Kennedy Custom ECM
2009 Arctic Fox 5er, Silver Fox Edition 29-5T, 3.6 Onan LPG, SteadyFast Stabilizers
Offline   Reply With Quote Quick reply to this message
Old 01-23-2020, 08:07 PM   #3 (permalink)
batshtcrzy527
Diesel Rookie
 
Join Date: Sep 2016
Location: OH
Posts: 35
iTrader Score: 0 reviews

no change by dropping one battery. i dont actually have the batteries charging right now. i took the connections from the isolator to the batterys off and just measure voltage at the isolator.

what controls the excitor on the isolator? with battery voltage to it with the key on engine off i would expect the ecm controls it.

ive had issues with the charging system on this truck since the day i bought it and thats why ive only been running 2 batteries. just put a band aid fix on it and got by till now.

ive had other battery isolator that dont have an excitor terminal. what the the excitor even do? i would be a lot more confident in fixing this if i fully understood how this isolator system works
__________________
2005 c5500 with the dual alternator package
Offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 01-24-2020, 05:16 AM   #4 (permalink)
SLOWPOKE96Z28
Clutch
 
Join Date: Jan 2006
Location: DFW, tx
Posts: 53
iTrader Score: 0 reviews
Send a message via AIM to SLOWPOKE96Z28 Send a message via Yahoo to SLOWPOKE96Z28

With 22 volts, it sounds like the isolator is shorted internally somehow. Whether the exciter terminal on an isolator is used or not used (or even present) depends on the alternator’s wiring. Here I THINK it’s meant to make sure the ECM energizes the alternators’ L terminals when the key is in the run position and shuts them off in any other position since modern GM alternators can’t directly sense B+ voltage because of the diodes in the isolator. That isolator can be had for under $200

Last edited by SLOWPOKE96Z28; 01-24-2020 at 05:17 AM.
Offline   Reply With Quote Quick reply to this message
Old 01-24-2020, 07:57 AM   #5 (permalink)
ronjhall
Diesel Champ
 
ronjhall's Avatar
 
Join Date: Aug 2006
Location: South East MI
Posts: 1,946
iTrader Score: 0 reviews

I am not a expert on alternators. But it is my understanding that the main alternator is always working. When it cannot keep up with charge (low voltage) requirements PCM starts the second alternator. The isolator would be for third battery. Since you have removed 3rd battery. Isolator should not be needed. I prefer a electrical/solenoid type isolator. It does not use any voltage when shut off. Diode type isolators use some current all the time. Hope this helps.
__________________
2004 C5500 Kodiak LLY. Gulf Stream Endura 25,000lbs with car, EGR Blocker & stick. PVC reroute. No programmer, Bilstien shocks, Ride Rite air Bags, Train horns, Filter minder, ISSPRO trans temp gauge, VDO EGT gauge, TST tire pressure monitor, Scangauge II, MBRP muffler, Modified turbo MP.
Avg mileage over 76k miles 10.3 mpg. Sold it 5/17.
Offline   Reply With Quote Quick reply to this message
Old 01-25-2020, 03:26 PM   #6 (permalink)
batshtcrzy527
Diesel Rookie
 
Join Date: Sep 2016
Location: OH
Posts: 35
iTrader Score: 0 reviews

i got it figured out. with the key on i would be getting voltage at the excitor and all 3 terminals on the isolator. so having voltage at the alternator wire had me thinking backwards. i thought i was getting voltage from the wire but the it was coming from the excitor terminal. removing the excitor and testing the isolator showed me otherwise.

i simply left the excitor off and ran the alternator cable to the battery positive and now im seeing 14.7 volts everywhere. which was my original plan before i was seeing voltage at places i didnt think there should be without the engine running. its my understanding that 14 volts in normal on these trucks instead of the 13.6 that im used to.

everyone here really helped me hash this out and i cant thank you guys enough for that.

just goes to show how thinking too hard can really slow you down sometimes. thanks
__________________
2005 c5500 with the dual alternator package
Offline   Reply With Quote Quick reply to this message
Old 01-25-2020, 06:37 PM   #7 (permalink)
SLOWPOKE96Z28
Clutch
 
Join Date: Jan 2006
Location: DFW, tx
Posts: 53
iTrader Score: 0 reviews
Send a message via AIM to SLOWPOKE96Z28 Send a message via Yahoo to SLOWPOKE96Z28

No more 20+ volts anywhere? That’s good. A regular “12 volt” charging system imo and experience is alright as long as it’s 13 to 15.5 volts.
Offline   Reply With Quote Quick reply to this message
Old 01-26-2020, 03:07 AM   #8 (permalink)
batshtcrzy527
Diesel Rookie
 
Join Date: Sep 2016
Location: OH
Posts: 35
iTrader Score: 0 reviews

i am very familiar with the 5.9 VP44 cummins trucks. ive delt with them since i was a teenager. that put together with all the car knowledge ive built up until now, ive always known that 13.6 is charging voltage. 12.6 is standing voltage. this truck is my first and last duramax truck. i dont plan on getting rid of this truck because i have trailers that are too heavy for a truck that isnt rated to pull a 30k+ trailer. For the 3 years ive owned this truck, in all honesty, it has been a complete nightmare. this forum has been a big reason that i have not sold it already.

most of the forums that ive been on have told me that im a dumbass for not being able to find the answers to my question with the search tool. On this forum ive always felt as if the people are really here to help even if the search tool as no answers to behold. i try really hard to not ask questions that are not answered by a search.

i am no newbie to how vehicles work, but i still have a lot to learn. i know my way around a vortec or LS motor, as well as a cummins in a pickup or a semi. The duramax trucks are a completely different story however.

the people here have been nothing but a huge help to me. wether they can answer my question exactly or not. the knowledge that i have found here has countless times helped me work out an issure that i have not known enough about to sort out on my own.

i cannot thank everyone enough, and i continue to thank you for all the advice everyone will grant me in the future as i deal with this truck. thank you everyone for all the advice. present and future.
__________________
2005 c5500 with the dual alternator package
Offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Diesel Place : Chevrolet and GMC Diesel Truck Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

PLEASE READ! You must check your email inbox for the confirmation link to complete registration. Please check your spam box if you do not see the email in your inbox.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in


Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 09:03 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
SEO by vBSEO 3.6.1
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
Shoutbox provided by vBShout v6.2.1 (Lite) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
© AutoGuide