LMM ITBC Problem - Diesel Place : Chevrolet and GMC Diesel Truck Forums
 
Home Forum Market Place Garage Tuning Library DTC Tool Register Vendors
Go Back   Diesel Place : Chevrolet and GMC Diesel Truck Forums > Speciality Forums > Towing
Register FAQ Forum Rules My Replies My Threads Advertise

Towing Discuss Anything Related To Towing With Your Diesel. Any RV-specific discussions belong here.


DieselPlace.com is the premier Duramax Diesel Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools
Old 04-13-2010, 10:26 PM   #1 (permalink)
Sharks
High Compression
 
Join Date: Dec 2009
Location: Longview, WA
Posts: 26
iTrader Score: 0 reviews

LMM ITBC Problem

I need some help guys..... Ok I have done a exhausting search of this topic but I still need a little help. I have the truck in my sig below. I only have 10000 miles and for the first time hooked up my travel trailer. Everything worked perfectly. After I unhooked the trailer I got a service trailer brake system on my DIC. No other lights. My brakes work fine and no ABS light. I have tried cleaning my plug connectors, including the fifth wheel plug. I found the brake controller box up on the frame behind the rear wheel on the driver side. I disconnected it and blew with a air compressor. I still get my message on DIC. I have read about a ground issue but couldn't find anything on the forum where the ground connector is located to check to see if this is the problem.

I also tried to hook back up my trailer to see if this would clear it. Now my trailer works (lights and brake and turn signals) but my brakes won't work. I get a trailer connected but no brakes. Is there something I can do to fix it, as I do have mods on my truck and I don't want to fight the dealer about oversize tires make the service trailer brake light come on, especially since the truck has been lifted almost 3 years ago when bought new. Thanks for any help you van provide.

__________________
2008 Silverado CC/SB LTZ 6.6L DMAX. 4" MBRP TB SS exhaust w/5" tip. Edge Evolution Race. Transgo Jr. Banks Cold Air Kit. 6" Pro Comp Lift. 35x12.50x20 Pro Comp T/A. PCV Reroute. Resonator Plugged. Painted to Match - Bushwacker Pocket Flare/Vent Visors/Factory GM Fibreglass Hard Tonneau Cover/Bug Shield/door handles & tailgate handle. T-Rex Billet Grill.
Offline  
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 04-13-2010, 10:47 PM   #2 (permalink)
dur0maxx
Diesel Apprentice
 
Join Date: Sep 2007
Location: Escondido, CA
Posts: 320
iTrader Score: 0 reviews

Armed Forces Club Member

I have the same problem. I hve searched and searched but you are the first to post the exact thing mine is doing. I am trying to get off work tomorrow so I can take it to the dealer.

__________________
2007.5 Chevy K2500 LMM Crew Cab: Nick's DSP5 Tune, EGR Blocked, Edge Insight Monitor, AFE 4" Turbo Back, PPE AirboxMod, MB Gunner 8's Plasti-Dipped, 295/65R20 Nitto Trail Grapplers, 4.5" BDS Lift, Deaver 4" Leafs, Fox 2.0 Aluminum Shocks, 4.56 Gears, Wireless Air System, Line-X, Tinted Tails and 3rd Brake Light, Tonneau Cover
Offline   Reply With Quote Quick reply to this message
Old 04-14-2010, 12:49 PM   #3 (permalink)
trailwhale
Diesel Boss
 
trailwhale's Avatar
 
Join Date: Jul 2006
Location: Puget Sound
Posts: 1,112
iTrader Score: 0 reviews

Try this list of threads

search Keyword was "ITBC"
search member was "heymcall"

In this list there are instruction on how to test the ITBC -Heymcall might chime in and point you to the specific threads

https://www.dieselplace.com/forum/sea...archid=8648916
__________________
2006 DA LBZ EC SB 4WD
LT1 Granite Blue Metallic
Nictane Fuel Filter - clean fuel = priceless
LT265/75R16 Michelin AT2
GM PS Cooler with Redline D4 ATF Fluid
Pullrite 18K Superglide Hitch
2008 Rage'N FA 3005 Toyhauler
Member #6 "Oil is Oil" Association
Life is like a coin. Once spent it is gone. Spend it wisely.
Full Throttle solves the problem or ends the suspense.
Offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 04-14-2010, 11:12 PM   #4 (permalink)
dur0maxx
Diesel Apprentice
 
Join Date: Sep 2007
Location: Escondido, CA
Posts: 320
iTrader Score: 0 reviews

Armed Forces Club Member

Dealer looked at mine today, said it was the pressure sensor or something that reads hydraulic pressure from the master cylinder. I'll know more tomorrow when I pick it up and have the parts list in front of me.
__________________
2007.5 Chevy K2500 LMM Crew Cab: Nick's DSP5 Tune, EGR Blocked, Edge Insight Monitor, AFE 4" Turbo Back, PPE AirboxMod, MB Gunner 8's Plasti-Dipped, 295/65R20 Nitto Trail Grapplers, 4.5" BDS Lift, Deaver 4" Leafs, Fox 2.0 Aluminum Shocks, 4.56 Gears, Wireless Air System, Line-X, Tinted Tails and 3rd Brake Light, Tonneau Cover
Offline   Reply With Quote Quick reply to this message
Old 04-16-2010, 11:38 PM   #5 (permalink)
Sharks
High Compression
 
Join Date: Dec 2009
Location: Longview, WA
Posts: 26
iTrader Score: 0 reviews

[QUOTE=dur0maxx;3812429]Dealer looked at mine today, said it was the pressure sensor or something that reads hydraulic pressure from the master cylinder. I'll know more tomorrow when I pick it up and have the parts list in front of me.[/QUOTE


Took mime to the dealer today. I couldn't find the problem myself. It was the same thing..... The pressure switch on the hydroboost. It's fix for now.....
__________________
2008 Silverado CC/SB LTZ 6.6L DMAX. 4" MBRP TB SS exhaust w/5" tip. Edge Evolution Race. Transgo Jr. Banks Cold Air Kit. 6" Pro Comp Lift. 35x12.50x20 Pro Comp T/A. PCV Reroute. Resonator Plugged. Painted to Match - Bushwacker Pocket Flare/Vent Visors/Factory GM Fibreglass Hard Tonneau Cover/Bug Shield/door handles & tailgate handle. T-Rex Billet Grill.
Offline   Reply With Quote Quick reply to this message
Old 04-18-2010, 07:13 PM   #6 (permalink)
WellShooter
Diesel Fanatic
 
WellShooter's Avatar
 
Join Date: Jun 2008
Location: Carlsbad, NM
Posts: 101
iTrader Score: 0 reviews

I had that happen once, but it went away on it's own. Nice to know what is the cause. BTW the link above doesn't work.
__________________
2008 2500 HD D/A CC, SB, DPF deleted, ATTA tank, B&W companion, Firestone AB, Scangauge II, pulling 2008 Keystone Challenger, GCVW 20,104+
Offline   Reply With Quote Quick reply to this message
Old 04-20-2010, 12:08 AM   #7 (permalink)
txdutt
Diesel Head
 
txdutt's Avatar
 
Join Date: Mar 2006
Location: Parker CO
Posts: 593
iTrader Score: 0 reviews

I've noticed on mine if the truck is running and you:

-plug the trailer in, all the trailer lights will work but the brakes won't activate
-unplug the trailer, I'll get the service trailer brakes message on the DIC

I make sure to turn the truck off now whether connecting or disconnecting my TT..
__________________
2007.5 Silverado 2500HD LTZ SB CC 4wd-6.0 LY6
Blue Granite w/Ebony Leather
Factory Navig/DVD/IBC/Fumoto Drain Valve
Line-X Bedliner/Bullydog Triple Dog Tune
VR3 b-up camera/Lund Genesis Tri-Fold Tonneau
2007 Jayco Eagle 328RLS Trvl Trlr 9200 GVW
2009 Jeep Wrangler Sahara Unlimited 4 Door

SOLD-2005 Silverado 2500HD LT CC LLY

U.S. Navy 1978-1986
Offline   Reply With Quote Quick reply to this message
Old 06-22-2010, 12:22 PM   #8 (permalink)
deminimis
Glow Plug
 
deminimis's Avatar
 
Join Date: Nov 2009
Location: Orygun
Posts: 214
iTrader Score: 0 reviews

Same problem here. Service Trailer Brake message. Lights work (slide in and trailer) but no trailer brakes. Sooo, does anyone have the part number for the pressure switch? Thanks!
__________________
2019 3500 LTZ Z71 4x4 SRW Longbed


2018 Toyota Tacoma TRD Pro (FOR SALE)


1978 Super Beetle Champagne Ed II (Resto In Progress)
Offline   Reply With Quote Quick reply to this message
Old 06-30-2010, 04:18 PM   #9 (permalink)
deminimis
Glow Plug
 
deminimis's Avatar
 
Join Date: Nov 2009
Location: Orygun
Posts: 214
iTrader Score: 0 reviews

Actually, I doubt my problem is the brake pressure switch as I get the Service Trailer Brake message when I turn on the ignition (even if I don't actually crank the engine). Tried to see if I threw any codes using my cheapy ODB2 reader, but no codes visible. My guess is its the actual module. That's a $400 part from my local dealer. Other than disconnecting it and going with an aftermarket unit, or spending that kind of $ on a factory unit, any thoughts? All fuses are good. The above link regarding testing the system does not work. Thanks!
__________________
2019 3500 LTZ Z71 4x4 SRW Longbed


2018 Toyota Tacoma TRD Pro (FOR SALE)


1978 Super Beetle Champagne Ed II (Resto In Progress)
Offline   Reply With Quote Quick reply to this message
Old 07-20-2010, 03:33 PM   #10 (permalink)
deminimis
Glow Plug
 
deminimis's Avatar
 
Join Date: Nov 2009
Location: Orygun
Posts: 214
iTrader Score: 0 reviews

Well, regardless, the brake pressure sensor part number is 15838718 in case anyone needs it.

__________________
2019 3500 LTZ Z71 4x4 SRW Longbed


2018 Toyota Tacoma TRD Pro (FOR SALE)


1978 Super Beetle Champagne Ed II (Resto In Progress)
Offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Diesel Place : Chevrolet and GMC Diesel Truck Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

PLEASE READ! You must check your email inbox for the confirmation link to complete registration. Please check your spam box if you do not see the email in your inbox.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in



Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Itbc Gmax84 Towing 1 02-21-2011 06:55 PM
Itbc RINGNEKS Towing 3 02-01-2011 12:23 AM
Itbc batmobile New Vehicle Information 5 06-25-2010 07:18 PM
ITBC not working? Chevrolet3500TY Electrical 19 05-28-2010 05:43 PM
Help Itbc wfocattle Towing 4 01-24-2010 03:47 PM


All times are GMT -4. The time now is 07:51 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
SEO by vBSEO 3.6.1
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Shoutbox provided by vBShout v6.2.1 (Lite) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
© AutoGuide