LBZ: Service Brake System Warning - Diesel Place : Chevrolet and GMC Diesel Truck Forums
 
Home Forum Market Place Garage Tuning Library DTC Tool Register Vendors
Go Back   Diesel Place : Chevrolet and GMC Diesel Truck Forums > Speciality Forums > Drivetrain - 2001 - 2010
Register FAQ Forum Rules My Replies My Threads Mark Forums Read Advertise

Drivetrain - 2001 - 2010 Discuss front and rear axle, transfer case, brakes, etc. Transmission questions belong in the appropriate transmission forum below. First through fourth generation...

DieselPlace.com is the premier Duramax Diesel Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools
Old 03-11-2012, 03:10 PM   #1 (permalink)
BigLBZPower08
Diesel Apprentice
 
Join Date: Jul 2006
Posts: 309
iTrader Score: 0 reviews

Service Brake System Warning

Hey all,

So the other day while driving my truck I all of the sudden got a "Service Brake System" warning on my DIC and just the parking brake light came on. For the rest of the day it would go on and off while driving but now it is staying on constantly and turning the truck on and off does not make it go away. I searched the forum a bit and I have checked the ground under the drivers door and after cleaning that and reinstalling it the light still stays on. I still do not have any ABS light on and I scanned the computer and there is no code coming up either. I know that the other thing to check is the front wheel bearings and the ABS sensor but the truck only has 84,000 miles on it and from what I can tell that is kind of early to replace the front wheel bearings.

Can anyone else think of something that I should look at checking before I buy new wheel bearings and replace them?

Thank you,

__________________
2007 Duramax Crew Cab
6 Speed Allison
4x4
Black
S&B Dry Filter Intake
MBRP 5 inch straight Pipe
AFE Intercooler Tube
Retro-Solutions 55w HID Low Beams 5000K
Alpine INA-W909 Head Unit
Offline  
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 03-12-2012, 01:27 AM   #2 (permalink)
BigLBZPower08
Diesel Apprentice
 
Join Date: Jul 2006
Posts: 309
iTrader Score: 0 reviews

Anybody have any ideas?

__________________
2007 Duramax Crew Cab
6 Speed Allison
4x4
Black
S&B Dry Filter Intake
MBRP 5 inch straight Pipe
AFE Intercooler Tube
Retro-Solutions 55w HID Low Beams 5000K
Alpine INA-W909 Head Unit
Offline   Reply With Quote Quick reply to this message
Old 03-14-2012, 06:45 PM   #3 (permalink)
faster01nu
Heat Sink
 
Join Date: Jul 2011
Location: Wyoming
Posts: 13
iTrader Score: 0 reviews

was it wet out when the light came on?? I replaced front wheel bearings at about 90K...
__________________
2006 Chevy 2500HD 6.6L Duramax LBZ, Cold Air Intake, MBRP 4" turbo back, PPE Xcelerator Programmer running 190HP 240TQ program, Auto Meter Boost and Pyrometer.
Offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 03-14-2012, 09:28 PM   #4 (permalink)
sparky1562
Diesel Champ
 
sparky1562's Avatar
 
Join Date: Feb 2007
Location: Arrington, TN
Posts: 1,812
iTrader Score: 0 reviews

Wheel bearings can go out early. Replaced driver at 78K, replaced it again at 115K. The last time the play in the bearing caused the brake light to come on.
__________________
Herb
2003 GMC 2500HD Crew 4WD 117 K miles
4" Turbo Back Magnaflow
MKW M26 Wheels BFG 265/70R-17/E
Fold-a-cover, trailer brakes, B&W Turn Over Ball
New Injectors at 83,670, ISSPRO Pyro and Boost Pillar mount. PPE Boost Valve. PPE Excellerator.
Cognito pitman and ilder arm brace. Bilstein Shocks at 100K.
Offline   Reply With Quote Quick reply to this message
Old 09-25-2012, 11:31 AM   #5 (permalink)
Kingston
Diesel Apprentice
 
Kingston's Avatar
 
Join Date: Dec 2007
Posts: 374
iTrader Score: 0 reviews

What ended up being the problem? I Have all three lights on presently!
__________________
2016 Silverado 2500HD 4x4, High Country, CC SB, LEER 100XQ w/ LEER Locker, Decked, Michelin Defender LTX M/S 265/60-R20E


2007 Sierra Classic 2500HD 4x4, SLT CC LB SR, Silver Birch Metallic, LBZ/Allison, Michelin LTX M/S2 265/75-R16 on PYOs, CURT XD Class V Rear Hitch, B&W Turnover Ball Gooseneck Hitch, Tekonsha Prodigy, Trippin in Yukon Sun Roof console, Z-Series Auto Meter Gauges, MBRP 4" TB, PPE Boost Controller, PPE Hot+2, PPE ABM, Blocked, Resonator Plugged, AirDog 150, Bilsteins, Sulastics, Cognito PM & IA Braces, Cognito HD tierods, Frederico F & R Sway Bars, 3500HD DRW second stage leaf spring packs and frame stops.
Offline   Reply With Quote Quick reply to this message
Old 09-25-2012, 01:54 PM   #6 (permalink)
heymccall
Diesel Elite
 
heymccall's Avatar
 
Join Date: Feb 2005
Location: Butler county, PA USA
Posts: 17,745
iTrader Score: 0 reviews

If the lights come on at startup, clean the ground on the frame under the driver's feet. The unit (EBCM- Electronic Brake Control Module) is failing it's self test. Poor ground connections cause low voltage resulting in a failed self test. A broken circuit will also fail the self test, but, the lights would, most likely, never , ever turn off.

If the lamps come on in motion (usually over 20mph), a bearing is failing. If the speedometer is accurate (consistent) and the transmission shifts correctly, one of the front wheel hub unit bearings is failing. It will be sloppy (wobbly) when jacked off the ground. If the speedo or shifting is erratic, then the transfer case mainshaft bearing has failed, most likely due to NO oil in the transfer case.
__________________
Brian
'13 Hyundai Genesis Coupe handshaker
'14 Peterbilt 337 handshaker
Quote:
Originally Posted by GetSome8.1HD
Its not like I said I enjoyed reading Good Housekeeping while taking a candle lit bubble bath then proceeding to using a loofah with exfoliating creams all while thinking about you . Now THAT would be creepy
Member #21 of the OiO association
Offline   Reply With Quote Quick reply to this message
Old 09-25-2012, 02:27 PM   #7 (permalink)
sheepdog42
Diesel Fanatic
 
sheepdog42's Avatar
 
Join Date: Nov 2008
Posts: 126
iTrader Score: 0 reviews

Mine came on and was staying on. Checked my brake fluid and it was low filled it up and it went off and hasn't came back on.
__________________
2008 LMM GMC 4x4 SLT
EFI Live, 5" MBRP turbo back, Air Box Mod, 6" lift, 37" Toyo Open Country M/Ts, 22" Rockstars, Fab Fours front bumper, 6000k HIDs,
Offline   Reply With Quote Quick reply to this message
Old 12-28-2012, 05:16 AM   #8 (permalink)
rage793
Freeze Plug
 
Join Date: Mar 2012
Posts: 21
iTrader Score: 0 reviews

Quote:
Originally Posted by heymccall View Post
If the lights come on at startup, clean the ground on the frame under the driver's feet. The unit (EBCM- Electronic Brake Control Module) is failing it's self test. Poor ground connections cause low voltage resulting in a failed self test. A broken circuit will also fail the self test, but, the lights would, most likely, never , ever turn off.

If the lamps come on in motion (usually over 20mph), a bearing is failing. If the speedometer is accurate (consistent) and the transmission shifts correctly, one of the front wheel hub unit bearings is failing. It will be sloppy (wobbly) when jacked off the ground. If the speedo or shifting is erratic, then the transfer case mainshaft bearing has failed, most likely due to NO oil in the transfer case.
Mine comes on at sustained freeway speed. It does not come on will driving around town. Speedo works properly and I just changed out front wheel bearings less than 10k ago. Any thoughts? Also have an airbag light on but have yet to figure out what section I should be looking for answers for that.
Offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Diesel Place : Chevrolet and GMC Diesel Truck Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

PLEASE READ! You must check your email inbox for the confirmation link to complete registration. Please check your spam box if you do not see the email in your inbox.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in


Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Service brake system warning. Dmckinley Drivetrain - 2001 - 2010 4 11-20-2011 03:09 PM
Service brake system warning coming on Kdmann64 Drivetrain - 2001 - 2010 16 01-23-2010 11:06 PM
Got ball joints replaced now I'm getting SERVICE BRAKE SYSTEM warning Kdmann64 Drivetrain - 2001 - 2010 3 01-04-2010 08:44 PM
Still get Service Brake System warning timowen1 Duramax Third Generation: 2006-2007.5 (LBZ & LLY) 0 09-29-2006 07:19 PM
Service Brake System Warning! Timberwolf530 Duramax First Generation: 2001-2004 (LB7) 8 12-19-2005 10:13 AM


All times are GMT -4. The time now is 03:26 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
SEO by vBSEO 3.6.1
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Shoutbox provided by vBShout v6.2.1 (Lite) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
© AutoGuide