Diesel Place : Chevrolet and GMC Diesel Truck Forums

Diesel Place : Chevrolet and GMC Diesel Truck Forums (https://www.dieselplace.com/forum/)
-   Duramax Fifth Generation: 2011-2016 (LML) (https://www.dieselplace.com/forum/63-gm-diesel-engines/365-duramax-fifth-generation-2011-2016-lml/)
-   -   LML: p0234 p2263 p2599 towing up hill (https://www.dieselplace.com/forum/63-gm-diesel-engines/365-duramax-fifth-generation-2011-2016-lml/904225-p0234-p2263-p2599-towing-up-hill.html)

johngeorge 04-14-2017 01:21 PM

p0234 p2263 p2599 towing up hill
 
Hi all,

I got P0234, P2263, P2599 when towing my 5th wheel up a hill on the highway, went into limp mode just as I am passing a big rig, ended up pulling over and resetting code and fixed issue. Trying to figure out how to fix this, it only happens when fully loaded trailer is getting towed up a long incline at highway speeds, so cant easily reproduce it.

Any ideas?

I've already replaced the turbo vane position sensor thinking that would fix it, but no deal, issue still happening.

p0234 engine overboost
p2263 turbocharger boost system performance
p2599 turbocharger boost control position sensor A performance stuck high

johngeorge 04-14-2017 01:27 PM

could it be the VGT control solenoid?

CntrlCalDmax 04-14-2017 03:45 PM

P0234 - Turbocharger Engine Overboost
-Test the charge air cooler for leaks.
-Inspect the turbocharger oil supply tube for restrictions.
-Inspect the turbocharger and turbocharger ducts for debris, sticking vanes, worn impeller and turbine blades or damage.
-If the induction system, charge air cooler system, the turbocharger and the turbocharger oil supply test normal, replace the B74 MAP sensor.

P2263 - Turbocharger Boost System Performance
-Inspect the turbocharger oil supply tube for restrictions.
-Inspect the turbocharger and turbocharger ducts for debris, sticking vanes, worn impeller and turbine blades or damage.
-If the induction system, charge air cooler system, the turbocharger and the turbocharger oil supply test normal, replace the B74 MAP sensor.

P2599 - Turbocharger Boost Control Position Performance - High Position
-Inspect the turbocharger for debris, sticking vanes, or damage.
-Inspect the Q41 turbocharger vane position control solenoid valve and B112 turbocharger Vane Position Sensor for damage or sticking.

CntrlCalDmax 04-14-2017 03:49 PM

How about creating a garage with pictures of the FFR Coupe. Would love to see some shots.

redwngr 04-14-2017 04:11 PM

Has it been checked for boost leaks?

johngeorge 04-19-2017 02:09 PM

Quote:

Originally Posted by CntrlCalDmax (Post 9052945)
How about creating a garage with pictures of the FFR Coupe. Would love to see some shots.

There are a ton of pics on my website from its first track day outing racing / 2017 VIR March 24-26, 2017 | FFR#48 John George Racing

enjoy

johngeorge 04-19-2017 02:11 PM

Quote:

Originally Posted by redwngr (Post 9052969)
Has it been checked for boost leaks?

Ill look tonight. I dont remember hearing any leaks.

nayther 04-26-2017 07:16 PM

These were the same codes I was getting on my 2011 that Chevy lemoned. Do a search for my screen name or "overboost". I believe the final diagnosis was a bad turbo but they screwed around with it so much not authorizing the correct fix that it went into "lemon" territory. I believe the guide vanes were sticking. But the symptoms were exactly as you describe, uphill while pulling and then passing a big rig.

jamilbk 05-02-2017 03:25 PM

I had the exact same codes on my 2015 last year during the exact same conditions: towing uphill when passing bigrigs. Had it at WOT for probably a minute or two to maintain 65 while towing a 13k brick. I scanned and cleared the codes then took it to dealer. They wouldn't troubleshoot anything unless the codes were actively in the computer. Sigh.

A few months later I noticed my downpipe was leaking pretty bad and doing the whole white smoke during regen so I got that fixed.

Not sure if those are related but issue hasn't come back. At 72k miles now so I'd hate for turbo to completely go out outside of warranty...

herbike 05-08-2017 11:51 PM

I am not getting any codes according to the dealer. Just won't pull like it did a month ago. 6 to 7 percent grade, pulled 20K gross with ease, now won't pull over 56 MPH. No explanation from the dealer. They cleaned the MAS sensor, that seems to help the mileage when I'm not pulling but drops off mileage and power when pull, don't know where to take it from here.


All times are GMT -4. The time now is 12:10 AM.

Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
SEO by vBSEO 3.6.1
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Shoutbox provided by vBShout v6.2.1 (Lite) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
© AutoGuide