Question: Leroys lift pump harness - Page 2 - Diesel Place : Chevrolet and GMC Diesel Truck Forums
 
Home Forum Market Place Garage Tuning Library DTC Tool Register Vendors
Go Back   Diesel Place : Chevrolet and GMC Diesel Truck Forums > GM Diesel Engines > 6.5L Diesel Engine
Register FAQ Forum Rules My Replies My Threads Mark Forums Read Advertise

6.5L Diesel Engine Discuss the 6.5 GM diesel engine & associated components. Automatic transmission questions & problems belong in the 4L80/85 - 4L60E - 6L90 Transmission Forum

DieselPlace.com is the premier Duramax Diesel Forum on the internet. Registered Users do not see the above ads.
Like Tree3Likes

Reply
 
LinkBack Thread Tools
Old Yesterday, 08:51 PM   #11 (permalink)
sctrailrider
Diesel Pro
 
sctrailrider's Avatar
 
Join Date: Dec 2010
Location: SC
Posts: 2,487
iTrader Score: 0 reviews

Old School Oil Burners (Old SOBs) Member

have you talked to leroy about this?

__________________
1993 K3500

owner Twisted Steel Performance
Head Porting, Ceramic coating

like us on Facebook




Online   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old Yesterday, 10:28 PM   #12 (permalink)
kellyc6903
Low Boost
 
Join Date: Apr 2019
Posts: 7
iTrader Score: 0 reviews

Yes, he said it sounds like a fuse or relay problem. I checked the fuse in his harness and it's good, checked the fuse on the firewall, good also. Not sure there is a relay in original lift pump harness??

__________________
1992 6.5L
Online   Reply With Quote Quick reply to this message
Old Today, 09:43 AM   #13 (permalink)
JMJNet
Diesel Legend
 
JMJNet's Avatar
 
Join Date: Feb 2006
Location: Richardson, TX
Posts: 17,178
iTrader Score: 0 reviews

The Suburban Club Member

Is it an electrical or mechanical LP? Just making sure.
Did you try to reverse the connector?
__________________
1995 GMC Suburban:
PMD in Bumper
Leroy Diesel Flight System PMD
Leroy Diesel Oil Cooler Line
4" Warpspeed Exhaust
Kennedy Diesel LP/OPS Harness
Bosch Duraterm GP
Heath Turbo-Master
AD244 Alternator

Last edited by JMJNet; Today at 09:43 AM.
Offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old Today, 09:24 PM   #14 (permalink)
kellyc6903
Low Boost
 
Join Date: Apr 2019
Posts: 7
iTrader Score: 0 reviews

Rechecked fuse on firewall, it was good but noticed the fuse was very loose in the holder. I replaced the holder and fuse and that did the trick! Lift pump now runs as it should.(thanks Glagulator for the tip) thanks to all for their ideas.
__________________
1992 6.5L
Online   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Diesel Place : Chevrolet and GMC Diesel Truck Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

PLEASE READ! You must check your email inbox for the confirmation link to complete registration. Please check your spam box if you do not see the email in your inbox.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in


Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 09:33 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
SEO by vBSEO 3.6.1
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Shoutbox provided by vBShout v6.2.1 (Lite) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
© AutoGuide