About Ready to Burn It.... - Diesel Place : Chevrolet and GMC Diesel Truck Forums
 
Home Forum Market Place Garage Tuning Library DTC Tool Register Vendors
Go Back   Diesel Place : Chevrolet and GMC Diesel Truck Forums > GM Diesel Engines > 6.5L Diesel Engine
Register FAQ Forum Rules My Replies My Threads Mark Forums Read Advertise

6.5L Diesel Engine Discuss the 6.5 GM diesel engine & associated components. Automatic transmission questions & problems belong in the 4L80/85 - 4L60E - 6L90 Transmission Forum

DieselPlace.com is the premier Duramax Diesel Forum on the internet. Registered Users do not see the above ads.
Like Tree16Likes

Reply
 
LinkBack Thread Tools
Old 07-25-2019, 01:44 PM   #1 (permalink)
jabon056
Diesel Student
 
Join Date: Aug 2009
Posts: 40
iTrader Score: 0 reviews

About Ready to Burn It....

1. Describe the problem you are having in detail: Rebuilt motor, would not run, hard starting. Had IP and injectors rebuilt, ran great for about 400 miles, then just stopped, changed PMD still no start. After sitting for a little while would start run fine for about 2 minutes then die, no stutter, just stop, wait a little while same thing. Changed IP and injectors again, extremely hard starting, only run at high idle and smoke bad, whitish grey at idle and coal black under acceleration, smoke acidic enough to burn eyes. Changed fuel sock and cleared restriction in return, would still smoke light grey haze at idle (actually idled) coal black under acceleration, very acidic smell. Was able to time motor 3.4 and tdco -.88, idle speed 618 rpm. And NOW back to the same hard start, no idle, heavy smoke.
2. Year of truck/engine. Truck 1994 Motor 2004
3. Odometer reading (indicate miles or kilometers). 190,000 miles
4. Indicate the model number on the Injection pump (starts DS4 or DB2......). DS4 5521
5. Indicate if you know if its a 1500, 2500, 2500HD, 3500, 3500HD. C3500
6. Do you have an EGR on the engine? (An F or an S engine code 8th VIN digit) No it's a "F"
7. Air Filter condition (visual check). new
8. Fuel filter condition (freshly changed, mileage since changed). 400 miles
9. Location of PMD/FSD? (ex. on pump/remote over intake, behind bumper). front bumper
9a. If remote mounted, describe wiring harness (homemade or purchased from which vendor). several new purchased
9b. Indicate the location and condition of the FSD/IP grounding wire. New located on pump
10. Outside Temperature (C or F). __90f___

11. Service Engine Light while running?- on/off/intermittent none
11a. Service Engine light does glow during start/cranking/bulb check: Yes/No yes
12.Have you scanned for engine codes? Yes/No yes
12a. List exact results on engine codes. none

13. Condition of Battery terminals (removed, cleaned and tightened). clean and new
14. Known condition and age of Batteries. new
14a. Are batteries a matched set of same age? Yes bought new together
15. Condition of Major Grounds (removed, cleaned and tightened) All clean with additional grounds installed
15a Have the batteries been individually load tested? Yes

16. Does engine crank, or "turn over"? yes
16a. Does engine start and run? yes but poorly
17. If engine does not start- Crack injector line: do you have fuel? Yes/No Yes
18. Does your Wait To Start light come on? Yes
18a.Number of seconds WTS light is lit. 10+ seconds initially then about 5-7 seconds
19. Engine Cranking speed (if you have an accurate tachometer). 242 rpm

20. Are you experiencing Stalling? yes
20a. Describe the event (upon startup only, down the road, hit a bump, etc...) Starts, pop accelerator and drops dead
20b. Do you notice loss of dash or instruments? none
21. Check turbo inlet and air filter for obstructions. clear
22. In a no-hot start, pour a bottle of room-temp water on the injection pump. Does it start now? Same hard start
23. Lift pump test - Describe results. 7.9 psi flow test 1 pint/15 seconds

24. Upon cold start, does the radiator hose get hard quickly? Yes/No no
25. Upon cold start, do you have excessive white smoke? Yes/No Gray
26. Do you have excessive cranking time before the engine starts? Yes/No yes on initial start, no after that
27. Have you used the block heater? Does it affect engine starting? (only try for starting problems). no
28. Are all glow plugs in proper working order? yes and replaced

29. During hard acceleration, do you have excessive black smoke? Yes/No Yes coal black smoke
30. Do you have any unusual exhaust smoke issues? very acidic like unburned fuel
31. Turbo check out - Pass/Fail pass brand new max 14 psi
32. Indicate fuel that you are using: Bio-Diesel, #2 Diesel, SVO/WVO, other #2
32a. If running Veggie Oil fuel setup, indicate details of your conversion (homemade or packaged system).
33. Are you using any fuel additives? If so, please list. Stanadyne lubrication
34. Upon unscrewing fuel cap, do you have a large vacuum formed in the tank? Yes/No no
35. Do you have any service history available that might pertain to the problem you are having? No rebuilt motor
36. Please indicate any modifications to the vehicle that might help us diagnose better. Remote fuel filter, A team Turbo, KOJO tune, Snorkel intake replaced


I have 2 new PMD and 1 used known good, 2 newly rebuilt IP, different builders, 2 sets rebuilt stock injectors and 1 set marine injectors, new fuel sock, 2 new lift pumps, 1 new turbo, 1 rebuilt turbo, 3 different chips 1 stock, 1 bought new to swap out pump from 5068 to 5521 and new KOJO tune, make no difference which chip I use. 2 ECMs. So I have been subbing in parts looking. I have had clear lines from fuel filter to pump and pump to return lines, no air bubbles in either. Runs smooth at high idle and higher rpm, motor shakey at normal idle. At idle it will suddenly shut down, like if you stuck a stick in a fan, a quick abrupt shut down.

__________________
1994 Chevrolet C3500 Crew Cab Dually, Automatic, 2004 AM General 6.5 TD, AT Turbo, Kojo chip, 4" exhaust w/modified crossover, remote bumper mounted PMD, 189k on truck, OPS bypass for lift pump, upgraded cooling fan and clutch, remote fuel filter.
Offline  
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 07-25-2019, 02:43 PM   #2 (permalink)
jnlperformance
Diesel Pro
 
jnlperformance's Avatar
 
Join Date: Aug 2010
Location: Georgia
Posts: 2,297
iTrader Score: 0 reviews

Georgia Diesel Owners Club Member

Maybe you should try and revert back to f vin (or s, which ever you may have) chip. See what happens.

Maybe the snorkel is a bit restrictive?

Check for a blown hg?

Check for any blow by?

How certain are you of the build quality?

Do you know what block id you have?? Not all 6.x blocks are made equal. If it was supplied to you, and it's a 141 or gm506... I'd get my $ back. If you supplied the block... well...

Who remanned the injectors and injection pump? Stanadyne service center??

If you do decide to burn it then I'll take the engine and trans... then burn it (was a light joke)

Post a video... from start to stall. May help.

__________________
94 2Dr Blazer 6.5L
AMG506 Optimizer Block
Peninsular Forged Rotating Assembly
18:1, soon to be 16:1
Arp Head / Main Studs / Girdles

I'll get back to this later...

Last edited by jnlperformance; 07-25-2019 at 02:52 PM.
Offline   Reply With Quote Quick reply to this message
Old 07-25-2019, 03:05 PM   #3 (permalink)
jabon056
Diesel Student
 
Join Date: Aug 2009
Posts: 40
iTrader Score: 0 reviews

I rebuilt the motor myself, have built, Detroits, Cummins, Cats, Chevrolet, Ford, VW and Dodge. Never had a start up problem like this. No blow by or indications of a blown head gasket. 1 pump/injectors were rebuilt by Diesel Care and Performance and the other by local Stanadyne Authorized re-builder. If I install org 5068 chip, nothing, all 3 of the others for 5521 pump same results.
__________________
1994 Chevrolet C3500 Crew Cab Dually, Automatic, 2004 AM General 6.5 TD, AT Turbo, Kojo chip, 4" exhaust w/modified crossover, remote bumper mounted PMD, 189k on truck, OPS bypass for lift pump, upgraded cooling fan and clutch, remote fuel filter.
Offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 07-25-2019, 03:29 PM   #4 (permalink)
OkDually
Administrator
 
OkDually's Avatar
 
Join Date: Jul 2013
Location: N.E. Oklahoma
Posts: 14,206
iTrader Score: 0 reviews

DieselPlace.com Lifetime Premium Member

Quote:
Originally Posted by jabon056 View Post
I rebuilt the motor myself, have built, Detroits, Cummins, Cats, Chevrolet, Ford, VW and Dodge. Never had a start up problem like this. No blow by or indications of a blown head gasket. 1 pump/injectors were rebuilt by Diesel Care and Performance and the other by local Stanadyne Authorized re-builder. If I install org 5068 chip, nothing, all 3 of the others for 5521 pump same results.
Where did the current IP that you are having the issues come from? DieselCare or the authorized Stanadyne rebuilder?
__________________
1996 K3500 6.5L,( "F" Eng #141 cast block) 5 speed manual, crewcab, dually longbed: 208,000mi.
Diamond Eye 4" Turbo Back Exhaust w/2.5" Flo-Pro Crossover
AirDog II DF165 w/ tank sock delete - XDP
TD-Max boost controller - Kennedy Diesel
OPS extension hose - Leroy Diesel
Glow Plug Harness- PT Wiring Solutions
Glowshift Maxtow EGT,Boost, Fuel gauges
Boost & Fuel Pressure Bolts - Leroy Diesel
2/0 Battery Cable Upgrade - PT Wiring Solutions
PMD w/#9 resistor and Re-Location Kit, mounted to bumper - Leroy Diesel
GM-5 Turbocharger
4.10 gear ratio
OptiLube Winter Formula


Proud member #1039 of The 3500 Dually Club

Offline   Reply With Quote Quick reply to this message
Old 07-25-2019, 04:44 PM   #5 (permalink)
Tr00b
Diesel Boss
 
Tr00b's Avatar
 
Join Date: Oct 2013
Location: Scales Mound, IL
Posts: 1,411
iTrader Score: 0 reviews

Is your timing gear 180 off? Shorts to power or ground on the IP harness?
__________________
1996 GMC K1500xcab 6.5 3.73 4L80E rear bags Bought at 99k 12/13 now 138k 9/17
Repairs:
BWD OPS 1/14 Heath PMD kit 3/14 Airtex boost solenoid 6/14 Lube Specialist cooler lines and cooler, rad support mounts, Pro Comp ES9000 Shocks, rear brakes 7/14 Interstate Batts, Cooper AT3 tires, Hummer H3 rims, stepper motor 4x4, coolant flush 11/14 Stabilizer bar links, soot trap gasket 9/15 Dorman tank, sending unit/sock delete, filler neck, filler neck, hose, Leroy's Tank Barbs, SAE30R9 lines, WIX filter head and prefilter with brackets by paleyjim, intake manifold gaskets 3/16 Used transmission, dipstick tube, fluid flush, drain plug pan by paleyjim, power steering fluid flush, transfer case seals and fluid 9/16 Duraterms 11/16 Ball Joints and wheel bearing drivers side. Powerstop pads, lubed sliders 4/17 AD244, Leroy's Flight Systems PMD 9/17
Performance:
Ashland Muffler 2.5 X-over 12/13 FTB FFM by paleyjim, ported upper egr delete S-code, lower F-code, ported IP fitting, FASS DRP-02 lift pump 3/16 Transgo Shift Kit by paleyjim, Energy Susp. engine+trans mounts 9/16 Ported GM8, Diamond Eye, Quadstar tune 11/16 K47 Box, Glowshift 3-1 1/17 Leroy's Billet Crank pulley, Fluidampr. 9/17
Offline   Reply With Quote Quick reply to this message
Old 07-25-2019, 05:43 PM   #6 (permalink)
jnlperformance
Diesel Pro
 
jnlperformance's Avatar
 
Join Date: Aug 2010
Location: Georgia
Posts: 2,297
iTrader Score: 0 reviews

Georgia Diesel Owners Club Member

Quote:
Originally Posted by Tr00b View Post
Is your timing gear 180 off? Shorts to power or ground on the IP harness?
With that said it's also possible the injection pump drive shaft could also have been installed 180 out during the pump reman but both pumps yield same results(?? Assuming???)
__________________
94 2Dr Blazer 6.5L
AMG506 Optimizer Block
Peninsular Forged Rotating Assembly
18:1, soon to be 16:1
Arp Head / Main Studs / Girdles

I'll get back to this later...
Offline   Reply With Quote Quick reply to this message
Old 07-25-2019, 06:06 PM   #7 (permalink)
jabon056
Diesel Student
 
Join Date: Aug 2009
Posts: 40
iTrader Score: 0 reviews

It is a 2004 506 block. The DCP pump originally ran for about 400 miles before starting the shutting off after 2 minutes, wait a little while and it would do the same thing again. Installed the current pump that is on it, wouldn't die after 2 minutes and will run all day long at high idle then when warm regular Idle. It will sometime abruptly shut off returning to idle from reving. Here is a video of it running, wouldn't die today. But you can hear motor running.

__________________
1994 Chevrolet C3500 Crew Cab Dually, Automatic, 2004 AM General 6.5 TD, AT Turbo, Kojo chip, 4" exhaust w/modified crossover, remote bumper mounted PMD, 189k on truck, OPS bypass for lift pump, upgraded cooling fan and clutch, remote fuel filter.

Last edited by jabon056; 07-25-2019 at 06:17 PM. Reason: repaired video link
Offline   Reply With Quote Quick reply to this message
Old 07-25-2019, 06:12 PM   #8 (permalink)
OkDually
Administrator
 
OkDually's Avatar
 
Join Date: Jul 2013
Location: N.E. Oklahoma
Posts: 14,206
iTrader Score: 0 reviews

DieselPlace.com Lifetime Premium Member

Quote:
Originally Posted by jabon056 View Post
It is a 2004 506 block. The DCP pump ran for about 2 minutes then would just die, wait a little while and it would do the same thing again. Installed the current pump that is on it, wouldn't die after 2 minutes and will run all day long at high idle then when warm regular Idle. It will sometime abruptly shut off returning to idle from reving. Here is a video of it running, wouldn't die today. But you can hear motor running.

https://youtu.be/lOKXqV9EHWM
Your DCP parts source is the issue.
Dieselcare of TN has many BBB complaints regarding parts quality to poor customer service.
Here are just some of the BBB reviews. there are other on line reviews if you research.
https://www.bbb.org/us/tn/memphis/pr...196/complaints.

I would start by finding a reputable parts source and then while you correct the IP issue, Pop test the Injectors for proper operation and replace them if needed.
__________________
1996 K3500 6.5L,( "F" Eng #141 cast block) 5 speed manual, crewcab, dually longbed: 208,000mi.
Diamond Eye 4" Turbo Back Exhaust w/2.5" Flo-Pro Crossover
AirDog II DF165 w/ tank sock delete - XDP
TD-Max boost controller - Kennedy Diesel
OPS extension hose - Leroy Diesel
Glow Plug Harness- PT Wiring Solutions
Glowshift Maxtow EGT,Boost, Fuel gauges
Boost & Fuel Pressure Bolts - Leroy Diesel
2/0 Battery Cable Upgrade - PT Wiring Solutions
PMD w/#9 resistor and Re-Location Kit, mounted to bumper - Leroy Diesel
GM-5 Turbocharger
4.10 gear ratio
OptiLube Winter Formula


Proud member #1039 of The 3500 Dually Club

Offline   Reply With Quote Quick reply to this message
Old 07-25-2019, 10:39 PM   #9 (permalink)
jabon056
Diesel Student
 
Join Date: Aug 2009
Posts: 40
iTrader Score: 0 reviews

All the DCP parts are off the truck, the current pump is the stanadyne rebuild, injectors are from NAPA. I had a feeling it was likely still the IP and possibly the injectors. Since I do have a oil leak on valve covers, I think I will check for maybe bent push rods, while I have fuel lines loose.
__________________
1994 Chevrolet C3500 Crew Cab Dually, Automatic, 2004 AM General 6.5 TD, AT Turbo, Kojo chip, 4" exhaust w/modified crossover, remote bumper mounted PMD, 189k on truck, OPS bypass for lift pump, upgraded cooling fan and clutch, remote fuel filter.
Offline   Reply With Quote Quick reply to this message
Old 07-25-2019, 10:44 PM   #10 (permalink)
OkDually
Administrator
 
OkDually's Avatar
 
Join Date: Jul 2013
Location: N.E. Oklahoma
Posts: 14,206
iTrader Score: 0 reviews

DieselPlace.com Lifetime Premium Member

Quote:
Originally Posted by jabon056 View Post
All the DCP parts are off the truck, the current pump is the stanadyne rebuild, injectors are from NAPA. I had a feeling it was likely still the IP and possibly the injectors. Since I do have a oil leak on valve covers, I think I will check for maybe bent push rods, while I have fuel lines loose.
I would still pop test those NAPA Injectors.
As mentioned double verify TDCO with the engine at operating temp ( 190* + )

__________________
1996 K3500 6.5L,( "F" Eng #141 cast block) 5 speed manual, crewcab, dually longbed: 208,000mi.
Diamond Eye 4" Turbo Back Exhaust w/2.5" Flo-Pro Crossover
AirDog II DF165 w/ tank sock delete - XDP
TD-Max boost controller - Kennedy Diesel
OPS extension hose - Leroy Diesel
Glow Plug Harness- PT Wiring Solutions
Glowshift Maxtow EGT,Boost, Fuel gauges
Boost & Fuel Pressure Bolts - Leroy Diesel
2/0 Battery Cable Upgrade - PT Wiring Solutions
PMD w/#9 resistor and Re-Location Kit, mounted to bumper - Leroy Diesel
GM-5 Turbocharger
4.10 gear ratio
OptiLube Winter Formula


Proud member #1039 of The 3500 Dually Club

Offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Diesel Place : Chevrolet and GMC Diesel Truck Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

PLEASE READ! You must check your email inbox for the confirmation link to complete registration. Please check your spam box if you do not see the email in your inbox.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in


Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 06:17 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
SEO by vBSEO 3.6.1
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Shoutbox provided by vBShout v6.2.1 (Lite) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
© AutoGuide