Question: Troubleshooting a no-start on 94 Suburban - can you help? - Diesel Place : Chevrolet and GMC Diesel Truck Forums
 
Home Forum Market Place Garage Tuning Library DTC Tool Register Vendors
Go Back   Diesel Place : Chevrolet and GMC Diesel Truck Forums > GM Diesel Engines > 6.5L Diesel Engine
Register FAQ Forum Rules My Replies My Threads Mark Forums Read Advertise

6.5L Diesel Engine Discuss the 6.5 GM diesel engine & associated components. Automatic transmission questions & problems belong in the 4L80/85 - 4L60E - 6L90 Transmission Forum

DieselPlace.com is the premier Duramax Diesel Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools
Old 04-15-2019, 11:26 AM   #1 (permalink)
gofarm
Gear Grinder
 
Join Date: Apr 2019
Posts: 2
iTrader Score: 0 reviews

Troubleshooting a no-start on 94 Suburban - can you help?

Good morning. Can you help me? I’m diagnosing a no-start with my 94 Suburban 6.5 and want to be sure I’ve covered all the reasonable possibilities before I replace the IP.

Vehicle:
• 1994 Suburban k2500
• 270k miles
• IP date appears to be 1/03, not the original IP
• PMD in factory location

Pre-failure Symptoms:
• Occasional stall over the last 5 years (less than a dozen times). Immediate restart each time
• Occasional miss over the same period, seemed to occur especially at highway speeds and high torque (uphill) Never could pinpoint if this was engine miss or transmission slip but suspected former
• Occasional CEL briefly lighting over the same period, not necessarily combined with the above symptoms
• Truck used only 2-3k miles per year for the last 3 years, daily driver before that. Cold starting took longer over the last few years with more white smoke.

Failure scenario:
Traveling at highway speed on a cool afternoon. CEL came on followed soon after by missing and then the throttle stopped responding, throttle settled out at ~2k rpm. When I tapped the brakes, the engine would throttle down but if I hit the APP again, it increased to ~2k. I could maintain close to highway speed in this condition. I shifted to neutral, pulled over and stopped. Engine began to cough and smoke. I shut it off. Restarted: engine idled roughly, black smoke, no throttle response. Towed home. Restarted: same symptoms but now worse, with engine seeking excessively, no rpm stability at all. Shut off. This time I smelled plastic burning. Checked under the hood and saw smoke from the PMD. Truck never restarted.

What I’ve done to troubleshoot:
• Troubleshot APP via AccurateDiesel’s guides (tests good)
• Troubleshot PMD circuit with AccurateDiesel's PMD guide – some question as to signal from the IP but not sure if I was measuring the voltage properly. I will probably need to recheck this.
• R2 PMD with 3 tested and 1 brand new module – no start with all
• Removed fuel solenoid and tested (good)
• Checked ECM fuse (good)
• Checked fuel filter (clean)
• Checked air filter (clean)
• Checked lift pump (opened t-valve while cranking)
• Cracked injector line on #3 – no fuel during cranking
• Checked fuel level (est 5-7 gal in tank)
• Checked resistance at all major grounds (G101, G102, G104, G105, block-to-frame straps, PMD ground), all .4 ohm or less
• All starting attempts have been made with fully charged batteries.

Unfortunately, I disconnected the battery for long-term storage without thinking about that erasing codes so I don't know what codes were tripped in the original incident. I'm grateful for any suggestions of alternative vectors to check.

Thanks.
-Adam

__________________
1994 Suburban K2500 6.5L
270k miles

Last edited by OkDually; 04-15-2019 at 12:39 PM. Reason: prefix/sig
Offline  
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 04-15-2019, 01:03 PM   #2 (permalink)
JMJNet
Diesel Legend
 
JMJNet's Avatar
 
Join Date: Feb 2006
Location: Richardson, TX
Posts: 17,077
iTrader Score: 0 reviews

The Suburban Club Member

When you test the PMD, was the PMD on a heatsink?
You know if it is NOT, then you toast all those PMD.

Did you load test the batteries one at a time?

__________________
1995 GMC Suburban:
PMD in Bumper
Leroy Diesel Flight System PMD
Leroy Diesel Oil Cooler Line
4" Warpspeed Exhaust
Kennedy Diesel LP/OPS Harness
Bosch Duraterm GP
Heath Turbo-Master
AD244 Alternator
Offline   Reply With Quote Quick reply to this message
Old 04-15-2019, 01:47 PM   #3 (permalink)
gofarm
Gear Grinder
 
Join Date: Apr 2019
Posts: 2
iTrader Score: 0 reviews

Quote:
Originally Posted by JMJNet View Post
When you test the PMD, was the PMD on a heatsink?
You know if it is NOT, then you toast all those PMD.

Did you load test the batteries one at a time?
I have not load tested the batteries. At full charge during start testing, the start cycle appeared to operate at a similar rpm to previous good-start cycles.

PMDs were not mounted to any heatsink for the start testing. There is quite a bit of metal on the bottom plate, I'd think that's plenty of thermal mass for 15-20 second tests. None of the modules were even hot following testing. Is that out of the ordinary?

-Adam
__________________
1994 Suburban K2500 6.5L
270k miles
Offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Diesel Place : Chevrolet and GMC Diesel Truck Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

PLEASE READ! You must check your email inbox for the confirmation link to complete registration. Please check your spam box if you do not see the email in your inbox.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in


Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
HELP LB7 no start for 13 weeks!! PewterLB7 Duramax First Generation: 2001-2004 (LB7) 42 02-13-2019 08:42 PM
Question: ´94 Chevy Suburban stalling, problems idling and dificulty to start engine. san15895 6.5L Diesel Engine 17 07-13-2018 08:51 AM
Opinions on troubleshooting another wont start 6.5td. Hateskate 6.5L Diesel Engine 11 03-17-2018 03:27 AM
1999 Suburban will not start, need help. josephus 6.5L Diesel Engine 10 10-07-2015 04:59 PM
'94 Suburban doesn't want to start, or stay running when it does. 94SUB 6.5L Diesel Engine 13 09-18-2015 06:46 PM


All times are GMT -4. The time now is 09:10 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
SEO by vBSEO 3.6.1
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Shoutbox provided by vBShout v6.2.1 (Lite) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
© AutoGuide