Frustrating No Start - Diesel Place : Chevrolet and GMC Diesel Truck Forums
 
Home Forum Market Place Garage Tuning Library DTC Tool Register Vendors
Go Back   Diesel Place : Chevrolet and GMC Diesel Truck Forums > GM Diesel Engines > 6.5L Diesel Engine
Register FAQ Forum Rules My Replies My Threads Mark Forums Read Advertise

6.5L Diesel Engine Discuss the 6.5 GM diesel engine & associated components. Automatic transmission questions & problems belong in the 4L80/85 - 4L60E - 6L90 Transmission Forum

DieselPlace.com is the premier Duramax Diesel Forum on the internet. Registered Users do not see the above ads.
Like Tree1Likes

Reply
 
LinkBack Thread Tools
Old 12-16-2018, 06:41 PM   #1 (permalink)
Stauby
Self Ignition
 
Join Date: Jan 2005
Posts: 86
iTrader Score: 0 reviews

Frustrating No Start

I've had 6.5's for 15 years and have had plenty of issues firing up over the years, but now am completely stumped. Have a 99 Suburban, replaced with rebuilt engine 2 yrs ago and had been very reliable and fast starting daily driver. One day it wouldn't start, only coughs for a few seconds and then nothing. Over 3 weeks of messing with it I can occasionally get it to start but not every time. Replaced glow plugs, tried second PMD, cleaned grounds, verified lift pump - slight improvement but still rarely starts. I appreciate any help and advice you can give. Here's the checklist.

1. Describe the problem you are having in detail: No start. Truck was daily driver and very reliable starting. Drove fine to work one day 3 weeks ago, then when time to go home wouldn’t start and has only started a few times since. Each crank gets a cough for a few seconds, then nothing. If I do this for a while, then charge the battery, I can sometimes get it to start. I have idled the engine for ˝ hr to be sure there are no air pockets. If engine is hot it will restart easily. When it cools back down it won’t start again.

2. Year of truck/engine. 1999
3. Odometer reading (indicate miles or kilometers). 165000
4. Indicate the model number on the Injection pump (starts DS4 or DB2......). DS4
5. Indicate if you know if it’s a 1500, 2500, 2500HD, 3500, 3500HD. 2500HD
6. Do you have an EGR on the engine? (An F or an S engine code 8th VIN digit) No
7. Air Filter condition (visual check). Tried with AF removed, no change
8. Fuel filter condition (freshly changed, mileage since changed). New
9. Location of PMD/FSD? (ex. on pump/remote over intake, behind bumper). Top driver side of engine on large heat sink
9a. If remote mounted, describe wiring harness (homemade or purchased from which vendor). Standard harness
9b. Indicate the location and condition of the FSD/IP grounding wire. Top of IP
10. Outside Temperature (C or F). _____ ° 45

11. Service Engine Light while running?- on/off/intermittent None
11a. Service Engine light does glow during start/cranking/bulb check: Yes
12.Have you scanned for engine codes? Yes
12a. List exact results on engine codes. None

13. Condition of Battery terminals (removed, cleaned and tightened). Cleaned and tightened
14. Known condition and age of Batteries. Optima, 2 yr
14a. Are batteries a matched set of same age? No, passenger battery is newer Optima
15. Condition of Major Grounds (removed, cleaned and tightened) cleaned battery grounds and rear left engine grounds
15a Have the batteries been individually load tested? No

16. Does engine crank, or "turn over"? Yes, speed seems normal
16a. Does engine start and run? Rarely
17. If engine does not start- Crack injector line: do you have fuel? Yes
18. Does your Wait To Start light come on? Yes on the first crank, sometimes no on second crank
18a.Number of seconds WTS light is lit. 15-20 on first crank
19. Engine Cranking speed (if you have an accurate tachometer). Seems normal. No tach

20. Are you experiencing Stalling? No
20a. Describe the event (upon startup only, down the road, hit a bump, etc...) N/A
20b. Do you notice loss of dash or instruments? N/A
21. Check turbo inlet and air filter for obstructions. Removed air filter. No change
22. In a no-hot start, pour a bottle of room-temp water on the injection pump. Does it start now? No. Tried new second PMD, no change
23. Lift pump test - Describe results. I have strong fuel stream out of T hose with engine running

24. Upon cold start, does the radiator hose get hard quickly? No
25. Upon cold start, do you have excessive white smoke? No, is grey for a while then clear
26. Do you have excessive cranking time before the engine starts? When it does start it goes quick.
27. Have you used the block heater? Does it affect engine starting? (only try for starting problems). Tried with and without, no obvious difference
28. Are all glow plugs in proper working order? Replaced them all with Bosch fast start and verified 12 v to all

29. During hard acceleration, do you have excessive black smoke? Yes/No Don’t know
30. Do you have any unusual exhaust smoke issues? No
31. Turbo check out - Pass/Fail
32. Indicate fuel that you are using: Diesel
32a. If running Veggie Oil fuel setup, indicate details of your conversion (homemade or packaged system). No
33. Are you using any fuel additives? If so, please list. Winter additive
34. Upon unscrewing fuel cap, do you have a large vacuum formed in the tank? No
35. Do you have any service history available that might pertain to the problem you are having? No
36. Please indicate any modifications to the vehicle that might help us diagnose better.
a. Mostly stock. Have diy turbomaster, boost fooler, gauges
b. Have clear hose on fuel return. Clear and no air bubbles. Tried removing to make sure no return blockage- no change
c. New fuel sending unit, hose all the way up. No delivery issues
d. Marine injectors, 2 yrs

__________________
Stauby
99 K2500 6.5L TD Suburban ex military vehicle.
Offline  
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 12-17-2018, 09:47 AM   #2 (permalink)
JMJNet
Diesel Legend
 
JMJNet's Avatar
 
Join Date: Feb 2006
Location: Richardson, TX
Posts: 17,015
iTrader Score: 0 reviews

The Suburban Club Member

Do 15a?

__________________
1995 GMC Suburban:
PMD in Bumper
Leroy Diesel Flight System PMD
Leroy Diesel Oil Cooler Line
4" Warpspeed Exhaust
Kennedy Diesel LP/OPS Harness
Bosch Duraterm GP
Heath Turbo-Master
AD244 Alternator
Offline   Reply With Quote Quick reply to this message
Old 12-17-2018, 10:22 AM   #3 (permalink)
vstech
Moderator
Eco-Logistical
 
vstech's Avatar
 
Join Date: Jul 2008
Location: My Holly, NC
Posts: 4,133
iTrader Score: 0 reviews
Send a message via AIM to vstech Send a message via Skype™ to vstech

Old School Oil Burners (Old SOBs) Member

DieselPlace.com Lifetime Premium Member

It sounds like injectors are pissing, and you have low compression.

1. You have new bosch glow plugs, and verified they are getting 12v

2. Your motor is cranking, and you have fuel to the injectors.

3. When it starts, you have grey smoke.

I would get a compression test performed.

Plug in the block heater to get it warm for morning starts.

A remote possibility is air in the fuel lines, but a filter bleed should show that.
__________________
6.5block in 6.2 trim with a TH400 attached
95 6.5 block, most of the IP, flywheel, and pressure plate.
95 Chevy Suburban 1500 "blue bomber"
2000 Chevrolet extended cab long bed 2500 6.5L HO
94 GMC extended cab long bed 6 lug truck 6.5L
Z71 ext cab standard bed S vin with a blown headgasket.

Last edited by vstech; 12-17-2018 at 10:23 AM.
Offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 12-17-2018, 08:21 PM   #4 (permalink)
Stauby
Self Ignition
 
Join Date: Jan 2005
Posts: 86
iTrader Score: 0 reviews

I'm leaning towards the batteries too, because after a charge I have a much better chance of starting, and after 3-4 cranks they start to slow down. I will have them load tested.

On the injector and low compression theory- this event was like flipping a switch type deal. Every start prior to the "no start" time was within a few seconds of turning the key, almost to the point it sounded more like a gasser than a diesel. I never had extended cranks before it would catch. Even that morning when it was much colder it fired up quickly, then after work nothing. Would the low compression and pissing injectors be so black and white, or would I have seen degradation over time?
__________________
Stauby
99 K2500 6.5L TD Suburban ex military vehicle.
Offline   Reply With Quote Quick reply to this message
Old 12-17-2018, 08:29 PM   #5 (permalink)
Stauby
Self Ignition
 
Join Date: Jan 2005
Posts: 86
iTrader Score: 0 reviews

One item I left out. I was low on the tank and the fuel sender was bouncing between 1/4 and empty. It is possible that I ran it dry that day. That would explain the difficulty in getting it restarted. The cough and then not running seems very similar to when I replaced the engine and had to get it restarted after being dry. However, I have run it for 1/2 hr since then, and there are no bubbles in the clear return tube. Is there a chance of air still in the system? Maybe grabbing at straws but wanted aty least to get everything I know out there
__________________
Stauby
99 K2500 6.5L TD Suburban ex military vehicle.
Offline   Reply With Quote Quick reply to this message
Old 12-17-2018, 11:19 PM   #6 (permalink)
EastCoast62
Diesel Rookie
 
Join Date: Nov 2018
Location: East Coast NC
Posts: 35
iTrader Score: 0 reviews

Old School Oil Burners (Old SOBs) Member

Not saying you do not have another problem, just went through the same thing with my 6.2 over the last few days, it refused to crank yesterday, but acted just like you described cranked for a few seconds and died, then once for a few minutes died. Fuel gauge same place, so I pulled the separator/filter and it was filthy, dumped it out then filled it with fresh diesel, cracked injector lines, same results, with very little fuel at the nuts. Today, after thinking about how much trash, dirty fuel and even a little water, I decided to change both filters, switched to the left tank which was full, and purged the air out with air pressure in my tank because I have a mechanical pump. Then once I got fuel to the new separator/filter it cranked right up, didn't even have to crank the injector lines....drove it about 10 miles, restarted fine, just feels like I have lost a little power, so I am going to clean more of the fuel system tomorrow. Just saying mine did the exact same thing low on fuel about 3/8 of a tank, surged a bit, driving home and would not crank back the next day. I was surprised at how much crude and nasty looking fuel that came out of the filter....and it was also only a few weeks old, so I know that I pulled it into the filter by running the tank low. Others have mentioned a sock in the tank off the sending unit causing them to replace ip and many other things only to find out that it was about a 27 dollar sock/strainer that was stopping up. You should be able to find the part number in the forum. I know that am dropping the right tank, cleaning it out and installing a new strainer as soon I a have a couple of free days to do it. Its worth a shot, to check these items too and good luck with it.
__________________
1982 6.2 4x4 truck, East Coast NC

Last edited by EastCoast62; 12-17-2018 at 11:39 PM.
Offline   Reply With Quote Quick reply to this message
Old 12-19-2018, 08:11 PM   #7 (permalink)
Stauby
Self Ignition
 
Join Date: Jan 2005
Posts: 86
iTrader Score: 0 reviews

Batteries both passed load test. It looks like a compression test is next. Any other suggestions?
__________________
Stauby
99 K2500 6.5L TD Suburban ex military vehicle.
Offline   Reply With Quote Quick reply to this message
Old 12-19-2018, 10:40 PM   #8 (permalink)
JMJNet
Diesel Legend
 
JMJNet's Avatar
 
Join Date: Feb 2006
Location: Richardson, TX
Posts: 17,015
iTrader Score: 0 reviews

The Suburban Club Member

make sure there is gas and make sure to bleed the air from fuel.
Did you try a KNOWN WORKING PMD?
__________________
1995 GMC Suburban:
PMD in Bumper
Leroy Diesel Flight System PMD
Leroy Diesel Oil Cooler Line
4" Warpspeed Exhaust
Kennedy Diesel LP/OPS Harness
Bosch Duraterm GP
Heath Turbo-Master
AD244 Alternator

Last edited by OkDually; 12-20-2018 at 11:18 AM. Reason: removed quote
Offline   Reply With Quote Quick reply to this message
Old 12-20-2018, 11:11 AM   #9 (permalink)
JMJNet
Diesel Legend
 
JMJNet's Avatar
 
Join Date: Feb 2006
Location: Richardson, TX
Posts: 17,015
iTrader Score: 0 reviews

The Suburban Club Member

Try to tap the starter when you start?
To check if starter is the culprit.
__________________
1995 GMC Suburban:
PMD in Bumper
Leroy Diesel Flight System PMD
Leroy Diesel Oil Cooler Line
4" Warpspeed Exhaust
Kennedy Diesel LP/OPS Harness
Bosch Duraterm GP
Heath Turbo-Master
AD244 Alternator
Offline   Reply With Quote Quick reply to this message
Old 01-05-2019, 01:42 PM   #10 (permalink)
Stauby
Self Ignition
 
Join Date: Jan 2005
Posts: 86
iTrader Score: 0 reviews

The winner is.... CRANKSHAFT POSITION SENSOR !!!!

The only way I figured it out is that it finally threw a code.

Thanks to everyone for your suggestions. I couldn't have figured it out without your help

__________________
Stauby
99 K2500 6.5L TD Suburban ex military vehicle.
Offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Diesel Place : Chevrolet and GMC Diesel Truck Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

PLEASE READ! You must check your email inbox for the confirmation link to complete registration. Please check your spam box if you do not see the email in your inbox.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in


Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
HELP LB7 no start for 13 weeks!! PewterLB7 Duramax First Generation: 2001-2004 (LB7) 42 02-13-2019 08:42 PM
Chevy G30 6.5 V8 Cranks but won't start jnymdnyt 6.5L Diesel Engine 26 08-09-2018 01:47 PM
6.5 Td will pull start but not start under cranking Tagremodels 6.5L Diesel Engine 11 01-21-2017 03:34 AM
98 6.5L will not start or turnover. SmokePoint 6.5L Diesel Engine 16 03-09-2016 11:30 AM
'94 Suburban doesn't want to start, or stay running when it does. 94SUB 6.5L Diesel Engine 13 09-18-2015 06:46 PM


All times are GMT -4. The time now is 01:24 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
SEO by vBSEO 3.6.1
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Shoutbox provided by vBShout v6.2.1 (Lite) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
© AutoGuide