lift pump not working....wtf - Diesel Place : Chevrolet and GMC Diesel Truck Forums
 
Home Forum Market Place Garage Tuning Library DTC Tool Register Vendors
Go Back   Diesel Place : Chevrolet and GMC Diesel Truck Forums > GM Diesel Engines > 6.5L Diesel Engine
Register FAQ Forum Rules My Replies My Threads Mark Forums Read Advertise

6.5L Diesel Engine Discuss the 6.5 GM diesel engine & associated components. Automatic transmission questions & problems belong in the 4L80/85 - 4L60E - 6L90 Transmission Forum

DieselPlace.com is the premier Duramax Diesel Forum on the internet. Registered Users do not see the above ads.
Like Tree6Likes

Reply
 
LinkBack Thread Tools
Old 03-23-2014, 03:17 PM   #1 (permalink)
crscrs
Diesel Starter
 
Join Date: Mar 2013
Location: Okanagan Valley, British Columbia Canada
Posts: 189
iTrader Score: 1 reviews

lift pump not working....wtf

i was having an issue with my truck idling at a low rpm, and one of the suggestions was to switch out the lift pump.

before i was able to, one of my tstat bolts snapped and started dumping my coolant all over the driveway. fixed the bolt, put in a temp gasket, topped up my coolant and on my way.

the next day i switched out the gasket, and brought yard waste to the disposal site and back (5 km trip). got back and my truck smelt like diesel bad. looked underneath and there was a drip drip. turned out the tstat fuel line cracked when i replaced the gasket, cut the line and put the fuel t back on lower on the hose. started the truck and it died soon after, tried to jump the pump and the pump would not power on.

dont know how long my lift pump was not working, my truck has been fishbitting a bit since i bought it. sometimes really bad sometimes not at all, so when my truck has been fish bitting recently i didnt know that my pump had no power. dont know if the fishbitting was always caused by the pump, an electrical issue or something...

i took off the stock lift pump, put on the walbro, plumbed it in, wired a plug onto it. i took a battery and manualy jumped the pump right to a battery (to prime the system), it ran good. i tried to jump the pump onthe ops mod like before, pump didnt run. i disconnected the pump and turned on the truck, the output to the pump on the ops relay had power with a test light but the lift pump harness (one thats on the truck, lift pump is not plugged in right now) does not have power.

i ran a new wire from the ops relay to the lift pump and put it into the harness. lift pump would not run, no power at the ops relay. if i jumped the wire the lift pump ran though. now that points to the ops?

so i went to parts store and got a ac delco ops, put it on and no power to the output on the ops relay.

when the truck is running, i put a pressure guage on the tstat. there is no pressure until i jump the pump to the ops, then over 10 psi pressure. i stop jumping it and it goes back to vacuum.

any thoughts, i am ticked off by this truck lol - next step is to rip apart my ops mod wiring and look at all of that wiring?

__________________
94 K1500 6.5L na 244k - PMD on top of block

95 K1500 6.5L TD 305k, PMD on top of block - Flipped on Coquihalla on 01/28/13, parted off and hauled away

95 k3500 6.5l TD - Project Truck - broken crank - Crew Cab Long Box , 4" exhaust

Last edited by crscrs; 03-23-2014 at 03:20 PM.
Offline  
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 03-23-2014, 03:29 PM   #2 (permalink)
Freddyack
Lead Moderator
Diesel Guru
 
Freddyack's Avatar
Quote:
Originally Posted by crscrs View Post
next step is to rip apart my ops mod wiring and look at all of that wiring?
If all the wiring checks out, then check to see if the relay is working.

Attached is a OPS mod wiring diagram.

Attached Files
File Type: pdf OPSmod.pdf (85.5 KB, 318 views)
__________________
Offline   Reply With Quote Quick reply to this message
Old 03-23-2014, 03:35 PM   #3 (permalink)
OkDually
Administrator
 
OkDually's Avatar
 
Join Date: Jul 2013
Location: N.E. Oklahoma
Posts: 13,808
iTrader Score: 0 reviews

DieselPlace.com Lifetime Premium Member

Quote:
Originally Posted by Freddyack View Post
If all the wiring checks out, then check to see if the relay is working.

Attached is a OPS mod wiring diagram.
x2 ..... also double check the grounds.... clean and tight
__________________
1996 K3500 6.5L,( "F" Eng #141 cast block) 5 speed manual, crewcab, dually longbed: 208,000mi.
Diamond Eye 4" Turbo Back Exhaust w/2.5" Flo-Pro Crossover
AirDog II DF165 w/ tank sock delete - XDP
TD-Max boost controller - Kennedy Diesel
OPS extension hose - Leroy Diesel
Glow Plug Harness- PT Wiring Solutions
Glowshift Maxtow EGT,Boost, Fuel gauges
Boost & Fuel Pressure Bolts - Leroy Diesel
2/0 Battery Cable Upgrade - PT Wiring Solutions
PMD w/#9 resistor and Re-Location Kit, mounted to bumper - Leroy Diesel
GM-5 Turbocharger
4.10 gear ratio
OptiLube summer + Formula


Proud member #1039 of The 3500 Dually Club

Online   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 03-23-2014, 03:39 PM   #4 (permalink)
crankme69
Diesel Pro
 
crankme69's Avatar
 
Join Date: Oct 2009
Posts: 2,446
iTrader Score: 0 reviews

I know how I'd fix it but I get gang raped by the safety notzies for suggesting it...
__________________
1995 1500 Silverado 6.5TD 2WD Ext Cab 246K, FSD cooler bumper mount, Buddy 3 pos chip, DE 4" exhaust, K47 with F intake

1995 Tahoe 6.5TD 217K Buddy chipped cat & muff delete

1994 1500 Silverado 6.5TD 2WD RCLB 208K Buddy chip F intake, daily work commuter 21mpg avg

2005 FLHTC 107 Twin Cam Tman 625 cams, 10.1 CR, Mik 45, DTT map, 3.37 final, E1 clutch & VPC with SE 6 sp, SnS roller rockers Bub 7 2 into 1 exhaust, 120Tq & 120Hp

1995 FXD 80 EVO V Thunder 2015 cam, Mikuni 42, SE slip ons, 80Tq & 70Hp
Offline   Reply With Quote Quick reply to this message
Old 03-24-2014, 12:32 AM   #5 (permalink)
crscrs
Diesel Starter
 
Join Date: Mar 2013
Location: Okanagan Valley, British Columbia Canada
Posts: 189
iTrader Score: 1 reviews

How can I bypass the ops so the lift pump comes on with the truck like normal? Just for tomorrow, then I have a week to troubleshoot. My gf needs my truck tomorrow and I don't want my ip strained for another day..
__________________
94 K1500 6.5L na 244k - PMD on top of block

95 K1500 6.5L TD 305k, PMD on top of block - Flipped on Coquihalla on 01/28/13, parted off and hauled away

95 k3500 6.5l TD - Project Truck - broken crank - Crew Cab Long Box , 4" exhaust
Offline   Reply With Quote Quick reply to this message
Old 03-24-2014, 06:15 AM   #6 (permalink)
HeavyChevy95
Diesel Veteran
 
HeavyChevy95's Avatar
 
Join Date: Jun 2008
Posts: 5,266
iTrader Score: 0 reviews

LPR Maint Jumper and/or Emergency Repair


Note: With paperclip (PC) installed as shown, LP will only activate with the ignition "ON" regardless if the engine is running or not.
In other words, the GF wont have to worry 'bout turning it on or off as she does her thang...

Good Luck.

Last edited by HeavyChevy95; 03-24-2014 at 06:24 AM.
Offline   Reply With Quote Quick reply to this message
Old 03-24-2014, 06:39 AM   #7 (permalink)
crankme69
Diesel Pro
 
crankme69's Avatar
 
Join Date: Oct 2009
Posts: 2,446
iTrader Score: 0 reviews

With the paper clip installed the pump will run continuously. Shoot me a pm if you want it to come on with the ignition
__________________
1995 1500 Silverado 6.5TD 2WD Ext Cab 246K, FSD cooler bumper mount, Buddy 3 pos chip, DE 4" exhaust, K47 with F intake

1995 Tahoe 6.5TD 217K Buddy chipped cat & muff delete

1994 1500 Silverado 6.5TD 2WD RCLB 208K Buddy chip F intake, daily work commuter 21mpg avg

2005 FLHTC 107 Twin Cam Tman 625 cams, 10.1 CR, Mik 45, DTT map, 3.37 final, E1 clutch & VPC with SE 6 sp, SnS roller rockers Bub 7 2 into 1 exhaust, 120Tq & 120Hp

1995 FXD 80 EVO V Thunder 2015 cam, Mikuni 42, SE slip ons, 80Tq & 70Hp
Offline   Reply With Quote Quick reply to this message
Old 03-24-2014, 12:49 PM   #8 (permalink)
crscrs
Diesel Starter
 
Join Date: Mar 2013
Location: Okanagan Valley, British Columbia Canada
Posts: 189
iTrader Score: 1 reviews

Quote:
Originally Posted by HeavyChevy95 View Post
LPR Maint Jumper and/or Emergency Repair


Note: With paperclip (PC) installed as shown, LP will only activate with the ignition "ON" regardless if the engine is running or not.
In other words, the GF wont have to worry 'bout turning it on or off as she does her thang...

Good Luck.

How would I do this with a 94? Pull the plug from the lift pump relay on the firewall and stick a paper clip in there?
__________________
94 K1500 6.5L na 244k - PMD on top of block

95 K1500 6.5L TD 305k, PMD on top of block - Flipped on Coquihalla on 01/28/13, parted off and hauled away

95 k3500 6.5l TD - Project Truck - broken crank - Crew Cab Long Box , 4" exhaust
Offline   Reply With Quote Quick reply to this message
Old 03-24-2014, 02:36 PM   #9 (permalink)
HeavyChevy95
Diesel Veteran
 
HeavyChevy95's Avatar
 
Join Date: Jun 2008
Posts: 5,266
iTrader Score: 0 reviews

Quote:
Originally Posted by crscrs View Post
How would I do this with a 94? Pull the plug from the lift pump relay on the firewall and stick a paper clip in there?
Not so fast, I was mistaken. No doubt crankme or another member will be along to offer a better way shortly... Otherwise you may have to pull the jumper out when not in operation..
Although very simular, Im not completely familiar with the specifics of '94 wiring harness nor where the LPR is located on the firewall. I can only speclate the '94 and '95 OBD1 models utilize the same LPR and LPR/wiring plug configuration. I appologize for the confusion..


Quote:
Originally Posted by crankme69 View Post
With the paper clip installed the pump will run continuously. Shoot me a pm if you want it to come on with the ignition
I suspect your correct crankme, Ive never tried it with the ignition "OFF." I hadn't given it any thought until you said otherwise.. Thats how I was shown to do it years ago, so I assumed it to be accurate info. My bad.
The real kicker, I knew better last night or I should have.. I just hadn't connected the dots yet.
Fact is.. I peeked under the skirt of the Convenience Center last night, specifically taking note (and pic) of the LPR wiring for another simular case of mistaken identity with DLC Pin Assignments for '95 OBD1 models.
My trick appears to connect ECM-B+ (B1 ORN) straight to LP (A3 GRY) which would make the LP runs constantly just as you say... However next time Im under the hood, I'll pop in the jumper with ignition OFF to further verify. Thanks for the correction.
Offline   Reply With Quote Quick reply to this message
Old 03-24-2014, 02:42 PM   #10 (permalink)
JMJNet
Diesel Legend
 
JMJNet's Avatar
 
Join Date: Feb 2006
Location: Richardson, TX
Posts: 17,290
iTrader Score: 0 reviews

The Suburban Club Member

Relay may be bad?

__________________
1995 GMC Suburban:
PMD in Bumper
Leroy Diesel Flight System PMD
Leroy Diesel Oil Cooler Line
4" Warpspeed Exhaust
Kennedy Diesel LP/OPS Harness
Bosch Duraterm GP
Heath Turbo-Master
AD244 Alternator
Offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Diesel Place : Chevrolet and GMC Diesel Truck Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

PLEASE READ! You must check your email inbox for the confirmation link to complete registration. Please check your spam box if you do not see the email in your inbox.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in


Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Working Lift pump + Clean fuel filter = RED-85-Z51 6.5L Diesel Engine 5 10-19-2013 12:46 AM
How do I know if my lift pump is working? greif03lb7 6.5L Diesel Engine 10 02-19-2010 07:45 PM
'94 lift pump not working mr_flowmaster 6.5L Diesel Engine 7 02-02-2010 11:00 AM
T-valve drain not working, lift pump is working Pa1dFor 6.5L Diesel Engine 9 04-01-2008 03:50 PM
TTS Lift Pump, how can you tell if working? brich6600 Fuel System, Air, Exhaust, & Emissions Upgrades 1 08-27-2007 07:39 PM


All times are GMT -4. The time now is 12:25 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
SEO by vBSEO 3.6.1
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Shoutbox provided by vBShout v6.2.1 (Lite) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
© AutoGuide