Cut out, won't start, check gauges light not Wait To Start light - Diesel Place : Chevrolet and GMC Diesel Truck Forums
 
Home Forum Market Place Garage Tuning Library DTC Tool Register Vendors
Go Back   Diesel Place : Chevrolet and GMC Diesel Truck Forums > GM Diesel Engines > 6.5L Diesel Engine
Register FAQ Forum Rules My Replies My Threads Mark Forums Read Advertise

6.5L Diesel Engine Discuss the 6.5 GM diesel engine & associated components. Automatic transmission questions & problems belong in the 4L80/85 - 4L60E - 6L90 Transmission Forum

DieselPlace.com is the premier Duramax Diesel Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools
Old 03-20-2011, 07:24 PM   #1 (permalink)
Statonigp1
Heat Sink
 
Join Date: Mar 2011
Posts: 13
iTrader Score: 0 reviews

Cut out, won't start, check gauges light not Wait To Start light

1997 6.5L GMC Savana cutaway duelly - Engine just cut out when driving. Would not start again. Check Gauges light is on. The Wait To Start light no longer comes on. Turns over well. Batteries are fine. I think the Lift Pump has stopped working but from what I read that would not stop the engine running. The lift pump for sure was working at least the day before as I could hear it running during Wait to Start and after turning off ignition. Tried direct power to the LP, no luck, so I think it needs replacing. But that doesn't explain the engine stopping if the Inject Pump can "suck" without the LP. If the Oil Pressure Switch needed to be changed, would that cause the engine to cut out and make the Check Gauges light to come on (and also make stop the WTS light coming on)? I did have the Water in Fuel light three times over the past few months, but I opened the fuel filter as instructed and each time it went out and did not come back on? I am pretty sure it is not a case of running out of diesel. At this point I am thinking a new OPS and LP? There was a new IP installed a year ago (previous owner). Are there any other ideas that I should check for? Any other cut out systems? Thanks in advance.

Offline  
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 03-21-2011, 09:51 PM   #2 (permalink)
Statonigp1
Heat Sink
 
Join Date: Mar 2011
Posts: 13
iTrader Score: 0 reviews

I replaced the Oil Pressure Switch (new one from GM). Still not working. Hooked up a new Lift Pump, but it is not "purring" either. It is missing power somewhere. Still no Wait to Start light on the dash. Also, I don't think there is power getting to the Fuel Relay in the fuse box (under the hood). HELP please. I need suggestions. All the other electrics are working. Lights, flashers, interior, heater fan radio. Battery is OK.

Offline   Reply With Quote Quick reply to this message
Old 03-22-2011, 08:46 PM   #3 (permalink)
Statonigp1
Heat Sink
 
Join Date: Mar 2011
Posts: 13
iTrader Score: 0 reviews

Finally there was a bad 20A fuse (ECM-B). That got the the Wait to Start light going again. New OPS and Lift Pump and it started first go. Only remaining problem I have now is the oil gauge on the dashboard is not working. It is stuck completely to the right well past the 550 mark. Any ideas on that?
Offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 03-23-2011, 06:59 PM   #4 (permalink)
Statonigp1
Heat Sink
 
Join Date: Mar 2011
Posts: 13
iTrader Score: 0 reviews

OK final problem solved (just not fixed yet). The connector plug into the top of the OPS needs changed. Bad coonection to the Oil Gauge pin
Offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Diesel Place : Chevrolet and GMC Diesel Truck Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

PLEASE READ! You must check your email inbox for the confirmation link to complete registration. Please check your spam box if you do not see the email in your inbox.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in


Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Wait to start light and check engine light stays on en3chix Duramax Third Generation: 2006-2007.5 (LBZ & LLY) 31 09-19-2011 11:03 AM
Glow plugs / Wait to Start light / GM factory auto start dbunn Duramax Fourth Generation: 2007.5-2010 (LMM) 18 04-20-2010 10:17 AM
No SES Light or Wait to Start Light!! mp4037 6.5L Diesel Engine 4 08-12-2007 11:32 PM
Wait to start light 22seconds and no start... OneTALLGMC96 Duramax Second Generation: 2004.5-2005 (LLY) 10 02-10-2007 12:15 PM
remote start / wait to start light JoBadluck Electrical 3 01-24-2007 08:25 AM


All times are GMT -4. The time now is 06:24 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
SEO by vBSEO 3.6.1
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Shoutbox provided by vBShout v6.2.1 (Lite) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
© AutoGuide