LMM: No oil pressure on start up after sitting for a day - Diesel Place : Chevrolet and GMC Diesel Truck Forums
 
Home Forum Market Place Garage Tuning Library DTC Tool Register Vendors
Go Back   Diesel Place : Chevrolet and GMC Diesel Truck Forums > GM Diesel Engines > Duramax Fourth Generation: 2007.5-2010 (LMM)
Register FAQ Forum Rules My Replies My Threads Mark Forums Read Advertise


Duramax Fourth Generation: 2007.5-2010 (LMM) Discuss the fourth generation (2007.5-2010) of the 6.6L Duramax diesel engine & associated components. Engine related discussion ONLY.

DieselPlace.com is the premier Duramax Diesel Forum on the internet. Registered Users do not see the above ads.
Like Tree2Likes

Reply
 
LinkBack Thread Tools
Old 04-20-2019, 02:20 PM   #1 (permalink)
Octane
Diesel Boss
 
Octane's Avatar
 
Join Date: Aug 2010
Location: Cranbrook,bc
Posts: 1,201
iTrader Score: 0 reviews

No oil pressure on start up after sitting for a day

Hey guys, so I've googled and likely cause they say is a bad drain back valve in the oil filter, and when I try to google the alternatives it always comes back to a filter issue. I've done 4 filters now over the course of an oil change, it seems like it *maybe* fixes it or its intermittent. Running shell t6 5-40 synthetic. Today the truck sat for about 48 hours or so, and I tried remote start it shut down which signals me to my Lack of oil pressure, so I go fire it up with the key and it takes about 5 or 6 seconds til my gauge shows pressure.


I have yet to put a mechanical gauge on it, it does read low like a hot idle is 15 psi. Could be a sending unit lazy? Or maybe the pressure relief valve somehow in the filter housing? If I Remeber right this issue started only on this oil change and I do my own changes.

Truck has about 400k km now.

__________________
1995 Chevy 2500 6.5l Turbo Diesel w/ intake restrictions removed . Diamond eye 4" exhaust straight piped, HX40W-II turbo with a K&N 4" pod ( temporary), ARP head studs & new heads, injectors w/ pop @ 2300 psi, Buddy "3" banger chip, VIN F, Currently running 24# boost-ish


2007.5 Chevy 3500 HD LMM CCLB.
Offline  
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 04-20-2019, 03:01 PM   #2 (permalink)
Ron Nielson
Diesel Pro
 
Ron Nielson's Avatar
 
Join Date: Aug 2009
Location: Berryton, KS
Posts: 2,307
iTrader Score: 0 reviews

Check to make sure the connection to the oil pressure switch is good. Also check for black wire 5V reference, gray - ground, tan and white sensor signal. Cheaper than buying a new sensor that is functioning correctly.

__________________
Ron Nielson

2008 2500HD LT CCLB/Ally. Line-X, B&W Companion, MaxLoader Springs, Edge Insight CTS, Kennedy Custom ECM
2009 Arctic Fox 5er, Silver Fox Edition 29-5T, 3.6 Onan LPG, SteadyFast Stabilizers
Offline   Reply With Quote Quick reply to this message
Old 04-21-2019, 01:36 AM   #3 (permalink)
Octane
Diesel Boss
 
Octane's Avatar
 
Join Date: Aug 2010
Location: Cranbrook,bc
Posts: 1,201
iTrader Score: 0 reviews

Quote:
Originally Posted by Ron Nielson View Post
Check to make sure the connection to the oil pressure switch is good. Also check for black wire 5V reference, gray - ground, tan and white sensor signal. Cheaper than buying a new sensor that is functioning correctly.
Will check the wiring soon here, today I decided to do an oil change, and while I was at it I put a mechanical guage in, I used the plug right in front of what. I believe is the bypass/pressure relief valve? So if memory serves me right it's the pressure of the unfiltered oil however shouldn't matter?

That said. I observed factory read out saying 60 psi through my edge display when revving up, the mechanical gauge was about 70#, then at idle and hot, the mechanical gauge read 20# when truck figured it had 16#, already finding its not accurate at all anymore. Had another start where it took like 6 seconds before pressure was up on the stock gauge/edge but I never thought to check the mechanical gauge on start up. So after a road trip I parked it for 30 and fired it up and this time it was fine, instant pressure lol so it's an intermittent issue? But I got a gauge on it now!

Shouldn't have any issues with readings pre-filtering element hey? It should be the same as after filtered in theory? Or very close until filters getting plugged but it's a fresh filter again.
__________________
1995 Chevy 2500 6.5l Turbo Diesel w/ intake restrictions removed . Diamond eye 4" exhaust straight piped, HX40W-II turbo with a K&N 4" pod ( temporary), ARP head studs & new heads, injectors w/ pop @ 2300 psi, Buddy "3" banger chip, VIN F, Currently running 24# boost-ish


2007.5 Chevy 3500 HD LMM CCLB.

Last edited by Octane; 04-21-2019 at 01:38 AM.
Offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 04-21-2019, 06:31 AM   #4 (permalink)
Rvn4me
Diesel Pro
 
Rvn4me's Avatar
 
Join Date: Jun 2016
Posts: 2,080
iTrader Score: 0 reviews

Michigan Oil Burners Member

What flavor of oil filter do you have. Is it with a Anti-Drainback Valve Type

Last edited by Rvn4me; 04-21-2019 at 06:35 AM.
Offline   Reply With Quote Quick reply to this message
Old 04-21-2019, 10:48 AM   #5 (permalink)
D_R_C
Diesel Prodigy
 
D_R_C's Avatar
 
Join Date: May 2007
Location: Rocky Top, USA
Posts: 4,035
iTrader Score: 0 reviews

I’ve had oil pressure issues with WIX/NAPA GOLD ended up eventually having defective anti-drain back valve on 2 different vehicles.
Resulted in having 0 oil pressure at cold start-ups like when you’ve just changed the oil filter.
All WIX/NAPA filters are off my list, the dmax fuel filters has its issues pretty much across the board with having a plastic housing.
__________________
2007.5 GMC "Black" Sierra SLT 3500HD SRW C.C. 4X4 LMM Z71
DIY stock airbox mod, aFe ProGuard 7, OEM drop-in
EFILive ECM ATP - Heavy Tow Tune with Turbo Brake
EFILive TCM Duramax Tuner
DHD Cold Side High Flow Intake Pipe
DHD PCV Re-route
AirDog 4G100


2007 GMC Yukon Denali "BLACK" 6.2 gasser, DIY stock airbox mod, K & N OEM drop-in, Airaid intake tube, EFILive TCM tuned
Offline   Reply With Quote Quick reply to this message
Old 04-21-2019, 12:09 PM   #6 (permalink)
Octane
Diesel Boss
 
Octane's Avatar
 
Join Date: Aug 2010
Location: Cranbrook,bc
Posts: 1,201
iTrader Score: 0 reviews

I was using Napa gold only for the past 2 or 3 oil changes, before that was always ac delco. never had an issue with them. The Issue coincidencially? started with one filter of the gold filters and or that oil change. I'm now in my 2nd ac delco filter pf2232A? It's a black filter, they used to be blue but has an A at the end of the numbers. Fresh rotella 15-40w, I run 5-40w synthetic for the winter up here in the great white north lol.

If I can trust the current readings of the gauge location then I'm already finding the sensor is somewhat majorly inaccurate.
__________________
1995 Chevy 2500 6.5l Turbo Diesel w/ intake restrictions removed . Diamond eye 4" exhaust straight piped, HX40W-II turbo with a K&N 4" pod ( temporary), ARP head studs & new heads, injectors w/ pop @ 2300 psi, Buddy "3" banger chip, VIN F, Currently running 24# boost-ish


2007.5 Chevy 3500 HD LMM CCLB.

Last edited by Octane; 04-21-2019 at 12:11 PM.
Offline   Reply With Quote Quick reply to this message
Old 04-21-2019, 01:11 PM   #7 (permalink)
dmax3500
Diesel Ace
 
Join Date: Mar 2005
Location: chi-town
Posts: 12,723
iTrader Score: 0 reviews

my truck on start-up shows oil pressure after 4-5 secs


and I use GM filters,AND WALMART HOUSE-BRAND OIL,made by ''mobil'' oil company,[same as mobil 1]
__________________
2013 2500 ltz 4x4 d/a,, fully loaded ,white crew cab
Offline   Reply With Quote Quick reply to this message
Old 04-21-2019, 03:10 PM   #8 (permalink)
Octane
Diesel Boss
 
Octane's Avatar
 
Join Date: Aug 2010
Location: Cranbrook,bc
Posts: 1,201
iTrader Score: 0 reviews

Quote:
Originally Posted by dmax3500 View Post
my truck on start-up shows oil pressure after 4-5 secs


and I use GM filters,AND WALMART HOUSE-BRAND OIL,made by ''mobil'' oil company,[same as mobil 1]
Weird! Does your remote start work fine with it like that? Mine kicks out because it's not seeing oil pressure.
__________________
1995 Chevy 2500 6.5l Turbo Diesel w/ intake restrictions removed . Diamond eye 4" exhaust straight piped, HX40W-II turbo with a K&N 4" pod ( temporary), ARP head studs & new heads, injectors w/ pop @ 2300 psi, Buddy "3" banger chip, VIN F, Currently running 24# boost-ish


2007.5 Chevy 3500 HD LMM CCLB.
Offline   Reply With Quote Quick reply to this message
Old 04-21-2019, 09:45 PM   #9 (permalink)
D_R_C
Diesel Prodigy
 
D_R_C's Avatar
 
Join Date: May 2007
Location: Rocky Top, USA
Posts: 4,035
iTrader Score: 0 reviews

I’d be very suspicious of this black ac delco oil filter, I’ve never seen anything other than blue and don’t remember ever seeing a A at the end of the part number.
a lot of black market copy cat out in our world.
I’ve used ac delco on mine for 12 years.
__________________
2007.5 GMC "Black" Sierra SLT 3500HD SRW C.C. 4X4 LMM Z71
DIY stock airbox mod, aFe ProGuard 7, OEM drop-in
EFILive ECM ATP - Heavy Tow Tune with Turbo Brake
EFILive TCM Duramax Tuner
DHD Cold Side High Flow Intake Pipe
DHD PCV Re-route
AirDog 4G100


2007 GMC Yukon Denali "BLACK" 6.2 gasser, DIY stock airbox mod, K & N OEM drop-in, Airaid intake tube, EFILive TCM tuned
Offline   Reply With Quote Quick reply to this message
Old 04-22-2019, 12:14 AM   #10 (permalink)
Octane
Diesel Boss
 
Octane's Avatar
 
Join Date: Aug 2010
Location: Cranbrook,bc
Posts: 1,201
iTrader Score: 0 reviews

Quote:
Originally Posted by D_R_C View Post
I’d be very suspicious of this black ac delco oil filter, I’ve never seen anything other than blue and don’t remember ever seeing a A at the end of the part number.
a lot of black market copy cat out in our world.
I’ve used ac delco on mine for 12 years.
I know what you mean, it came from a very reputable local automotive parts store so I'd be surprised if they are buying a fake filter per say. But between the Napa gold and this one results are the same of recent.

__________________
1995 Chevy 2500 6.5l Turbo Diesel w/ intake restrictions removed . Diamond eye 4" exhaust straight piped, HX40W-II turbo with a K&N 4" pod ( temporary), ARP head studs & new heads, injectors w/ pop @ 2300 psi, Buddy "3" banger chip, VIN F, Currently running 24# boost-ish


2007.5 Chevy 3500 HD LMM CCLB.
Offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Diesel Place : Chevrolet and GMC Diesel Truck Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

PLEASE READ! You must check your email inbox for the confirmation link to complete registration. Please check your spam box if you do not see the email in your inbox.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in


Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
L5P DIY Oil Change additional information for Diesel Newbie (like me) RDP Maintenance & Fluids 4 12-26-2018 05:57 PM
Question: knock, surge & black smoke Joey Duramax First Generation: 2001-2004 (LB7) 6 11-03-2018 04:19 PM
Low Oil Pressure after Thermostat Change SE-R Spec Duramax First Generation: 2001-2004 (LB7) 6 12-25-2016 08:16 PM
LB7: New to me 2003 questions .... oil pressure and mods. Rmart30 Duramax First Generation: 2001-2004 (LB7) 13 12-11-2016 09:47 PM
Oil pressure problems... Scijad 6.5L Diesel Engine 24 11-16-2015 06:19 AM


All times are GMT -4. The time now is 11:45 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
SEO by vBSEO 3.6.1
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Shoutbox provided by vBShout v6.2.1 (Lite) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
© AutoGuide