glow plug issue plaguing me, need help - Diesel Place : Chevrolet and GMC Diesel Truck Forums
 
Home Forum Market Place Garage Tuning Library DTC Tool Register Vendors
Go Back   Diesel Place : Chevrolet and GMC Diesel Truck Forums > GM Diesel Engines > Duramax Fourth Generation: 2007.5-2010 (LMM)
Register FAQ Forum Rules My Replies My Threads Mark Forums Read Advertise


Duramax Fourth Generation: 2007.5-2010 (LMM) Discuss the fourth generation (2007.5-2010) of the 6.6L Duramax diesel engine & associated components. Engine related discussion ONLY.

DieselPlace.com is the premier Duramax Diesel Forum on the internet. Registered Users do not see the above ads.
Like Tree1Likes

Reply
 
LinkBack Thread Tools
Old 10-29-2015, 08:39 PM   #1 (permalink)
sailinstud420
Glow Plug
 
Join Date: Oct 2007
Location: grand rapids, MI
Posts: 259
iTrader Score: 0 reviews

Michigan Oil Burners Member

glow plug issue plaguing me, need help

Any thoughts on glowplug issue. Truck is telling me #2 plug is bad, I put a new one in and am still intermittently throwing the same code after reseting computer. It will come on at random while driving after cleared, sometimes right away, sometimes after 3 -4 starts while running errands during the day. Seems to almost always trigger itself if I attempt the remote start. What do I check next ?

This could be my ignorance, but I checked the entire drivers side worth of plugs for voltage, I am only getting .02 volts on the meter ?? Why would that be ? I don't see any fuses related to the glowplugs to check either ?

__________________
'07.5 LMM Chevy Reg Cab 2500HD. Stock. 63k miles. Boss 9'2" Poly VXT, 16' Ebling rear.

Reg Cab Member # 70
Offline  
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 10-30-2015, 08:50 AM   #2 (permalink)
sailinstud420
Glow Plug
 
Join Date: Oct 2007
Location: grand rapids, MI
Posts: 259
iTrader Score: 0 reviews

Michigan Oil Burners Member

OEM remote start.

Didn't check pass side

Offline   Reply With Quote Quick reply to this message
Old 10-30-2015, 09:10 AM   #3 (permalink)
vtsquid
Diesel Head
 
vtsquid's Avatar
 
Join Date: Apr 2010
Location: Vermont
Posts: 630
iTrader Score: 0 reviews
Send a message via Yahoo to vtsquid

Was the GP you replaced OEM? If not it will throw a code due to dissimilar resistance compared to the other 7.I found this out the hard way.
__________________
_____________________
2018 Toyota Tundra Platinum Crewmax
SOLD:2008 LMM Silverado 2500 LTZ ECSB 4X4.
Aftermarket calibration by Danville Performance (Autocal w/DSP5), PCV re-route,EGR blocked, Nicktane with Baldwin BF7587, PPE lift pump with Baldwin BF1212 water separator, 285/75/17 Dura Grapplers on H2s, CTS Insight with pyro, Large fender mod.
Proud Member U/A Local 693 Plumbers/Pipefitters.
Offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 10-30-2015, 09:14 AM   #4 (permalink)
c20elephant
Gone but not forgotten member
 
c20elephant's Avatar
 
Join Date: Apr 2013
Location: Phoenix, Az.
Posts: 2,582
iTrader Score: 0 reviews

vtsquid, what combination if glow plugs gave you problems. From my understanding the 61G plug is being discontinued and the 9G is the replacement in the ACDelco.
__________________
~ Mike H ~
2006 EXTENDED CAB LONG BED
Offline   Reply With Quote Quick reply to this message
Old 11-11-2015, 02:55 PM   #5 (permalink)
roger10378
Self Ignition
 
Join Date: Jan 2009
Posts: 75
iTrader Score: 0 reviews

I am having the same problem. Most of the time I don't get a CEL but every so often I do. The frequency varies tremendously. It my be OK for a hundred starts or it may be only one. Some times it doesn't set the CEL until a minute after it starts. It always shows GP 6 or 3. Sometimes it is one, sometimes both. Sometimes there is more than one instance even if only one start. I did have to replace #6 before this started. I used the new GP when I replaced it. All GP are the Delco most of them the original and a couple of replacements that are the new one. I just carry a cheap OBDII scanner so that I can reset the code and keep driving.
__________________
7.5 Chevy 2500HD
Offline   Reply With Quote Quick reply to this message
Old 11-17-2015, 01:32 AM   #6 (permalink)
D_R_C
Diesel Prodigy
 
D_R_C's Avatar
 
Join Date: May 2007
Location: Rocky Top, USA
Posts: 4,041
iTrader Score: 0 reviews

Did you keep track of which cylinders you used the original GP and which cylinders you used the new part number. That way you'd be able to track down which style (new, old or both) is giving you problems.
When I've had a glow plug code and after I clear it, when the engine is warmed up I won't have any code again until the engine sets over night or a cold start before I get the check engine light again.
__________________
2007.5 GMC "Black" Sierra SLT 3500HD SRW C.C. 4X4 LMM Z71
DIY stock airbox mod, aFe ProGuard 7, OEM drop-in
EFILive ECM ATP - Heavy Tow Tune with Turbo Brake
EFILive TCM Duramax Tuner
DHD Cold Side High Flow Intake Pipe
DHD PCV Re-route
AirDog 4G100


2007 GMC Yukon Denali "BLACK" 6.2 gasser, DIY stock airbox mod, K & N OEM drop-in, Airaid intake tube, EFILive TCM tuned

Last edited by D_R_C; 11-17-2015 at 01:33 AM.
Offline   Reply With Quote Quick reply to this message
Old 11-17-2015, 07:29 AM   #7 (permalink)
Ramblinrodney
Diesel Veteran
 
Ramblinrodney's Avatar
 
Join Date: Sep 2006
Location: Midland, MI
Posts: 5,229
iTrader Score: 0 reviews

Michigan Oil Burners Member

sailinstud420 hasn't checked back in since his last post to see his responses so he must of found his fix or it's not that important to him. There are so many people like this, start a thread and never check the posts.
__________________
07 Chevy Classic 2500HD 4x4 2LT LBZ CC/SB White
Nasta Nerf Bars, Line-x, Rancho RS9000XL Shocks, Firestone air bags, Fold-a-cover,
Good/Year Wrangler S/A 265/75/16 E
Transgo Jr. PCV Reroute kit, Trans Line Repair Kit By Dirty Hooker Diesel,
Custom Perf/Tow Tune by Kennedy
2019 Arctic Fox 27-5L 10,500 dry weight
UAW Local 699 Retired Test Technician

Last edited by Ramblinrodney; 11-17-2015 at 07:31 AM.
Offline   Reply With Quote Quick reply to this message
Old 01-25-2016, 10:34 AM   #8 (permalink)
gmason
Clutch
 
Join Date: Mar 2004
Location: NC
Posts: 57
iTrader Score: 0 reviews

New glow plug, same error code

It's in the 20s and 30s here this week and last week I had glow plug number 3 replaced at my mechanic. the Truck sat there for a few days and when I picked it up the CEL was still on. He connected his scanner and reset the code right then. He said he thought he reset it when they replaced it a few days before. The truck ran for 5-10minutes before he reset and I tested the Remote Start to be sure.


Then after the truck sat for a few days in some cold weather I tried a remote start and the same error code popped up again.


It sure sounds like a battery or bad connection issue rather than a glow plug issue??
Next step I think I'll take and have the batteries checked for Cold Starting Amps to see if that could be the source of the issue.
Any ideas?


thanks
gary
__________________
2008 GMC 2500HD CC LineX
Offline   Reply With Quote Quick reply to this message
Old 01-25-2016, 10:50 AM   #9 (permalink)
Smoky_222
Sparkplug Hunter
 
Join Date: Dec 2015
Location: Sweetwater Texas
Posts: 1
iTrader Score: 0 reviews

I'd have to agree with everyone that says the glow plugs resistance. I found out the hard way about using non-OEM plugs. They worked but if the truck sat for a day or so, or was really cold during the night I'd get that plug number 2 was bad and sometimes 2 and 4 after I replaced them all with a cheaper brand. I was thinking it was my batteries since it sounded like a little drag starting. I finally read enough on it and decided to buy the AC Delco G9 that is what my 09 calls for. I haven't had a lick of problems since and my truck has sat for days and its been real cold since I replaced them. Make sure you or your mech. uses anti-seez on the news.
__________________
Cesar Ortiz 09 Duramax 2500hd
Offline   Reply With Quote Quick reply to this message
Old 01-25-2016, 12:21 PM   #10 (permalink)
D_R_C
Diesel Prodigy
 
D_R_C's Avatar
 
Join Date: May 2007
Location: Rocky Top, USA
Posts: 4,041
iTrader Score: 0 reviews

Did your mechanic use OEM A/C Delco or a aftermarket cheaper quality brand?
Verify that he changed #3, I've know many mechanics that have changed the wrong one's,
That's why I'll do my own.

Like smoky said only use OEM AC Delco, I was using the G61 but now the G9's (newer model) they are priced better on Amazon.

__________________
2007.5 GMC "Black" Sierra SLT 3500HD SRW C.C. 4X4 LMM Z71
DIY stock airbox mod, aFe ProGuard 7, OEM drop-in
EFILive ECM ATP - Heavy Tow Tune with Turbo Brake
EFILive TCM Duramax Tuner
DHD Cold Side High Flow Intake Pipe
DHD PCV Re-route
AirDog 4G100


2007 GMC Yukon Denali "BLACK" 6.2 gasser, DIY stock airbox mod, K & N OEM drop-in, Airaid intake tube, EFILive TCM tuned
Offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Diesel Place : Chevrolet and GMC Diesel Truck Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

PLEASE READ! You must check your email inbox for the confirmation link to complete registration. Please check your spam box if you do not see the email in your inbox.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in


Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
LBZ: I changed my #4 glow plug today tjg Duramax Third Generation: 2006-2007.5 (LBZ & LLY) 12 12-09-2015 02:53 PM
LMM: Glow Plug Replacement Issue jspafford Duramax Fourth Generation: 2007.5-2010 (LMM) 4 10-20-2015 04:28 PM
Reparing Glow Plug Harness ForeverFalcon40 6.5L Diesel Engine 10 10-06-2015 04:38 PM
Possible Short? Glow Plug and Low coolant lights stay on FOREVER! jkbowen 6.2L Diesel Engine 32 10-02-2015 11:30 PM
LML: Poor Qual DEF & Glow plug bad navybanker Duramax Fifth Generation: 2011-2016 (LML) 5 09-16-2015 04:39 PM


All times are GMT -4. The time now is 02:26 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
SEO by vBSEO 3.6.1
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Shoutbox provided by vBShout v6.2.1 (Lite) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
© AutoGuide