No power, lift pump running with no key! - Diesel Place : Chevrolet and GMC Diesel Truck Forums
 
Home Forum Market Place Garage Tuning Library DTC Tool Register Vendors
Go Back   Diesel Place : Chevrolet and GMC Diesel Truck Forums > GM Diesel Engines > Duramax Third Generation: 2006-2007.5 (LBZ & LLY)
Register FAQ Forum Rules My Replies My Threads Mark Forums Read Advertise

Duramax Third Generation: 2006-2007.5 (LBZ & LLY) Discuss the third generation (2006-2007.5 LBZ & LLY) of the 6.6L Duramax diesel engine & associated components. 2006 LLY engine discussion also belongs in this forum due to the similarities of the 2006 LBZ and the 2006 LLY. Engine related discussion ONLY.

DieselPlace.com is the premier Duramax Diesel Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools
Old 09-18-2017, 05:04 AM   #1 (permalink)
schaefertribe
Low Boost
 
schaefertribe's Avatar
 
Join Date: Jan 2008
Posts: 7
iTrader Score: 0 reviews

No power, lift pump running with no key!

So last week I went out to my LBZ to pop the hood and check the coolant level as I've been trying to eliminate a "coolant vanishing after a few hundred miles" problem. I unlocked it with the fob, popped the hood, checked the coolant, closed it and hit the lock on the fob. No lock, no beep, nothing, so went to open the driver door and heard the lift pump running, with no key WTF! Had to get to work, so pulled the pump fuse and left.

Scoured all the forums that evening and narrowed some possibilities to 1-neutral safety switch, 2-ignition switch and 3-tcm. Got in my truck, put the key in, still nothing, turned it to on and cycled the shifter several times. Boom! All lights n whistles come on and it fires right up. Let it idle for a few, then shut it off and dead. Tryed cycling the shifter again, several times, nothing.

Talked to an Allison shop nearby and he said it probably wasn't the NSS, sounded like the tcm, so naturally I ordered an ignition switch. Don't judge, it was $30, anyways once I got the new switch, swapped it, I could get only dash lights, no crank, no door locks and the lift pump was still running with the key out. So then I get in the engine compartment and start checking the wire harness for the tcm, ECM and BCM. As I'm gently moving them I can hear a click near the firewall and the lift pump shut off. Move it again, then back on.

So I spent this weekend unwrapping most of the wiring on the driver's side in the engine looking for a short, cleaning all the harness connectors inside and out and checking for anything out of the ordinary. Of course all batteries were disconnected. The only thing I found was a Stoopid fried pack rat that thought the positive and negative posts between the fuse block and fire wall was a good bed. I know what you're thinking but I spent hours searching for chewed wiring, none that I found.

So I've got everything rewrapped and buttoned back up and as I'm hooking the batteries up, the only thing that I found strange was the pass side battery hooks up normal, no arcing but the driver side arced a bit when i was getting the pos lead on. Changed batteries quite a few times and I never noticed it doing that unless the wrench hits something.

Anyways, put the key in, all lights come on and it fires right up however abs light, cel, no door locks and all gauges stay at 0. Shut it off, check every fuse, inside and out, all good, then fire it up again, everything is doing what it's supposed to and still has the cel. Pulled the U1301 and P2610 codes, cleared them, started n stopped it several times and had the p2610 come back once before I left for work.

So, given the novel I've written above, do any of you fine dmax owners have any good advise, other things to check, etc.? I refuse to take it to the stealer and I haven't found any reputable local shop in Tucson that like to give my hard earned cash to. Does this sound like a tcm, BCM or even possibly bad chassis fuse block?

Btw, it has the FASS 150 lift pump and efilive autocal with dsp5, been on for about a year with no problems

__________________
2006 2500HD 4X4, LBZ with Banks catback Monster Exhaust
Offline  
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 09-18-2017, 08:54 AM   #2 (permalink)
G2GBY
Diesel Boss
 
G2GBY's Avatar
 
Join Date: Aug 2017
Posts: 1,226
iTrader Score: 0 reviews

Most people get P2610 after 1st installed PPE programmer or changing tune levels but I don't see one in your Signature. it doesn't effect performance.

Code:P2610 Modules: ECM, PCM
Description:Control Module Ignition Off Timer Performance

#PIP4403: Control Module Ignition On Timer Performance DTC P2610 - keywords 6.6 cal calibration ECM engine LBZ LLY MIL replace replacement - (May 1, 2008)
Subject: Control Module Ignition On Timer Performance DTC P2610

Models: 2006-2007 Chevrolet Express, Kodiak, Silverado
2006-2007 GMC Savana, Sierra, Topkick
Equipped with the 6.6 Diesel Engine RPO codes LBZ or LLY
The following diagnosis might be helpful if the vehicle exhibits the symptom(s) described in this PI.

Condition/Concern:
A dealer may encounter a customer complaint of a check engine light (SES light ON) and a P2610 DTC may be stored in the ECM. This DTC may set intermittently after a reflash of certain modules such as the transmission control module (TCM), or glow plug control module (GPCM). Additionally, any loss of battery voltage to the ECM while the ignition is ON, can also cause a P2610 to set.

Recommendation/Instructions:
If a P2610 has been verified do not replace the ECM. Perform the following steps when encountering a P2610.

Turn the IGNITION OFF for 90 seconds. Unplug both the engine control module (ECM) connectors for 90 seconds. After 90 seconds has passed, re-install the ECM connectors. With the ignition on use the Tech2 and clear all codes in the ECM. This procedure should prevent future sets of the P2610. For 2006 and certain 2007 model vehicles, there may also be a calibration update available which addresses P2610 false sets.

Some people do this for P2610
Try this
" DTC P2610 is set if an internal ECM problem is detected.
1.With ignition OFF, remove both ECM connectors.
2.Wait at least one minute.
3. Replace the connectors making sure to completely seat and lock them.
4.Turn the ignition ON with the engine OFF, and clear the stored codes.Verify the MIL light turns OFF, and stays OFF. If the MIL light does not turn OFF, repeat the clear code command until it the MIL light remains OFF.
5.Turn OFF the ignition and leave it OFF for at least one minute.
6.Turn the ignition back ON with engine OFF and observe that the DTC does not reset.
If the DTC P2610 is still set, repeat Steps 1 through 6 one additional time. If Steps 1 through 6 still do not correct the DTC P2610, verify there is constant battery voltage to ECM Connector C1- terminal 77. (circuit 440 / orange wire) If battery voltage is not present on Connector C1- terminal 77, troubleshoot and repair the circuit.

It is something about an internal problem with the ecm. It happens when there's a short or something in the battery. This process just resets the ecm.


Code-U1301
Modules-DRR, EBCM, ECM/PCM, HVAC Control Module, IPC, Radio, RWSCM, CDX, RSA, RSE, SDM, TCM, Theft Deterrent
Description:Class 2 Data Link High

You said you checked every fuse. You even checked the 125A and 175A fuses under the plastic fuse panel cover?
Your batteries good?
The large plug on the rear of the transmission is good?
Have you ohmed all wires and pins for the GMLAN data.
Have you tryed a good TCM?
https://www.justanswer.com/chevy/9y6...z-duramax.html
There's so much on this code.
Google "Duramax LBZ U1301" lots to read


Last edited by G2GBY; 09-18-2017 at 09:20 AM.
Offline   Reply With Quote Quick reply to this message
Old 09-19-2017, 01:06 AM   #3 (permalink)
schaefertribe
Low Boost
 
schaefertribe's Avatar
 
Join Date: Jan 2008
Posts: 7
iTrader Score: 0 reviews

Ok, that's some good info. Will go thru the ECM reset tomorrow. As for the 2 big fuses, nope, forgot about them and no I didn't know about the plug on the back of the trans. Will CK that either. As for ohming out the obd2 port, gonna have to do some reading and borrow a multimeter first. Thanks for your reply. I really do appreciate it!
__________________
2006 2500HD 4X4, LBZ with Banks catback Monster Exhaust
Offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Diesel Place : Chevrolet and GMC Diesel Truck Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

PLEASE READ! You must check your email inbox for the confirmation link to complete registration. Please check your spam box if you do not see the email in your inbox.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in


Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Power steering pump issues kodiak diesel Suspension & Steering - 2001 - 2010 17 03-06-2017 05:44 PM
92 GMC 6.2 Diesel lift pump won't work after injector pump replacement deercamp101 6.2L Diesel Engine 13 09-21-2016 08:02 AM
Stalling: Ground locations on 6.5 1997 Express van CampVan 6.5L Diesel Engine 86 05-10-2016 08:56 PM
LB7 losing prime/ lift pump LB7Dirty Fuel System, Air, Exhaust, & Emissions Upgrades 1 01-06-2016 11:58 PM
Info: The 6.5L FAQ's... The Master List of Information and 6.5 Answers knkreb 6.5L Diesel Engine 16 07-15-2015 12:42 PM


All times are GMT -4. The time now is 11:26 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
SEO by vBSEO 3.6.1
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Shoutbox provided by vBShout v6.2.1 (Lite) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
© AutoGuide