Need help with built trans - Diesel Place : Chevrolet and GMC Diesel Truck Forums
 
Home Forum Market Place Garage Tuning Library DTC Tool Register Vendors
Go Back   Diesel Place : Chevrolet and GMC Diesel Truck Forums > GM Transmissions > Allison Aftermarket
Register FAQ Forum Rules My Replies My Threads Mark Forums Read Advertise

Allison Aftermarket Discuss aftermarket Allison upgrades as well as repairing & maintaining them.

DieselPlace.com is the premier Duramax Diesel Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools
Old 07-14-2019, 02:46 PM   #1 (permalink)
Durtydiesel06
Glow Plug
 
Durtydiesel06's Avatar
 
Join Date: May 2007
Location: Toronto
Posts: 270
iTrader Score: 0 reviews
Send a message via ICQ to Durtydiesel06 Send a message via MSN to Durtydiesel06

Ontario Diesel Place Chapter Member

Need help with built trans

ok i wil try not to ramble too much here, but my transmission was built by big dipper , who by the way is AMAZING. i had it refreshed in 2017 by him. i use my truck for mostly hauling my gooseneck tandem tandem 30 foot load trail a few times a week for a couple hundred kms each time, loaded with my 90 hp skid steer and 2 ton mini ex and sometimes 4-6 landscape trees.
Anyway, after getting my truck back in 2017, and putting it back to work, i ended up cracking a piston, which i was expecting , after 900,000 kms of hard work with a lot of mods and power put to it.
well i had another engine from another truck at my farm so i decided to swap it. my neighbor and also my little sisters bf offered to help so they could learn.
so we tackled it on a friday night and the doner engine i knew needed a rear main seal, so i got a new one from the dealer ahead of time along with red loctite. well while swapping the engine , i was busy with swapping my turbo, so i had my sisters bf who claimed he is a mechanic , do the rear main seal. so i handed him the loctite and told him to put it on the flywheel bolts before reinstalling them. well anyway. after the swap.. all was good until march this year, and i was starting to hear the odd rattle... i couldnt pinpoint it ... until one day i took the truck to the beer store and i was cruising and all of a sudden the truck just fell flat on its face but stayed running. coasted to the shoulder and called my dad to bring his truck to tow me back home.
after getting it home and looking at it with the inspection plate off , i figured something was seriously wrong. so i tore into it and removed the trans to find that the flexplate and trans mount plate was broke and the bolts were so loose. i will try to inlcude pictures. anyway,

i took the flexplate off and replaced it with the ones from my other engine.
i reinstalled the trans, and worked fine the first cruise but once i hooked the trailer to it , it limped and threw p0701 p0872 for sure and i think a few others in the p0873 or whatever anyway....also said range shift inhibited... and i swappd the nsbu switch and no change. basically i began by starting the truck and removing the plug beside the external filter.. well i removed it and nothing and then not a half a second later and it blew fluid all over my face and inmy mouth faster then i could react. i shut the truck off and reinstalled the plug, and tried the truck again.. worked for a trip up the road and then limped again but i did notice a delay in engagement from park to drive or park to reverse.

i then unplugged the rear trans plug on the passenger side and found that there was trans fluid in the pin area. so i cleaned it and tested it again and worked for a trip up the road and back and limped again... ( i have a tech 2 so i just cleaned the plug and cleared the codes ) and got it home, so then i figured , not much left to do, swap the valve body and internal harness.. so i did that the other day.. and the truck runs and drives ... no codes at all... BUT the delayed engagement is kinda worrying me and leaning me towards the transmission pump. like i said there is no codes at all.. but if i start the truck right now and put it right to drive, i have to wait like 4-5 seconds before the engagement... can anyone chime in ? maybe tell me that im on the right path? i also bought a transmission pressure gauge kit to test it but i dont have the right adapter for it yet...

__________________
2005 Chevy 2500HD LLY, Crew Cab, Short box, Fully Loaded.
Cognito Kazuaki complete suspension w/ Fox shocks, Cognito UCA's, Cognito braces, Cognito traction bars, Cognito HD tie rods.
Alpine IVA-W505/P1 w/XM tuner. Banks Diesel Dual Exhaust, with the Banks LBZ Ram Air Intake and the LBZ mouthpiece. ARP head studs.

Pro Flow shorty "Y" bridge, and 3" boost tube. Pro Flow log Headers and up pipes ceramic coated inside & out. ISSPRO EV2 boost & pyro gauges W/ SoCal overhead pod. EFI Live with DSP5. SCIV(BIGDIPPER) With ML, HTT, Air Dog II, SoCal 45 over injectors.

Last edited by Durtydiesel06; 07-14-2019 at 02:50 PM.
Offline  
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 07-18-2019, 11:24 PM   #2 (permalink)
Durtydiesel06
Glow Plug
 
Durtydiesel06's Avatar
 
Join Date: May 2007
Location: Toronto
Posts: 270
iTrader Score: 0 reviews
Send a message via ICQ to Durtydiesel06 Send a message via MSN to Durtydiesel06

Ontario Diesel Place Chapter Member

noone have any input guys ?

__________________
2005 Chevy 2500HD LLY, Crew Cab, Short box, Fully Loaded.
Cognito Kazuaki complete suspension w/ Fox shocks, Cognito UCA's, Cognito braces, Cognito traction bars, Cognito HD tie rods.
Alpine IVA-W505/P1 w/XM tuner. Banks Diesel Dual Exhaust, with the Banks LBZ Ram Air Intake and the LBZ mouthpiece. ARP head studs.

Pro Flow shorty "Y" bridge, and 3" boost tube. Pro Flow log Headers and up pipes ceramic coated inside & out. ISSPRO EV2 boost & pyro gauges W/ SoCal overhead pod. EFI Live with DSP5. SCIV(BIGDIPPER) With ML, HTT, Air Dog II, SoCal 45 over injectors.
Offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Diesel Place : Chevrolet and GMC Diesel Truck Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

PLEASE READ! You must check your email inbox for the confirmation link to complete registration. Please check your spam box if you do not see the email in your inbox.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in


Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 10:09 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
SEO by vBSEO 3.6.1
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Shoutbox provided by vBShout v6.2.1 (Lite) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
© AutoGuide