95 Step-Van - Stuck in Limp Mode? - Diesel Place : Chevrolet and GMC Diesel Truck Forums
 
Home Forum Market Place Garage Tuning Library DTC Tool Register Vendors
Go Back   Diesel Place : Chevrolet and GMC Diesel Truck Forums > GM Transmissions > 4L80/85E Transmissions. 6L90 Transmission
Register FAQ Forum Rules My Replies My Threads Mark Forums Read Advertise

4L80/85E Transmissions. 6L90 Transmission Discuss the 4L80/85E transmissions found in the 6.2/6.5L equipped vehicles and Duramax equipped vans. 6L90 discussion.

DieselPlace.com is the premier Duramax Diesel Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools
Old 01-07-2016, 02:46 PM   #1 (permalink)
Still Bill
Glow Plug
 
Join Date: Nov 2015
Posts: 243
iTrader Score: 0 reviews

95 Step-Van - Stuck in Limp Mode?

Hello- Greetings from not-so-sunny Florida. I am having a problem with my Step-Van. Seems to be stuck in Limp mode.

1. State model, year of vehicle and mileage: 1995 Chevy Step Van, 221K miles. 6.5L diesel, no turbo.

2. How long did you own the truck? Recent purchase? Purchased two months ago.

3. Any service engine light: yes/no. Intermittent check engine light? This is called CEL or MI: I have never seen the SES light come on - not even at start-up. Bulb is good. The TRANS light was on constantly - until the transmission went into LIMP mode, now it stays off. Bulb is still good.

4. Fluid level okay with the engine and transmission warm? Check on a level surface? Yes - light red color - no odor.

5. Have you retrieved Codes? AKA DTCs Diagnostic Trouble codes. I tried by jumping A-B, but no lights blink. The SES bulb is good, but I have never seen this light come on. I would like help getting this diagnostic function working. TRANS light was on constantly until Tranny started messing up.

6. Fluid color and smell? Red or Brown does the fluid smell burnt? Light red, clear, no odor at all.

7. Speedometer reading correctly at the appropriate speed? Are the tires the within OEM specifications and size? Use your GPS and verify speed. electronic transmissions remember? Tires are correct size and speed seems correct. Do not have GPS.

8. Is the transmission shifting normal? Is it shifting hard? Do recall the shifting symptoms or any shifting changes before or after the check engine light or after you retrieved codes. Trans was working fine - EXCEPT for a very FIRM/QUICK 1-2 shift. Previous owner said it was always like that for years. Now it appears to be stuck in 2 (or 3rd?). Does not respond to gearshift lever. Trans light was ON until this started happening, now it is off.

9. Did you or anyone else conduct any kind of maintenance to the vehicle recently? YES, but it was working normal for a few days after the following was done: New brakes front & rear, including master cylinder. New rear tires (same size as old), oil change, new power steering hoses, new radiator hoses.

10. Can you explain the type of driving? Heavy towing? Snowplowing? Just normal driving - empty truck with with no load.

11. Typical weather. Arizona hot mild winters? Minnessota cold. Please explain. Florida winter - 55-75 degrees.


10. Any problems with driver commanded/selected shifting into any gear?
ie.. 1st, 2nd, 3rd, 4th, Rev?
Does not respond to changing forward gear selection, either up-shifting or down-shifting. Reverse works fine.


8. Describe symptoms: Does the transmission refuse to shift in first? Will it shift into second and just stay in second gear? Seems stuck in 2nd (or 3rd?).

8a. TCC Locking? Is the transmission slipping in any gear? Can't tell in current situation.

8b. Is the transmission shifting into all FWD gears? At the
normal RPMs while the shift selector is in drive? Is it shifting later
than usual? See above answers.

Can your vehicle shift into all gears?
If you have a tachometer can you "notice" all forward gears shifting if you are not sure if the transmission is shifting? See above answers.

I should add that I checked the wire connector at rear of transmission. Unplugged, and it was completely dry, with no oil in harness.


Last edited by Still Bill; 01-07-2016 at 02:49 PM.
Offline  
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 01-07-2016, 03:44 PM   #2 (permalink)
Still Bill
Glow Plug
 
Join Date: Nov 2015
Posts: 243
iTrader Score: 0 reviews

Also - (can't find Edit button, so I'll add here)

Just replaced all glow plugs (but tranny was working fine after that). Also - There is a wire with a clip hanging-down near the PS pump. Has a round plug that looks like it clips onto some kind of sensor stud, but I can't find where it belongs. Goes into wire harness. Will try to get photo and post.

Offline   Reply With Quote Quick reply to this message
Old 01-07-2016, 07:58 PM   #3 (permalink)
Still Bill
Glow Plug
 
Join Date: Nov 2015
Posts: 243
iTrader Score: 0 reviews

Update:


Driving vehicle this evening - going downhill and hit a big bump. Tranny started working normally for one mile, then went back to Limp. Good news, I suppose - must be a loose wire?


Anyhow, water pump failed a few miles later! While working on that, I found that the loose connector is supposed to be on the brake line junction box.
Offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 01-11-2016, 06:31 AM   #4 (permalink)
Still Bill
Glow Plug
 
Join Date: Nov 2015
Posts: 243
iTrader Score: 0 reviews

Well, problem solved! Seems that when I was checking all the fuses recently, I replaced the ECM power fuse into the empty slot above where it was supposed to go.


Tranny now shifts normally (still very firm 1-2 shift though). Error codes work (the TRANS light is what blinks - no SES light I guess). Got error codes 22 (accelerator pedal low) and 71 (Cruise Control). Tried to clear them, but no dice.
Offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Diesel Place : Chevrolet and GMC Diesel Truck Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

PLEASE READ! You must check your email inbox for the confirmation link to complete registration. Please check your spam box if you do not see the email in your inbox.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in


Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Limp Mode, No Power Master_wayne01 Duramax First Generation: 2001-2004 (LB7) 9 11-19-2015 02:34 PM
Can transfer case make your tranny go into limp mode? Lonewolf867 Drivetrain - 2001 - 2010 5 11-09-2015 10:25 PM
Limp mode Ltaylor Duramax Third Generation: 2006-2007.5 (LBZ & LLY) 0 11-02-2015 12:51 PM
Limp mode - I think? akfamily 4L80/85E Transmissions. 6L90 Transmission 2 09-16-2015 12:50 PM
2011 lml changed tcm and still in limp mode dford27 Duramax Fifth Generation: 2011-2016 (LML) 5 09-15-2015 12:05 AM


All times are GMT -4. The time now is 04:06 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
SEO by vBSEO 3.6.1
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Shoutbox provided by vBShout v6.2.1 (Lite) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
© AutoGuide