Heated seats not working - Diesel Place : Chevrolet and GMC Diesel Truck Forums
 
Home Forum Market Place Garage Lounge (3) Tuning Library DTC Tool Register Vendors
Go Back   Diesel Place : Chevrolet and GMC Diesel Truck Forums > Speciality Forums > Electrical
Register FAQ Forum Rules My Replies My Threads Mark Forums Read Auto EscrowAuto LoansInsurance

DieselPlace.com is the premier Duramax Diesel Forum on the internet. Registered Users do not see the above ads.
Like Tree2Likes

Reply
 
LinkBack Thread Tools
Old 11-23-2009, 01:29 PM   #1 (permalink)
nhraracer90
Diesel Technician
 
Join Date: Dec 2005
Posts: 496
iTrader Score: 0 reviews

Heated seats not working

Hello,
I have an 04 Chevy 3500 with leather seats. My heated seats are not working, when I press the button on the door panel, it will light up for a few seconds (if that) and cut right back off. I can hear something under the seat click off when the lights on the button go off. Is it the switch in the door panel or something under the seat? Thanks
__________________
2004 Chevy 3500 CC Dually LB7 Duramax/Allison Blk on Blk LT loaded 72k MBRP 4inch exhaust
Offline  
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 11-25-2009, 12:42 AM   #2 (permalink)
banshee1973
Diesel Master
 
banshee1973's Avatar
 
Join Date: Feb 2005
Location: Colorado
Posts: 1,524
iTrader Score: 2 reviews

Anyone?
__________________
2005 Duramax LLy Banks Ram Air intake,Kodiak mouth piece, Banks exhaust turbo back, Nexus pyro,boost gauges Efilive V2 Trippin Kennedy Lift pumps & filter head, FS-2500 OIL FILTER BYPASS SYSTEM, BILLET FUEL PICKUP, PPE Egr delete kit, Lb7 Riser pipe,
Front Elocker, Rear Tru-trac locker Hid's high and low beam's, Diamond Eye Turbo down pipe,
7" to 9" Cognito lift set at 7" with 6" deavers and Uca and shock hoop's and Fox shock's, Cognito front swaybar and end link's, 18x10 Weld Evo's Xt's. on Toyo M/T open country's 35/12.50 R18
Amp Research Step's. Maxbrake controler, 4.11 gear ratio, Pac exhaust brake Eric Merchant pump upgrade Carli Suspension LONG travel air bags, Road Armor front bumper! Dmaxstore.com performancetruckproducts.com/
Offline   Reply With Quote Quick reply to this message
Old 11-25-2009, 12:51 AM   #3 (permalink)
Mike2112
Diesel Technician
 
Mike2112's Avatar
 
Join Date: Apr 2008
Location: Olympia, WA
Posts: 296
iTrader Score: 0 reviews

See if your power seat on the driver side stops working at the same time.

If it does you have a loose ground wire under that seat. It affects both seat heaters and the power on the driver's seat.

That thing drove me nuts for months until I found the problem. I guess it is fairly common.
__________________
2004.5 LLY
D60 Solid Front Axle
MPI Twin Turbos
Suncoast Transmission
Much More
See Garage...
Offline   Reply With Quote Quick reply to this message
Old 11-25-2009, 08:00 PM   #4 (permalink)
Big Blue Durama
Diesel Technician
 
Big Blue Durama's Avatar
 
Join Date: Jan 2009
Location: Long Grove, Iowa
Posts: 135
iTrader Score: 1 reviews

Midwest Smokers Member

Mine does the same thing. I have already changed the switch out thinking it was that, but I think its the heating elements. Just havent opened the seat up to check and see. It would be helpful if someone has had the same issue and what they did to fix it.
__________________
2007.5 Crew Cab, LTZ, LMM, Banks intake with scoop, Banks driver's side inter cooler boost tube, Truxedo low profile cover, Nitto 285/70r/17 on stockers, LEVELED,Merchant tie rod sleeves,Bilsteins 5100s,Cognito pitman support,green keys,20%tint,linex,and more to come!

SOLD 2003 4x4, SB, LT, Crew Cab, Keys, 3" body lift, Bilstein 5100,Merchant SS Tierod

67 Chevy Camaro(owned for 24 yrs),Frame Off Restoration, 327 sbc, .60over,12.5 to 1 compression,roller rockers, geardrive, march pulleys, MSD 6AL ignition,MSD Billet Distributor, 3" dual exhaust single chamber 40 series flowmasters, 10bolt 4.11 gears, 4spd M22,
Offline   Reply With Quote Quick reply to this message
Old 11-25-2009, 08:18 PM   #5 (permalink)
cooltoolguy
Diesel Head
 
cooltoolguy's Avatar
 
Join Date: Jun 2009
Location: new joisey
Posts: 44
iTrader Score: 0 reviews

ok, when you say it clicks, is it just the driver seat? does the passenger seat heater work properly if you use only the passenger seat? if it does, does passenger seat shut off when you turn on driver seat? i just went through this and it was a burned element on the driver seat back. get a mutli meter and check resistance, anything over i think 5.5 means burnt element. you can do this with out ripping seat apart. there is a grey plug under seat with six wires at the rear.
__________________
2003 GMC cc/dually d/a SLT 4x4,K&N filter, Silent Armor tires,
2003 Kawi ZX12R
1988 YJ wrangler
1988 YJ Laredo
1995 YJ Sport
2001 TJ Sahara
1986 C10 with LT-1 SPFI (sleeper)...RIP :-(
Offline   Reply With Quote Quick reply to this message
Old 11-29-2009, 12:01 AM   #6 (permalink)
nhraracer90
Diesel Technician
 
Join Date: Dec 2005
Posts: 496
iTrader Score: 0 reviews

ok...when I turn the passenger side on, it does the same thing as the driver side. It will stay on for a second or sometimes a few then turn off and I hear the same click noise under the driver seat..a bad ground somewhere under the seat like mike2112 said?
__________________
2004 Chevy 3500 CC Dually LB7 Duramax/Allison Blk on Blk LT loaded 72k MBRP 4inch exhaust
Offline   Reply With Quote Quick reply to this message
Old 11-29-2009, 03:59 PM   #7 (permalink)
nhraracer90
Diesel Technician
 
Join Date: Dec 2005
Posts: 496
iTrader Score: 0 reviews

there is a black box that has some plus going into it under the driver seat that is making that noise
__________________
2004 Chevy 3500 CC Dually LB7 Duramax/Allison Blk on Blk LT loaded 72k MBRP 4inch exhaust
Offline   Reply With Quote Quick reply to this message
Old 11-29-2009, 08:25 PM   #8 (permalink)
cooltoolguy
Diesel Head
 
cooltoolguy's Avatar
 
Join Date: Jun 2009
Location: new joisey
Posts: 44
iTrader Score: 0 reviews

the black box is the seat module and the click is normal, both seat are doing this, so first check your heating elements and rule them out, there is a grey 6 wire connect uder each seat which has the wires for the elements (upper and lower) the plug should be near the rear of seat. if the readings come back in spec, start checking for a rubbed through wire, melted connecter, or a shorted wire under the seat, or between seats. also check the two wires which run from under seat to seat belt latch, they do rub through
__________________
2003 GMC cc/dually d/a SLT 4x4,K&N filter, Silent Armor tires,
2003 Kawi ZX12R
1988 YJ wrangler
1988 YJ Laredo
1995 YJ Sport
2001 TJ Sahara
1986 C10 with LT-1 SPFI (sleeper)...RIP :-(
Offline   Reply With Quote Quick reply to this message
Old 11-30-2009, 07:06 AM   #9 (permalink)
cooltoolguy
Diesel Head
 
cooltoolguy's Avatar
 
Join Date: Jun 2009
Location: new joisey
Posts: 44
iTrader Score: 0 reviews


gray six wire plug under seat comes from seat back element and also feeds seat bottom


yellow and blk - seat back element brn and blk seat bottom, 2 in middle rd/blk dont test



just put test probes into connector, again one in yellow and one in black next to yellow then one in brn and one in black next to the brn. meter set to measure ohms, 6.8 too high must be under 5.0



toasty!
__________________
2003 GMC cc/dually d/a SLT 4x4,K&N filter, Silent Armor tires,
2003 Kawi ZX12R
1988 YJ wrangler
1988 YJ Laredo
1995 YJ Sport
2001 TJ Sahara
1986 C10 with LT-1 SPFI (sleeper)...RIP :-(

Last edited by cooltoolguy; 11-30-2009 at 07:22 AM.
Offline   Reply With Quote Quick reply to this message
Old 12-10-2010, 01:43 AM   #10 (permalink)
bigred74k20
Diesel Fanatic
 
bigred74k20's Avatar
 
Join Date: Jan 2007
Posts: 94
iTrader Score: 0 reviews

Hey guys, I know I am digging up an old thread here. My situation is that the driver heated seats turn off after 10 seconds and the Passenger side works fine until I turn the driver side on and it shuts them both down.

I Just checked the resistance on both seats and both upper and lower warmers all fell between 5.7-6.0 ohms... I don't understand why the passenger seat works fine and they have the same resistance as the drivers seat.

Any help would be appreciated
Offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Diesel Place : Chevrolet and GMC Diesel Truck Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
heated seats not working; driver's seat won't move GreyFox1981 Electrical 1 07-04-2010 02:23 PM
heated seats not working olivertractor Electrical 1 08-30-2009 11:24 AM
Heated Seats Not working djv72 Interior 12 11-06-2007 10:20 PM
Heated seats not working right WSS Interior 5 01-10-2007 01:30 AM
02 heated seats fromoo Interior 1 12-20-2006 03:09 PM


All times are GMT -4. The time now is 11:53 PM.


Shoutbox provided by vBShout v6.2.1 (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
© AutoGuide

SEO by vBSEO 3.6.0