cat 3116 engine problems - Diesel Place : Chevrolet and GMC Diesel Truck Forums
 
Home Forum Market Place Garage Lounge (0) Tuning Library DTC Tool Register Vendors
Go Back   Diesel Place : Chevrolet and GMC Diesel Truck Forums > Speciality Forums > Medium Duty Trucks
Register FAQ Forum Rules My Replies My Threads Mark Forums Read Auto EscrowAuto LoansInsurance

DieselPlace.com is the premier Duramax Diesel Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools
Old 03-08-2011, 08:35 PM   #1 (permalink)
picard25
Diesel Enthusiast
 
Join Date: Mar 2011
Posts: 2
iTrader Score: 0 reviews

cat 3116 engine problems

my truck died on me all of a sudden while going about 40 mph. i limped it to the garage and seemed like it was missing the whole way. before it died the exhaust got really loud and there was a loud air loise but at the same time i had an exhaust leak. exhaust got fixed at the same time as everything else and no more hissing or loud air noise so im assuming it was from that. also when i start my truck in the morning the exhaust was really white for the last little while but its really cold here so i had assumed it was from that but im starting to think differently now. they did several things their including looking for leaks and didnt see any. anyway eventurally my main pump hiue i guess got changed not cheap. the one they got didnt work on the bench, didnt lift fuel. so this was at midnight so they decided to take apart my old one which also didnt work on the bench and cleaned up the lift pump in it and put back together and it starting working on the bench. put it back in truck now starts and runs great. i took it for a ride and got it up to 60 mph no problem. the only weird thing was if i had revs up to where i needed to shift but decided to stop instead i put in neutral and it would sputter and die right away. if i had revs up and stepped on the brake with it in gear and waited for revs to slow down than put in neutral it was fine. worked good for about 2 days smoke in the morning was considerably less. than all of a sudden i had no power. not missing or anything like before but no power at all. revs would be up like crazy but no speed. pull out turbo and get tested its fine. so maybe a weak pump. buy a new one this one works on the bench. put it in and now instead of no power im back to the original problem i had sputtering and seems to be missing. im lost and so is everyone else i bring my truck to. i have all new fuel lines and even bypassed one of the filters. they also put in a new check valve. the dealer i brought my truck to got my truck running and was running really good on idle in the shop and reving it up to. ran really good on ther test drive till they got to sixth gear than it sputtered out on them and now its back to where it was before not running good at all. i really need help. maybe that combustion gases thing or is there a sensor or something?
Offline  
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 03-08-2011, 08:37 PM   #2 (permalink)
picard25
Diesel Enthusiast
 
Join Date: Mar 2011
Posts: 2
iTrader Score: 0 reviews

sorry its a 98 gmc c7500.
Offline   Reply With Quote Quick reply to this message
Old 03-09-2011, 12:14 AM   #3 (permalink)
damutt
Cat nut, Ford Stupid
 
damutt's Avatar
 
Join Date: May 2010
Location: phoenix,az
Posts: 970
iTrader Score: 0 reviews

Old School Oil Burners (Old SOBs) Member

picard when you installed your pump did you realign the injectors? if not that is the miss or might be.
__________________
1972 International harvester
Cat 3116 215 HP 605 TQ
Road ranger rt6610 10 speed manual
chevy 3500HD axles 5 lug front/10 lug rear dana 80
4.63 ratio thanks to Diaric
Huge thanks goes to Cornman369 for the axles

2007 F150
4.2L v6 202HP
5 speed manual transmission IFS
RCLB
Offline   Reply With Quote Quick reply to this message
Old 03-09-2011, 10:28 AM   #4 (permalink)
wertman94
Diesel Fanatic
 
wertman94's Avatar
 
Join Date: Feb 2011
Location: Seattle
Posts: 61
iTrader Score: 0 reviews

I had a similar problem. Mine would run fine until I had the engine under full load and then would sputter and cut-out. Turned out to be the primary fuel filter (which I did not know it had) was full of water. Drained it and worked fine. I know you said you had bypassed one of the filters, have you checked the fuel tanks for water?
__________________
1994 Kodiak 3116/Allison
Offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Diesel Place : Chevrolet and GMC Diesel Truck Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

PLEASE READ! You must check your email inbox for the confirmation link to complete registration. Please check your spam box if you do not see the email in your inbox.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
cat 3116 damutt Medium Duty Trucks 52 04-28-2011 11:54 PM
1997 Chev. 3116 Caterpillar fuel problems Bikertrash Medium Duty Trucks 2 03-28-2011 11:43 AM
Max hrs on 3116 cat DieselTerritory Any Other Vehicles 0 01-19-2011 12:56 AM
3116 Cat C Schomer Other Performance Discussion 4 02-19-2008 08:07 PM


All times are GMT -4. The time now is 05:38 AM.


Shoutbox provided by vBShout v6.2.1 (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
© AutoGuide

SEO by vBSEO 3.6.0