2004 Duramax, 4x4 lights work, but it wont engage.. - Diesel Place : Chevrolet and GMC Diesel Truck Forums
 
Home Forum Market Place Garage Lounge (0) Tuning Library DTC Tool Register Vendors
Go Back   Diesel Place : Chevrolet and GMC Diesel Truck Forums > Speciality Forums > Drivetrain - 2001 - 2010
Register FAQ Forum Rules My Replies My Threads Mark Forums Read Auto EscrowAuto LoansInsurance

DieselPlace.com is the premier Duramax Diesel Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools
Old 12-10-2012, 12:53 AM   #1 (permalink)
Nickleahy23
Diesel Fanatic
 
Join Date: May 2007
Posts: 50
iTrader Score: 0 reviews

2004 Duramax, 4x4 lights work, but it wont engage..

Long story short, buddy got a new truck and im driving it for a few days. got 16" of snow today and 4x4 doesnt work. The lights on the switches like up and do not blink or take much time. I can hear the tcase shift, and can feel it when its in 4lo, but the front wheels dont move. Im thinking its the actuator on the front diff, but i was just wondering what else I should check? I gotta check the trec fuse or whatever it is tomorrow, and if thats not it, gotta crawl under it in the snow and swap the front actuator. Any advice would be great. Thanks guys
Offline  
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 12-10-2012, 02:41 AM   #2 (permalink)
frankenstien
Diesel Technician
 
frankenstien's Avatar
 
Join Date: Dec 2011
Location: Fairbanks, Alaska
Posts: 440
iTrader Score: 0 reviews

on my LLY, when the actuator went out the 4x4 light would blink as it doesent send the signal for a solid light until the actuator is engauged. pull the actuator and watch it while someone pushes the button, see if it extends, make sure the driveline doesnet move when in 4Hi and 4LO, might be a problem with the shift fork and ring in the front diff. or a problem in the t case
__________________
2005 GMC 2500HD SLT LLY FE9 Emissions, EGR block Plate, PCV reroute, Res Plugged, Modded Air Box, 5'' MBRP TB Straight Pipe, LBZ MP, Edge Insight CTS, Torsion Bars cranked 2ish Inches, LT 255/85/16E BF Goodrich Mud Terrain T/A KM2, Mobile Delvac In The Allison, All Season Diesel SS Tie Rod Sleevs,ProFab DP, EGR is MIA, EFI Live V2 DSP5 tuning by ATP

HG's at 100,500 miles, studs and grade C's

1974 GMC Sierra Grande 383/TH350/205/D44/14FF
2007 Arctic Cat F8 SnoPro
2012 Ford F150 FX4 (wife's rig)
Offline   Reply With Quote Quick reply to this message
Old 12-10-2012, 11:40 AM   #3 (permalink)
Nickleahy23
Diesel Fanatic
 
Join Date: May 2007
Posts: 50
iTrader Score: 0 reviews

i did get a service 4x4 message for a few seconds, but the lights worked as if there were no problems. I will pull that actuator and go from there. Its pretty easy from what i remember
Offline   Reply With Quote Quick reply to this message
Old 12-10-2012, 01:19 PM   #4 (permalink)
Nickleahy23
Diesel Fanatic
 
Join Date: May 2007
Posts: 50
iTrader Score: 0 reviews

well i tested the actuator and it didnt extend, so i threw a new one in, and made sure it extended. Intalled it and still no 4x4..i could not turn the shaft by hand when in 4x4 and i could in 2x4, but i think there is something wrong with the t case. when i put it in 4 lo and let off the brake it make a wierd clunking like the chain was slipping
Offline   Reply With Quote Quick reply to this message
Old 12-10-2012, 02:49 PM   #5 (permalink)
Nickleahy23
Diesel Fanatic
 
Join Date: May 2007
Posts: 50
iTrader Score: 0 reviews

Just got it looked at, pulled the codes and checked everything. Front actuator works, encoder motor shifts as we can feel it shift and can tell its in 4 lo to the rear wheels, no movement out of the front shaft so it must be something internal

codes were 0379 and 0790
Offline   Reply With Quote Quick reply to this message
Old 12-10-2012, 07:57 PM   #6 (permalink)
frankenstien
Diesel Technician
 
frankenstien's Avatar
 
Join Date: Dec 2011
Location: Fairbanks, Alaska
Posts: 440
iTrader Score: 0 reviews

bum deal, sounds like youve got it figured at least
__________________
2005 GMC 2500HD SLT LLY FE9 Emissions, EGR block Plate, PCV reroute, Res Plugged, Modded Air Box, 5'' MBRP TB Straight Pipe, LBZ MP, Edge Insight CTS, Torsion Bars cranked 2ish Inches, LT 255/85/16E BF Goodrich Mud Terrain T/A KM2, Mobile Delvac In The Allison, All Season Diesel SS Tie Rod Sleevs,ProFab DP, EGR is MIA, EFI Live V2 DSP5 tuning by ATP

HG's at 100,500 miles, studs and grade C's

1974 GMC Sierra Grande 383/TH350/205/D44/14FF
2007 Arctic Cat F8 SnoPro
2012 Ford F150 FX4 (wife's rig)
Offline   Reply With Quote Quick reply to this message
Old 12-10-2012, 08:59 PM   #7 (permalink)
Nickleahy23
Diesel Fanatic
 
Join Date: May 2007
Posts: 50
iTrader Score: 0 reviews

ya sucks to find out during 18" of snow haha. not very fun to have to push out a 7300 lb truck with bald tires..hes gonna get it taken care of back home, prolly just get it rebuilt and fix pump rub issue while they are at it

Last edited by Nickleahy23; 12-10-2012 at 09:00 PM.
Offline   Reply With Quote Quick reply to this message
Old 12-23-2013, 12:39 AM   #8 (permalink)
JimCole007
Diesel Enthusiast
 
Join Date: Dec 2013
Posts: 2
iTrader Score: 0 reviews

What did you find out about your 4x4 not working? Im having the same issue.
Offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Diesel Place : Chevrolet and GMC Diesel Truck Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
2004.5 duramax has codes 0193 0642 and 0670 help wont run but like 10 seconds. hubert Duramax Second Generation: 2004.5-2005 (LLY) 5 10-24-2012 08:35 PM
4x4 wont engage jkwood_80 Duramax Fourth Generation: 2007.5-2010 (LMM) 12 09-13-2010 09:29 PM
HELP day time running lights wont work gearhead Electrical 3 09-15-2009 08:06 PM
4x4 Wont Engage big tentacles Drivetrain - 2001 - 2010 10 10-18-2008 10:14 AM
brake lights wont work basscat200 Electrical 4 10-12-2006 12:43 AM


All times are GMT -4. The time now is 01:17 PM.


Shoutbox provided by vBShout v6.2.1 (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
© AutoGuide

SEO by vBSEO 3.6.0