Engine loses power during hard acceleration - Diesel Place : Chevrolet and GMC Diesel Truck Forums
 
Home Forum Market Place Garage Lounge (0) Tuning Library DTC Tool Register Vendors
Go Back   Diesel Place : Chevrolet and GMC Diesel Truck Forums > GM Diesel Engines > Duramax First Generation: 2001-2004 (LB7)
Register FAQ Forum Rules My Replies My Threads Mark Forums Read Auto EscrowAuto LoansInsurance

DieselPlace.com is the premier Duramax Diesel Forum on the internet. Registered Users do not see the above ads.
Closed Thread
 
LinkBack Thread Tools
Old 09-14-2006, 01:02 PM   #1 (permalink)
comdac
Diesel Enthusiast
 
Join Date: Sep 2006
Location: Virginia Beach, VA
Posts: 8
iTrader Score: 0 reviews

Engine loses power during hard acceleration

I have a 2004 Chevy Silverado 2500 HD, 2WD, extended cab, long bed with the Duramax diesel and Allison transmission which I use to tow a 12,000 lb. RV.

During hard acceleration, when the transmission shifts up to a higher gear, the engine experiences a severe loss of power. If I momentarily let up on the accelerator and then continue accelerating, the power returns.

I have not noticed this problem during moderate acceleration or while I am towing the RV. Gas mileage is good while towing and non-towing. And the problem only seems to occur just after a transmission upshift.

This is a real problem during passing situations. Any thoughts on a possible cause?
Offline  
Quick reply to this message
Sponsored Links
Advertisement
 
Old 09-14-2006, 01:23 PM   #2 (permalink)
jcummins
Diesel Technician
 
Join Date: Oct 2003
Location: Creal Springs, IL
Posts: 165
iTrader Score: 0 reviews

check fuel filter
__________________
2002 GMC 2500HD D/A CC SB 4x4 SLT pewter, HJ, SCIII, 4" Kenndy exhaust, Amsoil air filter, ICI running boards, Truck Trunk bed box, aux tank, Superglide 5th wheel, 36ft Holiday Rambler, GCWR 22000+
Offline   Quick reply to this message
Old 09-14-2006, 01:43 PM   #3 (permalink)
Trippin
Diesel Sr. Technical Member
 
Join Date: Oct 2003
Location: Valencia, CA
Posts: 5,563
iTrader Score: 0 reviews

Sounds like Allison defueling to me in order to protect the transmission during up shifts. Do you have any power adders?
Offline   Quick reply to this message
Old 09-14-2006, 06:46 PM   #4 (permalink)
comdac
Diesel Enthusiast
 
Join Date: Sep 2006
Location: Virginia Beach, VA
Posts: 8
iTrader Score: 0 reviews

It is almost time to replace the filter.

This problem started less than 10,000 miles ago (I have 72,000 on the odometer). So this is not normal operation. I am talking serious power loss that lasts until I ease up on the accelerator. This cannot be tolerated during passing situations. Everything is stock.
Offline   Quick reply to this message
Old 09-14-2006, 08:58 PM   #5 (permalink)
dutch
Diesel Technician
 
Join Date: Nov 2003
Location: west Texas
Posts: 185
iTrader Score: 0 reviews

Change fuel filter first. I bet that will fix it!
__________________
Personal 2002 DM/A 4x4 CC long bed. Ranch Hand grill guard and Westin step bars. 305/70R16's, Juice, high idle. (old work truck, hope it to mine soon mine now)
work truck. 08 Dodge 6.7L Cummins Megacab 4x4 shortbed 315 BF G's, full replacement front bumper, headache rack, Big Country step bars.
Wife's 2004 Suburban
Son's 2002 GMC ton ext cab
Truck pics

farming pics
Offline   Quick reply to this message
Old 09-14-2006, 10:28 PM   #6 (permalink)
Trippin
Diesel Sr. Technical Member
 
Join Date: Oct 2003
Location: Valencia, CA
Posts: 5,563
iTrader Score: 0 reviews

Quote:
Originally Posted by dutch;1300288;
Change fuel filter first. I bet that will fix it!


And air filter if that hasn't been done.
Offline   Quick reply to this message
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
lacking power under hard acceleration justinspiller Duramax Second Generation: 2004.5-2005 (LLY) 2 11-24-2010 01:36 AM
Engine Suddenly Loses Power jasond Duramax Third Generation: 2006-2007.5 (LBZ & LLY) 6 10-03-2007 08:47 AM
under hard acceleration... BullydogPowered Drivetrain - 2001 - 2010 4 04-22-2007 12:21 PM
Engine loses most power, service light comes on? DaveBis Duramax First Generation: 2001-2004 (LB7) 32 12-22-2005 08:37 PM
loses power skippie Any Other Vehicles 2 08-17-2005 02:14 AM


All times are GMT -4. The time now is 10:09 AM.


Shoutbox provided by vBShout v6.2.1 (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
© AutoGuide

SEO by vBSEO 3.6.0