check engine light on wont shift - Diesel Place : Chevrolet and GMC Diesel Truck Forums
 
Home Forum Market Place Garage Lounge (0) Tuning Library DTC Tool Register Vendors
Go Back   Diesel Place : Chevrolet and GMC Diesel Truck Forums > GM Diesel Engines > Duramax Second Generation: 2004.5-2005 (LLY)
Register FAQ Forum Rules My Replies My Threads Mark Forums Read Auto EscrowAuto LoansInsurance

DieselPlace.com is the premier Duramax Diesel Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools
Old 10-28-2011, 08:47 AM   #1 (permalink)
north-freak
Diesel Enthusiast
 
Join Date: Dec 2009
Posts: 15
iTrader Score: 0 reviews

check engine light on wont shift

Backed out of the garage this morning and the check engine light came on.
Now it seems to only be running in second or third gear. I shut it off and started it back up and the shift range inhibit came up briefly. any Ideas?
thanks Bob
this is a 2004 duramax lly with the allison tranny. everything is stock. I have not pulled a trailer for quite some time

Last edited by north-freak; 10-28-2011 at 08:54 AM. Reason: not enough info
Offline  
Reply With Quote
Sponsored Links
Advertisement
 
Old 10-28-2011, 08:49 AM   #2 (permalink)
PrivatePilot
Administrator
Resident Coffee Addict
 
PrivatePilot's Avatar
 
Join Date: Jun 2008
Location: Near The Coffee Maker
Posts: 14,952
iTrader Score: 0 reviews

Ontario Diesel Place Chapter Member

Year, make, model? You may want to fill in your signature to make it easier for our members to help you out now, and in the future.

I'll move your post to an engine forum once I have the relevant info - the 911 forum is usually reserved for stranded-away-from-home situations.
__________________


Mark - Courtice, Ontario, Canada.
'97 C3500 Crew Cab Long Box Dually 6.5 Turbo Diesel.
Rebuilt with Navistar 506 block spring 2012
Special thanks to Racer55 and WhiteK2500 for their invaluable assistance!
Commercial OTR Driver Since '95

Find my list of reference information HERE
New members, please introduce yourself HERE
Online   Reply With Quote
Old 10-28-2011, 08:55 AM   #3 (permalink)
north-freak
Diesel Enthusiast
 
Join Date: Dec 2009
Posts: 15
iTrader Score: 0 reviews

thanks
Offline   Reply With Quote
Old 10-28-2011, 10:42 PM   #4 (permalink)
turnpike
Diesel Master
 
turnpike's Avatar
 
Join Date: May 2004
Location: Alberta/Arizona
Posts: 1,615
iTrader Score: 0 reviews

Quote:
Originally Posted by north-freak View Post
Backed out of the garage this morning and the check engine light came on.
Now it seems to only be running in second or third gear. I shut it off and started it back up and the shift range inhibit came up briefly. any Ideas?
thanks Bob
this is a 2004 duramax lly with the allison tranny. everything is stock. I have not pulled a trailer for quite some time
I think you have a problem with the trany. The TCM (transmission control module), has asked the ECM (engine control module), to lite the check engine light, and the transmission is working with only one gear (limping), likely third. Check the oil level, just over the add mark when hot (175F).

Best to have the codes read. Likely has a P0700 - set CEL code, which is mentioned above. If it does, you will also have other TCM codes that some better code readers will display for you. Then you can start to work on diagnoses of the problem. "Shift range inhibit" is the transmission control module setting about to self preserve the trany. There is a boat load of possible symptoms with different causes, and the code will help nail down the situation.

Let us know all the codes you get. Write them down as you read them, then post here.
__________________
Turnpike

'05 Chev, 2500HD, CC, SB, Duramax, Allison, 4WD, bought new April '05-times up - off warranty, now 144,000 miles, LBZ mouthpeice, Blocker Plate & Unplugged EGR, Air Box cut out, lost the cat, 52 US Gal (196 Litre) Titan Fuel Tank, SuperChips tuner on Tow mode, AirLift air bags, BrakeSmart Trailer Brake controller, PaceEdwards cover-replaced 2013, PopLock tailgate lock, DSP Fifth Hitch, JVC KW-NT1 headunit, "AutoEnginuity" scanner.

'02 GMC, 2500HD, CC, SB, D/A, 4wd, Traded in - wrong color

Last edited by turnpike; 10-28-2011 at 10:44 PM.
Offline   Reply With Quote
Old 10-29-2011, 10:48 AM   #5 (permalink)
duradrift13
Diesel Fanatic
 
duradrift13's Avatar
 
Join Date: Mar 2010
Posts: 59
iTrader Score: 0 reviews

Sounds like limp, delete the code and see if it happens again
__________________
05 Sierra 2500hd SLT- 4094vvt(turbo), built trans, t-case pump rub kit, ARP studs and c gaskets, Pcv reroute, egr blocked, afe turbo mouthpiece, 4 inch mbrp turbo back exhaust, 3 inch downpipe, Air dog 2 165, 6k HID's heads, fogs, and in the DRL's, 5% tint, EFI Live, autometer ultra-lite 2 gauges, air raid cold air, a viper remote start and alarm with smart start, a custom ported box with a L7 powered by a kicker dx 1000.1, added some pioneer 4inch in the doors as well infinity kappa components all the way around powered by 2 kicker dx 400.4 with all tsunami wiring, pioneer 940bt with back up cam, and 20x9 BMF Novakane's death metal black, N-FAB steps, zone lift with fox shocks, rare parts tie rods, cognito support braces, 35 toyo MTs.


Big thanks to david at Diesel Technology Source
Offline   Reply With Quote
Old 10-29-2011, 10:31 PM   #6 (permalink)
snaketigre
Diesel Fanatic
 
snaketigre's Avatar
 
Join Date: Mar 2005
Location: Ontario / Quebec border, Canada
Posts: 51
iTrader Score: 0 reviews
Send a message via Skype™ to snaketigre

Hi there, it sounds like it is your NSBU switch which is located on the drivers side on the transmission. I had the same issue last year. It would not engage and I had an engine checl light. If you do a research in the forum DB on the above (NSBU) you will find lots of info.
__________________
05 GMC SLE DMAX 4x4, stock, short box ext cab, polo green, Aux American tank - 30 gal, Cobra Mobile Soundtracker CB, Amzoil dual oil filtering system, Air Green filter, Buckets, BOSE syst - 6 CD Changer, Prodigy brake control, Firestone air bags, Large capacity oil pan - Allison, Extang soft tonneau, stock aluminum wheels, electic heated camping mirrors, Extruded Owen Classic series full lenght running boards.
Offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
the light comes on and then goes off and engine wont start bob_22r Duramax Third Generation: 2006-2007.5 (LBZ & LLY) 3 01-23-2010 03:53 PM
S.O.S I need a techs help. Rough idle, wont rev beyound 2k and engine light on Dirty Sanchez Duramax Second Generation: 2004.5-2005 (LLY) 34 10-29-2008 03:31 PM
won't shift - Service Engine Light on jbrown1444 Allison OEM 9 03-06-2007 07:20 AM
installed finger stick, check engine light wont go off ChevyManSC Second Generation Duramax Electronics/Tuners 10 01-22-2006 08:40 PM
Weird shift then check engine light 05king Allison OEM 3 09-28-2005 01:17 PM


All times are GMT -4. The time now is 10:08 AM.


Shoutbox provided by vBShout v6.2.1 (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
© AutoGuide

SEO by vBSEO 3.6.0