repeated limp modes after p202 code and repair - Diesel Place : Chevrolet and GMC Diesel Truck Forums
 
Home Forum Market Place Garage Lounge (0) Tuning Library DTC Tool Register Vendors
Go Back   Diesel Place : Chevrolet and GMC Diesel Truck Forums > GM Diesel Engines > Duramax Second Generation: 2004.5-2005 (LLY)
Register FAQ Forum Rules My Replies My Threads Mark Forums Read Auto EscrowAuto LoansInsurance

DieselPlace.com is the premier Duramax Diesel Forum on the internet. Registered Users do not see the above ads.
Closed Thread
 
LinkBack Thread Tools
Old 11-09-2008, 10:19 AM   #1 (permalink)
leroy creeper
Diesel Enthusiast
 
Join Date: Mar 2006
Posts: 11
iTrader Score: 0 reviews

repeated limp modes after p202 code and repair

i have a 04.5 lly. it has now been in the shop 6 times for going into "limp mode" it seems to be throwing a p202.

the dealership service dept seems competent and friendly. they go by the book and replace the #2 and #7 injector harness and suport them and use a pick to increase the crimp on the injector connector.

to make it crazier, it will limp, throw a code, be repaired, break the next day, go back in the shop, get fixed again and run a few months then repeat.

something else is wrong. any ideas? computer?, injectors? other harness problems?
Offline  
Quick reply to this message
Sponsored Links
Advertisement
 
Old 11-09-2008, 11:22 AM   #2 (permalink)
Rttoys
Commissioner Gordon
 
Rttoys's Avatar
 
Join Date: Jul 2005
Location: Houston, TX
Posts: 3,062
iTrader Score: 0 reviews

Ficm
__________________
'05 K2500HD cc/sb D/A LT
V2 w/fan, Fan Damn Max, twin 130 amp alts, LBZ mouthpiece, BD manifold, custom high flow up pipes, 4" down pipe, kitty gone, P/S cooler, EFI Live, boost and pyro gauges.

45 gal Transfer Flow tank, B&W gooseneck hitch, class 5 hitch, Bilstein shocks, 285/70-17 on H2 wheels

Normaly pulling my 05 Desert Fox 28KS toy hauler
Total GCGW 21,800#

Last edited by Rttoys; 11-09-2008 at 11:22 AM.
Offline   Quick reply to this message
Old 11-20-2008, 01:26 AM   #3 (permalink)
rodom
Diesel Enthusiast
 
Join Date: Apr 2005
Location: North Central Texas
Posts: 23
iTrader Score: 0 reviews

My did the same thing... and dealer said the fuel filter was dirty. I went ahead and let them change the filter and drove home. Truck ran fine for a few miles and then I pulled out in front of a semi..... Stupid thing went into limp mode, Lucky for me the semi went to the ditch which was not very deep. No damage and no injuries..... Called the service manager and gave him an ear full. Dealer changed filter, dropped fuel tank, checked injectors, and drove it for a week. Dealer said it was fixed. It was not. Last thing they tried was to replace the fuel rail..... Worked like a charm... no problems in the last 55,000 miles.
__________________
05 GMC CC 4X4 DMAX/Allison, Edge w/***. Airraid intake, 4" cat back exhaust, Bilstein shocks, and a B&W gooseneck hitch.
Offline   Quick reply to this message
Old 11-20-2008, 09:29 AM   #4 (permalink)
briano
Diesel Master
 
briano's Avatar
 
Join Date: Sep 2004
Location: Austin, Tx
Posts: 4,586
iTrader Score: 0 reviews

Quote:
Originally Posted by leroy creeper View Post
i have a 04.5 lly. it has now been in the shop 6 times for going into "limp mode" it seems to be throwing a p202.

the dealership service dept seems competent and friendly. they go by the book and replace the #2 and #7 injector harness and suport them and use a pick to increase the crimp on the injector connector.

to make it crazier, it will limp, throw a code, be repaired, break the next day, go back in the shop, get fixed again and run a few months then repeat.

something else is wrong. any ideas? computer?, injectors? other harness problems?
is it always the same code? p0202 is Injector #2 problem.. typically it's that harness and connector fixed with the ice pick that you say they did, but if the damage is already done it's probably the injector. I imagine if they did the harness repair they would have seen any broken wires on that side if they existed. did they check the balance rates of the injectors? that will tell them if it's on the way out or not.
__________________
04.5 LLY 2500HD - Full 4" MBRP, D-Pipe, 3" tubes, LBZ MP, Turbo Timer, Built Tranny, DuramaxTuner EFI Live, Elec-fans, Lift pump.

LLY FAQ, Most Popular Tuner, Most Popular Exhaust, How to Search, Front Pipe Install,
Duramax Engine Pics, Front Pipe vs. Down Pipe Which Engine do I have?? Programmer Comparison Dual Electric Fan Install Online Manuals MBRP Powertube Install and Dyno "True" Downpipe Install

Please create a signature under User CP with year, make, and any mods. This will help us help you.
Offline   Quick reply to this message
Old 11-20-2008, 09:30 AM   #5 (permalink)
briano
Diesel Master
 
briano's Avatar
 
Join Date: Sep 2004
Location: Austin, Tx
Posts: 4,586
iTrader Score: 0 reviews

Quote:
Originally Posted by rodom View Post
It was not. Last thing they tried was to replace the fuel rail..... Worked like a charm... no problems in the last 55,000 miles.
replaced fuel rail, the actual piping? or the fuel pressur regulator?
__________________
04.5 LLY 2500HD - Full 4" MBRP, D-Pipe, 3" tubes, LBZ MP, Turbo Timer, Built Tranny, DuramaxTuner EFI Live, Elec-fans, Lift pump.

LLY FAQ, Most Popular Tuner, Most Popular Exhaust, How to Search, Front Pipe Install,
Duramax Engine Pics, Front Pipe vs. Down Pipe Which Engine do I have?? Programmer Comparison Dual Electric Fan Install Online Manuals MBRP Powertube Install and Dyno "True" Downpipe Install

Please create a signature under User CP with year, make, and any mods. This will help us help you.
Offline   Quick reply to this message
Old 11-20-2008, 11:18 AM   #6 (permalink)
randy_the_hack
 
Posts: n/a

Quote:
Originally Posted by rodom View Post
My did the same thing... and dealer said the fuel filter was dirty. I went ahead and let them change the filter and drove home. Truck ran fine for a few miles and then I pulled out in front of a semi..... Stupid thing went into limp mode, Lucky for me the semi went to the ditch which was not very deep. No damage and no injuries..... Called the service manager and gave him an ear full. Dealer changed filter, dropped fuel tank, checked injectors, and drove it for a week. Dealer said it was fixed. It was not. Last thing they tried was to replace the fuel rail..... Worked like a charm... no problems in the last 55,000 miles.
Wow - now that sounds like grounds for a lawsuit. Glad nobody got hurt... but good grief! It's not like a road test wouldn't have found that! I guess there's a chance it wouldn't have... but still...
  Quick reply to this message
Old 11-20-2008, 07:34 PM   #7 (permalink)
RoadRunnerTR21
Diesel Master
 
RoadRunnerTR21's Avatar
 
Join Date: Aug 2005
Location: Trinidad, TX
Posts: 1,223
iTrader Score: 0 reviews

Quote:
Originally Posted by rodom View Post
My did the same thing... and dealer said the fuel filter was dirty. I went ahead and let them change the filter and drove home. Truck ran fine for a few miles and then I pulled out in front of a semi..... Stupid thing went into limp mode, Lucky for me the semi went to the ditch which was not very deep. No damage and no injuries..... Called the service manager and gave him an ear full. Dealer changed filter, dropped fuel tank, checked injectors, and drove it for a week. Dealer said it was fixed. It was not. Last thing they tried was to replace the fuel rail..... Worked like a charm... no problems in the last 55,000 miles.
Damn! That's scary right there.

I had a situation a while back when I pulled pulled out onto a highway and my emergency brake cable pulled on my 5er and it locked the trailer brakes. There was a semi a ways away but I knew he was barreling down the road. Needles to say the DMAX drug the 37' trailer over to the side of the road. No harm, no foul because he was heads up. Scary!
__________________
____________________________
2013 Honda Pilot EXL with Nav
2012 VW Passat TDI

Sold with 45K miles: 05 Chev 3500 LT CC LB DRW 4X4
DMAX/Ally
Rhino Lining, Blocked, Fingerstick, Fumoto valve, MBRP Turbo Back (Bye, Bye Kitty!), LBZ MP, PCV Re-route

Member #165 3500 Dually Club

Sold: 2003 Medallion 36SKQ 5er
Sold: 1998 Triton TR21 DC w/ 2004 225 Evinrude DI
Offline   Quick reply to this message
Old 01-08-2009, 10:51 PM   #8 (permalink)
thedirtymax05
Diesel Enthusiast
 
thedirtymax05's Avatar
 
Join Date: Jan 2009
Location: oklahoma
Posts: 5
iTrader Score: 0 reviews

Quote:
Originally Posted by leroy creeper View Post
i have a 04.5 lly. it has now been in the shop 6 times for going into "limp mode" it seems to be throwing a p202.

the dealership service dept seems competent and friendly. they go by the book and replace the #2 and #7 injector harness and suport them and use a pick to increase the crimp on the injector connector.

to make it crazier, it will limp, throw a code, be repaired, break the next day, go back in the shop, get fixed again and run a few months then repeat.

something else is wrong. any ideas? computer?, injectors? other harness problems?
hey i dont know if you have the problem fixed yet or not but mine did that same stuff for a while but only after i put a programmer on it i did some research and turns out the stock fuel pump couldnt supply the engines demand for fuel so the trucks computer freaks out and doesnt know why and goes into limp mode so i got a holley blue electric fuel pump and put it on the fuel line right outside the tank and mounted it to the frame and it stopped just a suggestion let me know what ya think...
__________________
05 Dmax with the 5inch turbo back MBRP exhaust with the chrome rolled edge 6inch tip 33 in all terrains ranch hand grill guard had bullydog tripledog sold it today and ordered the PPE xceleratot hot +2 cant wait to try it out!
Offline   Quick reply to this message
Old 01-09-2009, 05:59 AM   #9 (permalink)
randy_the_hack
 
Posts: n/a

Quote:
Originally Posted by thedirtymax05 View Post
hey i dont know if you have the problem fixed yet or not but mine did that same stuff for a while but only after i put a programmer on it i did some research and turns out the stock fuel pump couldnt supply the engines demand for fuel so the trucks computer freaks out and doesnt know why and goes into limp mode so i got a holley blue electric fuel pump and put it on the fuel line right outside the tank and mounted it to the frame and it stopped just a suggestion let me know what ya think...
Dude... punctuation is your friend. Get some...
  Quick reply to this message
Old 01-09-2009, 09:54 AM   #10 (permalink)
azduramax04
Diesel Technician
 
azduramax04's Avatar
 
Join Date: Jul 2006
Location: Flagstaff AZ
Posts: 469
iTrader Score: 0 reviews
Send a message via AIM to azduramax04 Send a message via Yahoo to azduramax04

FUNNY post! Randy, he did use the correct amount of periods. Just put them all at the end...
__________________
2005 HD2500 LLY ccsb, 4x4, Leveling Kit, 56 Gal Tank, 20" American Racing Wheels, 33" Toyo AT's, 4" Turbo Back Exhaust no Kitty, EGR blocked FE9, PCV rerouted, #2 and #7 fix @ 45k, Peddle spring mod, Boost stick, KD home made intake, Billet Grill, Video DVD system, Bed cover, Edge Juice with attitude HOT
Offline   Quick reply to this message
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Limp mode: #2, #7 repair harness, new FICM? magnetic Duramax Second Generation: 2004.5-2005 (LLY) 0 08-24-2011 10:09 AM
After headgasket repair low rail pressure code MEW Duramax Third Generation: 2006-2007.5 (LBZ & LLY) 0 06-09-2011 11:41 PM
a p202 problem the dealership cant fix leroy creeper Duramax Second Generation: 2004.5-2005 (LLY) 1 11-25-2008 08:39 PM
Idle only limp - no code Road_King Duramax Second Generation: 2004.5-2005 (LLY) 1 07-16-2008 09:54 PM
Limp with no code? steelerguyND Allison OEM 2 05-17-2008 01:03 PM


All times are GMT -4. The time now is 03:59 AM.


Shoutbox provided by vBShout v6.2.1 (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
© AutoGuide

SEO by vBSEO 3.6.0