98 k2500 no tach/speedo/gear indicator help - Diesel Place : Chevrolet and GMC Diesel Truck Forums
 
Home Forum Market Place Garage Lounge (3) Tuning Library DTC Tool Register Vendors
Go Back   Diesel Place : Chevrolet and GMC Diesel Truck Forums > GM Diesel Engines > 6.5L Diesel Engine
Register FAQ Forum Rules My Replies My Threads Mark Forums Read Auto EscrowAuto LoansInsurance

DieselPlace.com is the premier Duramax Diesel Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools
Old 12-30-2012, 03:41 PM   #1 (permalink)
rich2004
Diesel Enthusiast
 
Join Date: Sep 2012
Location: boston ma
Posts: 17
iTrader Score: 0 reviews

98 k2500 no tach/speedo/gear indicator help

Hey guys i have my 98 K2500 6.5 with about 165K on her now and while out plowing today i looked at the dash to see my SES light on, my tach/speedo and gear indicator not lit and the truck will not shift out of second gear. It starts and stops in second. I read alot of talk about replacing the ignition switch and solving the problem, so I replaced that and still no luck and also ended up breaking the plastic tab that fits into the ignition switch out of the column. Also all fuses are good. any pointers would be greatly appreciated.
Offline  
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 12-31-2012, 11:52 AM   #2 (permalink)
Steve83
Diesel Master
 
Steve83's Avatar
 
Join Date: Aug 2011
Location: Memphis, TN 38133, USA, Earth, Milky Way
Posts: 1,082
iTrader Score: 1 reviews

You checked every fuse in BOTH fuse blocks?
__________________
Walk softly & carry a BIG SIX ! ! !
'97 Silverado K3500 Xcab longbed dually 10KGVWR 212Kmi FOR SALE
Dual Alternator Mod, Dorman FSD in grille, FFM raised, Opti-Lube, high idle switch, Curt Cl.V receiver, reverse sensors, hitching lights, 750W inverter, in-dash USB power, mini bed crane, all-on brights, Magnefines, revised 4WD actuator
Offline   Reply With Quote Quick reply to this message
Old 12-31-2012, 12:05 PM   #3 (permalink)
rich2004
Diesel Enthusiast
 
Join Date: Sep 2012
Location: boston ma
Posts: 17
iTrader Score: 0 reviews

yes under the hood and in the cab...I was preying to find a blown fuse but no so lucky
Offline   Reply With Quote Quick reply to this message
Old 12-31-2012, 02:45 PM   #4 (permalink)
Tommygunner
Diesel Master
 
Tommygunner's Avatar
 
Join Date: Feb 2010
Location: Northesat Nevada
Posts: 1,249
iTrader Score: 0 reviews

You should check codes if possible. The CEL is lit which leads me to bieleve the PCM is Ok. Ignition switch replaced.
You really should check codes. I wil bet a bunch of trans codes come up. The problems you are having point to a power problem at the transmission.
Beings you have NO information on your truck in your sig which would be very helpful when you want help. I am going to assume you have an automatic.
Check the plugs/wires on the trans connection plug, and the PNP switch located on the left side of trans just above the pan. Wiggle things around make sure everything is connected and no wires are pulled out or shorted, packed with snow/ice. IIRC there is a TSB out on the PNP switch about melted wires & connections or something like that.
Power issues at the trans can cause all the problems you are having
__________________
The beauty of the Second Amendment is that it will not be needed until they try to take it.

Earth First!!! We will mine the rest of the planets later.

1998 GMC K1500 6.5 66000 miles. Auto, 3.73 gears.
Remote PMD mounted on the radiator support
KOJO tune WOW !
Carter HD lift pump. Feed the beast
K&N filter
Ported, gasket matched upper intake.
New Bosch injectors. flow matched 2200 lbs pop
3 1/2" custom Aero turbine exhaust. Nutered Cat
2" Lift RS5000 Shocks. 285 X 17 BFG AT summer tires.
12.50 x 33 x 15 Procomp MTswinter. Powertrax No slip locker in rear.

Last edited by Tommygunner; 12-31-2012 at 02:46 PM.
Offline   Reply With Quote Quick reply to this message
Old 12-31-2012, 04:03 PM   #5 (permalink)
rich2004
Diesel Enthusiast
 
Join Date: Sep 2012
Location: boston ma
Posts: 17
iTrader Score: 0 reviews

in attempts to check the connectors/wiring on the side of the tranny the entire tail of that black plastic unit that the two connectors plug into cracked and has broken. the plugs are pretty well stuck in there hence why it broke. not sure what exactly that unit is but will try and do some research.
Offline   Reply With Quote Quick reply to this message
Old 12-31-2012, 04:09 PM   #6 (permalink)
rich2004
Diesel Enthusiast
 
Join Date: Sep 2012
Location: boston ma
Posts: 17
iTrader Score: 0 reviews

found it to be the neutral safety switch that i have broken in the process
Offline   Reply With Quote Quick reply to this message
Old 12-31-2012, 04:56 PM   #7 (permalink)
rich2004
Diesel Enthusiast
 
Join Date: Sep 2012
Location: boston ma
Posts: 17
iTrader Score: 0 reviews

codes are:
P0753- SHIFT SOLENOID A
P0758-SHIFT SOLENOID B
C0237 REAR SPEED SENSOR ERRATIC - WAS IN HISTORY AND NOT PRESENT
Offline   Reply With Quote Quick reply to this message
Old 12-31-2012, 05:33 PM   #8 (permalink)
rich2004
Diesel Enthusiast
 
Join Date: Sep 2012
Location: boston ma
Posts: 17
iTrader Score: 0 reviews

and just checked the #20 fuse to find it blown..now i have the tach/indicator and speedo back but still no shifting, just Park Neutral and 2nd sorry for all of the single posts

Last edited by rich2004; 12-31-2012 at 05:34 PM.
Offline   Reply With Quote Quick reply to this message
Old 12-31-2012, 08:16 PM   #9 (permalink)
Tommygunner
Diesel Master
 
Tommygunner's Avatar
 
Join Date: Feb 2010
Location: Northesat Nevada
Posts: 1,249
iTrader Score: 0 reviews

Quote:
Originally Posted by rich2004 View Post
in attempts to check the connectors/wiring on the side of the tranny the entire tail of that black plastic unit that the two connectors plug into cracked and has broken. the plugs are pretty well stuck in there hence why it broke. not sure what exactly that unit is but will try and do some research.
That is the PNP (Park neutral position) switch i posted about eariler. It is far more than a nuetral safety switch. It tells the PCM exactly what gear you are in.. It controls a number of functions because power to the functions like shift solenoids runs thru it.
reason you only have PNR and 2 is trans is in limp home mode. You will have to fix the switch before things will hopefully work.
Posted eariler that there is a TSB out about that switch getting hot and melting things together.
__________________
The beauty of the Second Amendment is that it will not be needed until they try to take it.

Earth First!!! We will mine the rest of the planets later.

1998 GMC K1500 6.5 66000 miles. Auto, 3.73 gears.
Remote PMD mounted on the radiator support
KOJO tune WOW !
Carter HD lift pump. Feed the beast
K&N filter
Ported, gasket matched upper intake.
New Bosch injectors. flow matched 2200 lbs pop
3 1/2" custom Aero turbine exhaust. Nutered Cat
2" Lift RS5000 Shocks. 285 X 17 BFG AT summer tires.
12.50 x 33 x 15 Procomp MTswinter. Powertrax No slip locker in rear.
Offline   Reply With Quote Quick reply to this message
Old 01-01-2013, 03:20 PM   #10 (permalink)
rich2004
Diesel Enthusiast
 
Join Date: Sep 2012
Location: boston ma
Posts: 17
iTrader Score: 0 reviews

hey guess what you were right!!! replaced the neutral switch and i have gears again. cant thank you guys enough for all the help
Offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Diesel Place : Chevrolet and GMC Diesel Truck Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
tach and speedo help OhioDieselTruck 6.5L Diesel Engine 15 08-04-2012 03:54 PM
Lost Speedo, Gear indicator, & Trans stuck in 2nd Gear dbensavage 4L80/85E Transmissions. 6L90 Transmission 11 05-02-2012 02:05 PM
Speedo spiked to 100-Tach to 4K RWH Duramax Third Generation: 2006-2007.5 (LBZ & LLY) 6 08-24-2010 01:35 PM
K2500 Tach and tranny quit burned_one 6.5L Diesel Engine 4 02-25-2010 10:50 PM
speedo and tach bunt Electrical 1 09-16-2009 04:34 PM


All times are GMT -4. The time now is 11:47 PM.


Shoutbox provided by vBShout v6.2.1 (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
© AutoGuide

SEO by vBSEO 3.6.0