truck shuts down after start up. - Diesel Place : Chevrolet and GMC Diesel Truck Forums
 
Home Forum Market Place Garage Lounge (0) Tuning Library DTC Tool Register Vendors
Go Back   Diesel Place : Chevrolet and GMC Diesel Truck Forums > GM Diesel Engines > 6.5L Diesel Engine
Register FAQ Forum Rules My Replies My Threads Mark Forums Read Auto EscrowAuto LoansInsurance

DieselPlace.com is the premier Duramax Diesel Forum on the internet. Registered Users do not see the above ads.
Closed Thread
 
LinkBack Thread Tools
Old 08-30-2008, 12:22 AM   #1 (permalink)
walkerline
Diesel Enthusiast
 
Join Date: May 2008
Posts: 21
iTrader Score: 0 reviews

truck shuts down after start up.

hello everyone. I own a 1999 gmc 3/4 ton sierra. 6.5 L diesel 307,000 km's

I had a rough idle problem during cold start up. I had change cylinder heads , injectors, glow plugs and a remanufactured injection pump with a new pmd.

anyway I bleed the fuel system, had it running for about 10 minutes and run perfect.

now after 24 hours,

I went to start it up, she will only run for 3 seconds and shut down.

I bleed the system again. but still will only run for 3 seconds.

there is fuel at the injectors.

lift pump is working within spec.


the new remanufactured pump with pmd have just been put on within pass 24 hours.

what can be causing this problem , and how should I go about finding it?
Offline  
Quick reply to this message
Sponsored Links
Advertisement
 
Old 08-30-2008, 03:36 AM   #2 (permalink)
DieselCash
Diesel Master
 
Join Date: Dec 2006
Posts: 1,114
iTrader Score: 0 reviews

Lone Star Diesels Member

Do the diagnostic checklist! it will help us help you on figuring out what all is going wrong and our right. Their is a link to it in my signature.
Thanks,
Offline   Quick reply to this message
Old 08-30-2008, 10:13 AM   #3 (permalink)
walkerline
Diesel Enthusiast
 
Join Date: May 2008
Posts: 21
iTrader Score: 0 reviews

0. Describe in detail the problem you are having. Please be as descriptive as possible.
1. Does the engine crank, or 'turn over'?
yes

1a. Does the engine start and run?
runs for 3 seconds , than shuts off

1a1. If the engine does not start - Crack injector line: do you have fuel? Yes/No
yes

1b. Do you have a Wait To Start Light & the amount of time (seconds) lit.
yes

1c. Ambient Condition (temperature outside indicate F or C) ____
20c (70f)

1d. Engine Cranking speed (if you have an accurate tachometer).
no accurate , cranking over good enough.

1e. Are you experiencing stalling?
yes

1f. If Stalling, describe (upon startup only, down the road, hit a bump etc)
startup

1g. If Stalling, do you notice loss of dash or instruments?
-note if experiencing stalling,you must indicate PMD location in #24.
no

1h. Check turbo inlet and air filter for obstructions. Cone filters have lost disk and stopped air to turbo.
all ok

1.1 Lift pump test - describe results
tested ok

2. Service Engine Light while running?- on/off/intermittent
off

2a. Service Engine light does glow during start/cranking/bulb check: Yes/No
yes

3. Model year
1999

3a. Odometer reading (indicate if in miles or km)
307,000 km's

3b. Miles on major engine components if been replaced (example Injection pump)
24 hours. 0.2 km's

3c. Indicate the model number on the Injection pump (starts DS4 or DB2......)
don't know but i'ts a new re-manufactured pump

4. Have you scanned for engine codes? (varies by pre/post 96) yes/no
no

5. List exact results on engine codes:
don't know

6. Air Filter condition (visual check)
all ok

7. Fuel filter condition (freshly changed/condition unknown/mileage since changed)
replace the filter after this problem started to happen but didn't fix it.

8. Condition of Battery terminal connections (removed, cleaned and tightened)
all ok

8a. Known condition and age of the batteries.
1 year in november

8b. Are batteries of differing age or are they a matched set?
matched set

8c. Condition of Major Grounds. (same drill as batt - removed, cleaned, retightened)
all ok

9. Upon cold start, does the radiator hose get hard quickly? Yes/no
this got nothing to do with my problem

11. Do you have excessive cranking time before the engine starts?
yes

12. Have you used the block heater, and does this effect engine starting?(only try for starting problems)
no

15. Turbo check out - pass/fail
pass

16. Do you have an EGR on the engine? (An F or an S engine code 8th VIN digit)
no

17. Indicate if you know if its a 1500, 2500, 2500HD, 3500, 3500HD.
2500

18. Indicate fuel that you are using: Bio-diesel, #2 Diesel, #1Diesel, SVO/WVO, other
low sulfur diesel

19. Are you using any fuel additives? If so, please list.
no

20. Please indicate geographic region you are in: (example: Texas or Canada)
atlantic canada

21. Do you have any service history available that might pertain to the problem you are having?
the problem first started with a rough idle during cold start. I replace the cylinder heads , injectors, glow plugs and injection pump. bleed fuel system she ran perfect. than 24 hours later, went to start it up , it would only run for 3 seconds, bleed the fuel system again , but still won't run more than 3 seconds.

22. Please indicate any modifications to the vehicle that might help us diagnose better.
everything is stock. the re-manufactured injection pump came with a new pmd, fuel solenoid

23. Upon unscrewing the fuel cap, do you have a large vacuum formed in the tank? yes/no
no

24. Location of PMD/FSD? On the pump/remoted over intake/remoted out of engine bay (please specify placement specifically)
on the pump. never had the engine running at operating temp. so the heat wouldn't have killed it already.

25. Are ALL glow plugs in proper working order as per this thread?
yes
Offline   Quick reply to this message
Old 08-30-2008, 05:40 PM   #4 (permalink)
walkerline
Diesel Enthusiast
 
Join Date: May 2008
Posts: 21
iTrader Score: 0 reviews

hello everyone. the truck started up for me today with no problem but the security light is staying on in the dash?

anyone know why?
Offline   Quick reply to this message
Old 08-30-2008, 07:31 PM   #5 (permalink)
jifaire
Diesel Master
 
jifaire's Avatar
 
Join Date: Jun 2006
Location: Great White North
Posts: 4,237
iTrader Score: 0 reviews

You had your batteries disconnected for a long time, right? You need to do a security re-learn.

Start truck, if it stalls, good. DON'T shut it off... let it sit there, key on, for 10 minutes.

I mean it, 10 whole minutes. Wait until the Security light quits flashing and goes steady. Then start your truck. Should be good to go.

If the truck is running good, just shut it off, turn the key to on, and let it sit like above.

===========
Security re-learn procedure is in FAQ, by the way, under Theft Deterrent Learn.
===========
__________________
Supporter of All Things 6.5 TurboDiesel


Last edited by jifaire; 08-30-2008 at 07:33 PM.
Offline   Quick reply to this message
Old 09-08-2008, 02:36 PM   #6 (permalink)
walkerline
Diesel Enthusiast
 
Join Date: May 2008
Posts: 21
iTrader Score: 0 reviews

truck will no start, while cranking it over 10 seconds you can hear it pick up fuel for 1 to 3 seconds and that's it.

secuirity light is still on but solid.

I have been having this problem since new ip / pmd as been installed.
Offline   Quick reply to this message
Old 09-08-2008, 05:54 PM   #7 (permalink)
JMJNet
Diesel Laureate
 
JMJNet's Avatar
 
Join Date: Feb 2006
Location: Richardson, TX
Posts: 12,039
iTrader Score: 0 reviews

The Suburban Club Member

Did you do the security re-learn suggested by Jif?
__________________
1995 GMC Suburban:
PMD in Bumper
4" Warpspeed Exhaust
KD LP/OPS Harness
Bosch Duraterm GP
Heath Turbo-Master
Chevron's XLP Diesel Additive
Online   Quick reply to this message
Old 09-09-2008, 12:18 AM   #8 (permalink)
walkerline
Diesel Enthusiast
 
Join Date: May 2008
Posts: 21
iTrader Score: 0 reviews

yes I did, few times. I've been doing engine work to this truck since may, and i'ts been getting to me. why I own a gmc 6.5 L diesel.

put it this way I have learn my lesson. I will never ever own another chevy or gm product again in my life!
Offline   Quick reply to this message
Old 09-09-2008, 09:11 AM   #9 (permalink)
JMJNet
Diesel Laureate
 
JMJNet's Avatar
 
Join Date: Feb 2006
Location: Richardson, TX
Posts: 12,039
iTrader Score: 0 reviews

The Suburban Club Member

How is the alternator? and starter? Fuses?

There are 2 things to watch, electrical and fuel supply.

By the way it took me 1 year to get all the quirks out of the way.
Although, the burb is running all that time so I have to eliminate problem one at a time as it comes.
The first thing I did was moved the PMD outside the engine compartment just to eliminate that issue.
__________________
1995 GMC Suburban:
PMD in Bumper
4" Warpspeed Exhaust
KD LP/OPS Harness
Bosch Duraterm GP
Heath Turbo-Master
Chevron's XLP Diesel Additive

Last edited by JMJNet; 09-09-2008 at 09:16 AM.
Online   Quick reply to this message
Old 09-09-2008, 09:36 AM   #10 (permalink)
HamOP
Diesel Specialist
 
HamOP's Avatar
 
Join Date: Oct 2007
Location: SW Tennessee
Posts: 876
iTrader Score: 0 reviews

Quote:
put it this way I have learn my lesson. I will never ever own another chevy or gm product again in my life!
I can relate to that ^^^^ My BIG never-ending troubles were with a Ford... My brother-in-law's was (actually, still is) with a Dodge. Ya never know!

Where did you get the IP? Any kind of warrantee?? Do you know if they put a new FSD on it or a used (but good - Ha) one?
Have you checked for air in the fuel system feeding the IP? You just need a clear piece of tube. There's info here on ThePlace.
When it stops is there fuel in the fuel manager?

Don't just give up (Yep - Hard not to at this point) you can fix this if you go about it methodically. Best of luck solving this!
__________________
95 GMC 3500 HD, 6.5TD (F) 145k miles - Mostly stock.
5 SPD, NVG, 109MM, 5.61 1ST, O/D, 4.63 Rear,
Snorkle & Pretty Cover now gone, Remote engine Versalift TEL-29 Bucket Truck - Start/Stop, High idle switch. Stahl Utility Bed, 12VDC/120VAC M/G set
Starts & Runs GREAT so far

Proud member of the CreativePunctuationSociety (Hz) (Was CPS - Now Hz)
Offline   Quick reply to this message
Sponsored Links
Advertisement
 
Sponsored Links
Advertisement
 
Closed Thread

Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Please Help: Hard Start, then shuts off instantly after ~5-20 seconds. Fox_Suburban 6.5L Diesel Engine 44 07-07-2011 07:46 PM
truck shuts off eben Duramax First Generation: 2001-2004 (LB7) 1 03-22-2009 08:43 PM
randomly shuts off on cold start theswede Duramax First Generation: 2001-2004 (LB7) 1 06-11-2008 02:04 PM
The padlock light flashes on my '03; then fuel shuts off and it won't start danr1707 Electrical 6 01-23-2007 07:34 PM
Engine shuts down first thing on start up Chalie Duramax First Generation: 2001-2004 (LB7) 2 10-12-2006 08:07 PM


All times are GMT -4. The time now is 11:56 AM.


Shoutbox provided by vBShout v6.2.1 (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
© AutoGuide

SEO by vBSEO 3.6.0