"Service Trailer Brake System" DIC message - Diesel Place : Chevrolet and GMC Diesel Truck Forums
 
Home Forum Market Place Garage Lounge (0) Tuning Library DTC Tool Register Vendors
Go Back   Diesel Place : Chevrolet and GMC Diesel Truck Forums > GM Diesel Engines > Duramax Fourth Generation: 2007.5-2010 (LMM)
Register FAQ Forum Rules My Replies My Threads Mark Forums Read Auto EscrowAuto LoansInsurance

Duramax Fourth Generation: 2007.5-2010 (LMM) Discuss the fourth generation (2007.5-2010) of the 6.6L Duramax diesel engine & associated components. Engine related discussion ONLY.

DieselPlace.com is the premier Duramax Diesel Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools
Old 12-12-2008, 09:50 AM   #1 (permalink)
MKILROY
Diesel Technician
 
Join Date: Mar 2005
Location: Lockport NY
Posts: 163
iTrader Score: 0 reviews

"Service Trailer Brake System" DIC message

I keep getting this message on my DIC. I took it to the dealer when it was off and they said it didn't store a code. Has anyone ever had it come up? This is without a trailer connected.
__________________
- 05' Chev. 2500HD SLT Crew Cab, D-Max W/Alli, LOADED, Extang Cover, Fact. Bedliner, Round Steps, Light Jumper, Bridgestone Dueler's 285/75R/16's

- 08' GMC 2500HD SLT Crew Cab, D-Max W/Alli, LOADED, Extang Cover, Factory Bedliner, Round Factory Steps, MaxPower's Driving Light Jumper, BFG K/O 285/70R/17's

- 11' GMC Denali 1500 Loaded, Extang Cover.
Offline  
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 12-12-2008, 10:03 AM   #2 (permalink)
slickzone
Diesel Technician
 
slickzone's Avatar
 
Join Date: Jul 2007
Posts: 150
iTrader Score: 0 reviews

i get the same thing on mine sometimes,but the brake and lights always work fine when i hook up,wierd
__________________
2007 cc LMM 4x4
auto meter gauges
MBRP-tonneau master
3" boss lockers-bfgoodrich t/a-ko 265-75-16
6" oval GM steps
Piaa high and low
air lift 5000
Offline   Reply With Quote Quick reply to this message
Old 12-12-2008, 03:49 PM   #3 (permalink)
filip
Diesel Fanatic
 
Join Date: Aug 2007
Location: Orlando, Florida
Posts: 60
iTrader Score: 0 reviews

I have seen it.. usually just unplug and plug back in and it usually it goes away.. unless there is a wiring problem... things might be wet etc... or a short.

It is the ITBC doing diagnostics and something is out of norm..
__________________
Filip
Apopka, Florida

2007.5 Chevy 2500HD Duramax LMM / Allison
2WD Crew Cab SB LTZ - Silver Birch
Michelin 265.75.16 LTX M/S
Diablo Predator - Tow Mode
Air Lift Air bags w/ smart air - auto level system
48 Gallon custom auxiliary fuel tank with gravity feed
Cargo Management system w/ big tool box
2008 Glendale Titanium 32E37SA 37' w/ Superglide 18k hitch
2007 22' Pace American Pursuit trailer Xtra Tall 8' w/ Hensley Arrow Hitch
Amsoil in Engine and Transmission
Offline   Reply With Quote Quick reply to this message
Old 12-12-2008, 03:49 PM   #4 (permalink)
filip
Diesel Fanatic
 
Join Date: Aug 2007
Location: Orlando, Florida
Posts: 60
iTrader Score: 0 reviews

Of course I have only seen it with trailer connected...
__________________
Filip
Apopka, Florida

2007.5 Chevy 2500HD Duramax LMM / Allison
2WD Crew Cab SB LTZ - Silver Birch
Michelin 265.75.16 LTX M/S
Diablo Predator - Tow Mode
Air Lift Air bags w/ smart air - auto level system
48 Gallon custom auxiliary fuel tank with gravity feed
Cargo Management system w/ big tool box
2008 Glendale Titanium 32E37SA 37' w/ Superglide 18k hitch
2007 22' Pace American Pursuit trailer Xtra Tall 8' w/ Hensley Arrow Hitch
Amsoil in Engine and Transmission
Offline   Reply With Quote Quick reply to this message
Old 12-12-2008, 06:33 PM   #5 (permalink)
ies10frank
Diesel Technician
 
ies10frank's Avatar
 
Join Date: Dec 2006
Location: Innisfil Ontario Canada
Posts: 101
iTrader Score: 0 reviews

Ontario Diesel Place Chapter Member

yeah i had the same problem, disconnected it the wires and sprayed with electric grease and problem went away...hopefully for awhile cause it was getting annoying
__________________
2000 Pontiac Trans AM Ram air
2005 GMC Sierra 3500 SLT LLY dually
2008 GMC Sierra 2500 HD SLT LMM
Offline   Reply With Quote Quick reply to this message
Old 12-12-2008, 10:39 PM   #6 (permalink)
FSTDMAX
Diesel Technician
 
Join Date: Dec 2007
Location: St. Paul, Minnesota
Posts: 186
iTrader Score: 0 reviews

Ha funny. Just got home and mine was doing it so I came on here to see what was up. Trailer on, funny it worked fine till I got the bobcat loaded-go figure.
__________________
-08 GMC ECSB SLT LMM
-06 GMC LBZ CCSB SLT-SOLD
-02 F350 7.3L-SOLD
-O5 F350 6.0L-SOLD
-08 F350 6.4L-Didn't come in time
Offline   Reply With Quote Quick reply to this message
Old 12-12-2008, 11:11 PM   #7 (permalink)
Big Sky Blue
Diesel Enthusiast
 
Join Date: Oct 2008
Location: Airdrie Alberta Canada
Posts: 8
iTrader Score: 0 reviews

Alberta Coal Rollers Member

check your brake controler and turn it down it stop coming on when i did this
Offline   Reply With Quote Quick reply to this message
Old 12-12-2008, 11:11 PM   #8 (permalink)
GMC2500HD
Diesel Sr. Technical Member
 
GMC2500HD's Avatar
 
Join Date: Dec 2003
Posts: 8,756
iTrader Score: 0 reviews

Did you get any water in the connector? Or back into the water, like putting in a boat or something?

Last edited by GMC2500HD; 12-12-2008 at 11:11 PM.
Offline   Reply With Quote Quick reply to this message
Old 12-13-2008, 11:02 AM   #9 (permalink)
50rck
Diesel Fanatic
 
50rck's Avatar
 
Join Date: Aug 2007
Posts: 55
iTrader Score: 0 reviews

Mine said the same thing, but only when the trailer was connected. I went over all the wiring in the trailer, and found a wire had actually been cut by something on the road. Not sure if this is your same problem. All the lights on the trailer actually worked, so I thought everything was fine, and that it may have been a problem with the controller. I didn't actually see the cut wire until I got a flat on the trailer. Your problem may not be the same as the one I had, but it couldn't hurt to check if all else fails.
__________________
07.5 2500 HD black, crew cab short bed
17x9 HD Spy wheels, 285/70/17 Nittos, leveling kit Over 140,000 and counting

SOLD::::early '99 Ford F250 SuprDuty Tan ext cab long bed, Luk clutch upgrade, no other mods

$$$$$ from ^^^^^ used to buy a 34'4" 5th wheel toyhauler

'91 Jeep Wrangler 4.0.....waiting on a V8 swap
Offline   Reply With Quote Quick reply to this message
Old 12-13-2008, 01:35 PM   #10 (permalink)
hankrents
Diesel Head
 
Join Date: Feb 2008
Location: Newnan, Georgia
Posts: 44
iTrader Score: 0 reviews

When it rains my truck will do the same thing. I currently have over 36000 miles and it only happens after it is washed or rains. I usually use compressed air and open the connector and air it out or just let it dry and no problems. I have found out with my truck that if and when I hook up to my 5th wheel w/ the truck still running there will be no connection. I have to plug the trailer to the truck then crank the truck. Truck then says trailer connected and then and only then will I have electric brakes. Nice when I'm hauling a 12,000 lb trailer. There is nothing wrong your braking system. Probably just wet at the plug.
__________________
2007.5 LMM. CCSB SLT. PPE Hot +2 since 78,000. Set on Level 1. 45 Gallon Transfer Flow tank. Linex. PCV reroute. EGR delete.
Current Mileage as of 1/9/12 - 101,091
Offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Diesel Place : Chevrolet and GMC Diesel Truck Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

PLEASE READ! You must check your email inbox for the confirmation link to complete registration. Please check your spam box if you do not see the email in your inbox.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
LMM: "Service Trailer Brake System" maplelawnfarm Electrical 5 09-01-2011 11:22 AM
"Service Trailer Brake System" messege and ABS light. Joshthemule Electrical 28 04-10-2011 10:53 PM
"Service trailer brake system" on DIC LMMKING Duramax Fourth Generation: 2007.5-2010 (LMM) 20 12-15-2010 04:05 AM
"Service Trailer Brake System" lights turned on Joshthemule Electrical 7 10-06-2010 05:45 PM
"service trailer brake system" possible cause is line-of-fire? sierradmax Electrical 0 05-19-2010 02:45 PM


All times are GMT -4. The time now is 11:47 AM.


Shoutbox provided by vBShout v6.2.1 (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
© AutoGuide

SEO by vBSEO 3.6.0