Codes P2563 and P003A - Diesel Place : Chevrolet and GMC Diesel Truck Forums
 
Home Forum Market Place Garage Lounge (1) Tuning Library DTC Tool Register Vendors
Go Back   Diesel Place : Chevrolet and GMC Diesel Truck Forums > GM Diesel Engines > Duramax Third Generation: 2006-2007.5 (LBZ & LLY)
Register FAQ Forum Rules My Replies My Threads Mark Forums Read Auto EscrowAuto LoansInsurance

DieselPlace.com is the premier Duramax Diesel Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools
Old 05-09-2012, 11:36 AM   #1 (permalink)
adamrc
Diesel Technician
 
Join Date: May 2007
Location: Nashville, TN
Posts: 379
iTrader Score: 0 reviews

Codes P2563 and P003A

I am running a DSP5 switch and tunes from Duramaxtuner.com. I have both codes P2563 and P003A. I have already replaced both the vane control solenoid and the vane position sensor but it still throws the codes after a while. I've never had this problem before when running stock tuning. I'm wondering if it's an issue with the EFI programming. Also I've noticed that when I first start the truck and start driving immediately, the truck won't build any boost for the first 10 or 15 seconds. After that, it builds boost just fine and drives great.

Any suggestions?
__________________
2007 Chevrolet 2500HD Classic CC, LT2, 4x4, Duramax LBZ, 6-Speed Allison with Transgo Jr, Kennedy Diesel Lift Pump, Nicktane Billet Aluminum OEM Filter Adapter with CAT 2 Micron Fuel Filter, Dieselsite Coolant Filter, EFI Live with DSP5 switch running IdahoRob tunes, Dipricol Opix Series EGT and Boost Gauges, PPE Airbox Mod, Michelin LTX M/S2 LT265/75R/16 - Running Homebrewed Biodiesel B100 made with a BioPro 190
Offline  
Reply With Quote
Sponsored Links
Advertisement
 
Old 05-10-2012, 08:27 AM   #2 (permalink)
Ramblinrodney
Diesel Master
 
Ramblinrodney's Avatar
 
Join Date: Sep 2006
Location: Midland, MI
Posts: 2,011
iTrader Score: 0 reviews

Michigan Oil Burners Member

You could of tested both the vane control solenoid and the vane position sensor so you didn't have to replace them. Take the EFI programming out to see if thats the issue. Search P2563 and P003A Lots to read from how to clean the turbo or have it replaced to many other things that might be the cause. Heres just two Threw a code. P003A and Dealer giving me new turbo!
__________________
07 Chevy Classic 2500HD 4x4 2LT LBZ CC/SB White
Nasta Nerf Bars, Line-x, Bilstein shocks, Firestone air bags, Fold-a-cover,
Good/Year Wrangler S/A 265/75/16 E
Transgo Jr. PCV Reroute kit, Trans Line Repair Kit By Dirty Hooker Diesel,
Custom Perf/Tow Tune by Kennedy
2005 Sunnybrook 30RKFS 5er 11,300 lbs dry
UAW Local 699 Retired

Last edited by Ramblinrodney; 05-10-2012 at 08:51 AM.
Offline   Reply With Quote
Old 05-10-2012, 09:53 AM   #3 (permalink)
adamrc
Diesel Technician
 
Join Date: May 2007
Location: Nashville, TN
Posts: 379
iTrader Score: 0 reviews

The first thing I did without testing anything was change the vane position sensor. It didn't fix the issue so I then took it to the dealer and they tested everything and did a vane sweep test and determined it was a bad vane control solenoid. I bought a new one and installed it. It did help a whole lot on the power. The turbo is a lot more responsive now. After a while, it threw the two codes yet again and I'm just about out of ideas at this point. I would remove the EFI programming but that is not an option since I sent in my ECU to have it re-programmed. I wish I would have kept the stock ECU.
__________________
2007 Chevrolet 2500HD Classic CC, LT2, 4x4, Duramax LBZ, 6-Speed Allison with Transgo Jr, Kennedy Diesel Lift Pump, Nicktane Billet Aluminum OEM Filter Adapter with CAT 2 Micron Fuel Filter, Dieselsite Coolant Filter, EFI Live with DSP5 switch running IdahoRob tunes, Dipricol Opix Series EGT and Boost Gauges, PPE Airbox Mod, Michelin LTX M/S2 LT265/75R/16 - Running Homebrewed Biodiesel B100 made with a BioPro 190
Offline   Reply With Quote
Old 07-14-2012, 11:09 AM   #4 (permalink)
lugnutgmc
Diesel Fanatic
 
lugnutgmc's Avatar
 
Join Date: May 2007
Location: Middletown RI
Posts: 91
iTrader Score: 0 reviews

Ocean State Diesel Club Member

Ever get anywhere with this problem?

I'm having the exact same issue, DSP5 switch and tune from Duramaxtuner. Have been running the tune and switch for at least a year with no problems. But the past month I got both codes. I have EFI live capabilities, but have not messed around with it too much to do any diagnosing.

Think I'm going to take some time today and learn more about using EFI to its full potential. In what capacity can it function like a Tech II? Can I use it to cycle the vanes and check the sensors? Would love to test em before spending the money on 2 new senors/solenoids. If they're fine, sounds like I might need a new turbo, time to start researching the aftermarket options!!
__________________
2006 GMC 2500HD 6.6 LLY 4wd. Reg cab 8ft bed. EGR blocked, PCV reroute, EFI DSP5 tuned, MBRP downpipe back exhaust, custom non-leaking trans lines.
Offline   Reply With Quote
Old 08-29-2014, 01:30 PM   #5 (permalink)
LB7sFOREVER
Diesel Enthusiast
 
LB7sFOREVER's Avatar
 
Join Date: Oct 2012
Location: Minerva,OH
Posts: 2
iTrader Score: 0 reviews

ever figure it out?? im also having the same issue!
__________________
06LLY!
04.5LLY 350,000+ miles
Offline   Reply With Quote
Old 08-31-2014, 03:27 AM   #6 (permalink)
JoggerFogger
Diesel Technician
 
JoggerFogger's Avatar
 
Join Date: Jul 2005
Location: Portlandia
Posts: 172
iTrader Score: 0 reviews

Not sure if you noticed, but this thread is 2 years old.

I had these codes come up repeatedly. I checked the vane position sensor, it was fine. and the solenoid was working fine as well. The problem was build up of carbon or gum or something that was blocking the vane sweep at 84%.

There was some sort of blockage that wouldn't let the vanes open completely, and when it would do a random sweep, it would get stuck at 84 and throw the code.

The fix is to take apart the turbo and clean the vane path of the blockage and put it all back together. F that. Instead I took a broom handle and pushed the plunger in manually. It got stuck at 84 (verified on my CTS gauge) and I tapped it further until it broke through. Then I stopped driving like a grandpa and romped the S out of the truck. That included towing my 8,000 lb Airstream up the coastal range as fast as I could and getting the turbo up and over 1250 deg F. I had a hard time getting the temp over 1100 with the truck empty, and it would be just for a few seconds. I didn't feel comfortable going over 100mph around town.

I should also mention that I run 100% homemade biodiesel, and I could have made some with more soap production than usual which produces a larger amount of ash than normal. But this error code is more common with biodiesel trucks for other reasons that I don't remember. Mostly to do with buildup of crud on the exhaust side of the turbo that interferes with the vane sweep.

-Kevin
__________________
2007 GMC 2500HD Duramax/Allison CCSB 4x4 SLT Black.
DIY AUX fuel filter, Edge Evo CTS, B100, H2s
Offline   Reply With Quote
Old 08-31-2014, 09:06 PM   #7 (permalink)
Dennis G
Diesel Fanatic
 
Dennis G's Avatar
 
Join Date: Mar 2007
Location: Edmonton, Alberta, Canada
Posts: 53
iTrader Score: 0 reviews

There is a turbo cleaner that really works. Go to Revive Turbo Cleaner. There is a US distributor as well. It is not a repair but should be a routine maintenance item. Cleans the vanes and sensors and is DPF safe. Check out the testimonials. Several shops I deal with use it with great results and no turbo replacement.
__________________
2006 EC, SB, LBZ, Hypertech, 17" OEM wheels, 265 70 R17, Transfer Flow fuel tank (170 Liters), box rails, step bars, EGR delete, fingerstick, lost kitty
Offline   Reply With Quote
Old Yesterday, 09:56 PM   #8 (permalink)
SAYWHAT
Diesel Master
 
SAYWHAT's Avatar
 
Join Date: Feb 2004
Location: Tomah,WI
Posts: 1,048
iTrader Score: 0 reviews

Minnesota/Western Wisconsin DP Club Member

So who will be the guinea pig? Could spraying into the intake tract cause a run-away condition?
__________________
2007 Classic GMC D/A Ext. cab,s.b.,built 11-2006,Di*Priol boost and pyro gauges,Garmin GPS,MBRP catback exhaust,kitty taking a nap,300* hose permanent fix tranny cooling lines,M/A pump rub kit,Prodigy bc,Reese 16,000 lb. slider 4-way tilt hitch.Luverne SS side steps,Truxedo bed cover,Michelin LTX M/S 2 tires and Bilstein shocks.
Offline   Reply With Quote
Old Yesterday, 10:40 PM   #9 (permalink)
Dennis G
Diesel Fanatic
 
Dennis G's Avatar
 
Join Date: Mar 2007
Location: Edmonton, Alberta, Canada
Posts: 53
iTrader Score: 0 reviews

Spraying into the intake system does not cause a runaway because Revive is water based. Nobody has to be a guinea pig because this has been used in the aircraft industry for years and modified for vehicle use. It was featured at SEMA as well. Go to the website as shown in earlier post.
__________________
2006 EC, SB, LBZ, Hypertech, 17" OEM wheels, 265 70 R17, Transfer Flow fuel tank (170 Liters), box rails, step bars, EGR delete, fingerstick, lost kitty
Offline   Reply With Quote
Old Today, 12:17 AM   #10 (permalink)
Stinkydog
Diesel Technician
 
Stinkydog's Avatar
 
Join Date: May 2011
Posts: 130
iTrader Score: 0 reviews

Looks like some good stuff.
__________________
'06 LLY
4" DiamondEye Turbo-Back
EFILive custom tuned by me
Transgo Jr.
EGR Blocker


"If it's too fast, you're too old!"
Offline   Reply With Quote
Sponsored Links
Advertisement
 
Sponsored Links
Advertisement
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Getting P2563 and P234 Codes blazerdog Duramax Fourth Generation: 2007.5-2010 (LMM) 23 05-29-2012 10:34 AM
LBZ P0108 and P2563 codes at the same time shafermike Duramax Third Generation: 2006-2007.5 (LBZ & LLY) 3 09-30-2011 06:08 PM
Does EFI Live tuning or EGR Blocking Cause P003A or P2563? mram10 Duramax Third Generation: 2006-2007.5 (LBZ & LLY) 5 09-21-2011 01:42 PM
p2563/p2564 codes need help roberts9169 Duramax Second Generation: 2004.5-2005 (LLY) 4 10-25-2009 04:30 PM
codes P0046,P2563 hjk15087 Second Generation Duramax Electronics/Tuners 0 02-06-2007 08:48 PM


All times are GMT -4. The time now is 02:45 AM.


Shoutbox provided by vBShout v6.2.1 (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
© AutoGuide

SEO by vBSEO 3.6.0