4L80E Slips in Reverse No Overdrive or Lockup - Diesel Place : Chevrolet and GMC Diesel Truck Forums
 
Home Forum Market Place Garage Lounge (4) Tuning Library DTC Tool Register Vendors
Go Back   Diesel Place : Chevrolet and GMC Diesel Truck Forums > GM Transmissions > 4L80/85E Transmissions. 6L90 Transmission
Register FAQ Forum Rules My Replies My Threads Mark Forums Read Auto EscrowAuto LoansInsurance

DieselPlace.com is the premier Duramax Diesel Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools
Old 04-02-2012, 11:22 PM   #1 (permalink)
Black95
Diesel Enthusiast
 
Join Date: Apr 2012
Posts: 2
iTrader Score: 0 reviews

4L80E Slips in Reverse No Overdrive or Lockup

I recently installed a 95 (F) engine in my 95 (S) truck, Everything worked great for about 2500 km although it was throwing EGR code 33

The first problem I had was the trans wouldn't shift into overdrive and no converter lockup. If I stopped and shut the engine off and restarted it worked normal again. Did this off and on for about a month.

At the time 1st, 2nd, 3rd and reverse worked normally.

As this evolved it got to the point where shutting the engine off and on wouldn't correct the "No OD"

At the moment I have No OD or lockup and now the trans is slipping in reverse.

1st, 2nd and 3rd work normal when cold. When things warm up a bit it only has 1st and 2nd.

Here's some the addition info about the truck

1. State model, year of vehicle and mileage:

1995 GMC K2500 VIN Code S with a F engine from a 1995 GMC K2500 - 402,000 total km on truck
New stock turbo - Has a BD Chip, Banks 3.5" exhaust and K&N Filter. The PMD was long ago relocated to behind the bumper.

2. How long did you own the truck? Recent purchase?

Owned the truck for 14 Years - had 52,000 Km when i purchased

3. Any service engine light: yes/no. Intermittent check engine light?
This is called CEL or MIL

Yes

4. Fluid level okay with the engine and transmission warm? Check on
a level surface?

Yes

5. Have you retrieved Codes? AKA DTCs Diagnostic Trouble codes.

Shows DTC33 and 87 using a paper clip and flashing Engine light.

Shows DTC42 and 96 using a scanner?? But no DTC33 or 87 (Not sure i trust the scanner)

6. Fluid color and smell? Red or Brown does the fluid smell burnt?

Fluid is Red no burned smell. Was changed during engine swap. Was OK when it was changed. Has had Amsoil synthetic for the past 350,000 km

7. Speedometer reading correctly at the appropriate speed? Are the tires the within OEM specifications and size? Use your GPS and verify speed. electronic transmissions remember?

Speedometer and Tach OK. Verified speed with another vehicle
Stock tire size.

8. Is the transmission shifting normal? Is it shifting hard? Do recall the shifting symptoms or any shifting changes before or after the check engine light or after you retrieved codes.

Normal 1-2 shift. Shifts normally into 3rd when cold. Wont shift into 3rd when warm. No OD or Lockup cold or warm

9. Did you or anyone else conduct any kind of maintenance to the vehicle recently?

New trans fluid (Amsoil) about 2500 km ago when swapping engine. No nasties in the pan when i changed the fluid. Pass through connector is dry. All grounds were cleaned when engine was swapped.

10. Can you explain the type of driving? Heavy towing? Snowplowing?

90% (no load) highway - 10% in town. no towing or plowing.

11. Typical weather. Arizona hot mild winters? Minnessota cold. Please explain.

Alberta, Canada

10. Any problems with driver commanded/selected shifting into any gear?
ie.. 1st, 2nd, 3rd, 4th, Rev?

1st OK - 2nd OK - no third or OD - Reverse slips but it does move.

8. Describe symptoms: Does the transmission refuse to shift in first? Will it shift into second and just stay in second gear?

1st gear OK, stays in 2nd. If i stop it starts in 1st and has a normal 1-2 shift and then hangs.

8a. TCC Locking? Is the transmission slipping in any gear?

No lockup - slips in reverse.

8b. Is the transmission shifting into all FWD gears? At the
normal RPMs while the shift selector is in drive? Is it shifting later
than usual?

1-2 and 2-3 normal when cold. Only 1-2 when warm.

Can your vehicle shift into all gears?
If you have a tachometer can you "notice" all forward gears shifting if you are not sure if the transmission is shifting?

I appreciate any help on this.
Thank You!
__________________
1995 GMC K2500 6.5L Diesel (F) Engine in a S Truck.
Banks exhaust, BD chip, K&N Filter.
Offline  
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 04-03-2012, 09:25 PM   #2 (permalink)
clinebarger
Diesel Head
 
Join Date: Feb 2012
Location: Fort Worth Texas
Posts: 44
iTrader Score: 0 reviews

The Center Support sealing rings are leaking when warm...No 3rd/4th hot & DTC 87 (high ratio code).
I sure the Direct clutches have seen better days.

A worn Low/Reverse band will cause slipping in reverse.
__________________
2006 Chevy CCSB LT LBZ/Allison

1985 Chevy C20 Suburban with a 2004 5.3/4L60E
Offline   Reply With Quote Quick reply to this message
Old 04-15-2012, 09:41 PM   #3 (permalink)
lkmk
Diesel Fanatic
 
Join Date: Apr 2011
Location: Saskatoon SK Canada
Posts: 93
iTrader Score: 0 reviews
Send a message via MSN to lkmk

Pacific Iron Mountain Truck Club Member

Alberta Coal Rollers Member

Quote:
Originally Posted by Black95 View Post
I recently installed a 95 (F) engine in my 95 (S) truck, Everything worked great for about 2500 km although it was throwing EGR code 33

The first problem I had was the trans wouldn't shift into overdrive and no converter lockup. If I stopped and shut the engine off and restarted it worked normal again. Did this off and on for about a month.

At the time 1st, 2nd, 3rd and reverse worked normally.

As this evolved it got to the point where shutting the engine off and on wouldn't correct the "No OD"

At the moment I have No OD or lockup and now the trans is slipping in reverse.

1st, 2nd and 3rd work normal when cold. When things warm up a bit it only has 1st and 2nd.

Here's some the addition info about the truck

1. State model, year of vehicle and mileage:

1995 GMC K2500 VIN Code S with a F engine from a 1995 GMC K2500 - 402,000 total km on truck
New stock turbo - Has a BD Chip, Banks 3.5" exhaust and K&N Filter. The PMD was long ago relocated to behind the bumper.

2. How long did you own the truck? Recent purchase?

Owned the truck for 14 Years - had 52,000 Km when i purchased

3. Any service engine light: yes/no. Intermittent check engine light?
This is called CEL or MIL

Yes

4. Fluid level okay with the engine and transmission warm? Check on
a level surface?

Yes

5. Have you retrieved Codes? AKA DTCs Diagnostic Trouble codes.

Shows DTC33 and 87 using a paper clip and flashing Engine light.

Shows DTC42 and 96 using a scanner?? But no DTC33 or 87 (Not sure i trust the scanner)

6. Fluid color and smell? Red or Brown does the fluid smell burnt?

Fluid is Red no burned smell. Was changed during engine swap. Was OK when it was changed. Has had Amsoil synthetic for the past 350,000 km

7. Speedometer reading correctly at the appropriate speed? Are the tires the within OEM specifications and size? Use your GPS and verify speed. electronic transmissions remember?

Speedometer and Tach OK. Verified speed with another vehicle
Stock tire size.

8. Is the transmission shifting normal? Is it shifting hard? Do recall the shifting symptoms or any shifting changes before or after the check engine light or after you retrieved codes.

Normal 1-2 shift. Shifts normally into 3rd when cold. Wont shift into 3rd when warm. No OD or Lockup cold or warm

9. Did you or anyone else conduct any kind of maintenance to the vehicle recently?

New trans fluid (Amsoil) about 2500 km ago when swapping engine. No nasties in the pan when i changed the fluid. Pass through connector is dry. All grounds were cleaned when engine was swapped.

10. Can you explain the type of driving? Heavy towing? Snowplowing?

90% (no load) highway - 10% in town. no towing or plowing.

11. Typical weather. Arizona hot mild winters? Minnessota cold. Please explain.

Alberta, Canada

10. Any problems with driver commanded/selected shifting into any gear?
ie.. 1st, 2nd, 3rd, 4th, Rev?

1st OK - 2nd OK - no third or OD - Reverse slips but it does move.

8. Describe symptoms: Does the transmission refuse to shift in first? Will it shift into second and just stay in second gear?

1st gear OK, stays in 2nd. If i stop it starts in 1st and has a normal 1-2 shift and then hangs.

8a. TCC Locking? Is the transmission slipping in any gear?

No lockup - slips in reverse.

8b. Is the transmission shifting into all FWD gears? At the
normal RPMs while the shift selector is in drive? Is it shifting later
than usual?

1-2 and 2-3 normal when cold. Only 1-2 when warm.

Can your vehicle shift into all gears?
If you have a tachometer can you "notice" all forward gears shifting if you are not sure if the transmission is shifting?

I appreciate any help on this.
Thank You!
Got the same damn problem...
__________________
94 gmc sierra 6.5 turbo
Truck is sold as of Sept 20th 2012!!!!

"Jan 31/2001 7:29pm [chevyIL6girly] i just got to sit quietly in my corner and played with my boobs"
Offline   Reply With Quote Quick reply to this message
Old 04-15-2012, 10:08 PM   #4 (permalink)
Black95
Diesel Enthusiast
 
Join Date: Apr 2012
Posts: 2
iTrader Score: 0 reviews

Update

Over the weekend I've been driving the truck and realize my original post is not 100% accurate.
I originally thought that the 2-3 shift didn't happen once it warmed up, but that was wrong.

As i posted earlier, If I drive the truck after a 3 or 4 minute minute warmup it has a normal 1-2 and a normal 2-3 shift but still no OD, no lock up and slips in reverse.

Here's what I discovered that is different from my original post.

If I stop or slow down enough to cause the transmission to go into first gear, the 1-2 shift is normal but then it hangs in 2nd gear and wont shift into 3rd.

But if I stop and turn the engine off and then restart, it will shift 1-2 and 2-3 every time regardless of temp. Also if I slow enough to only cause a downshift into 2nd it will up-shift to 3rd every time, regardless of temp.

Also,
I went to the wrecking yard and cut off the wiring harness for the pass through connector. I connected it to my faulty unit and tested the solenoids. All of the solenoids test the same as a good working trans we have here. So know I'm really stumped??

BTW - We repaired for the EGR code by re-connecting the vacuum lines for the original S engine, still getting DTC code 87.
__________________
1995 GMC K2500 6.5L Diesel (F) Engine in a S Truck.
Banks exhaust, BD chip, K&N Filter.
Offline   Reply With Quote Quick reply to this message
Old 04-19-2013, 08:36 PM   #5 (permalink)
theleggman
Diesel Enthusiast
 
theleggman's Avatar
 
Join Date: Nov 2010
Location: Omaha
Posts: 21
iTrader Score: 0 reviews

So what happened after that?

Sent from AutoGuide.com Free App
__________________
Everything I know about 6.5's came from this site!!! Thank you!!!

97 K2500 LT Suburban 6.5TD 240K 285/75/16 Dick Cepeks on 2007 Duramax aluminum wheels, 5 in exhaust, K/N, 480LE, 4.10's, new harmonic balancer, Pensicola PMD, Turbo-master, boost-fooler and vac pump delete with 99.5 in belt!!!
Offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Diesel Place : Chevrolet and GMC Diesel Truck Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

PLEASE READ! You must check your email inbox for the confirmation link to complete registration. Please check your spam box if you do not see the email in your inbox.

User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
hard 1-2 upshift, no lockup and no overdrive issues dwayne0714 6.5L Diesel Engine 11 09-24-2010 03:01 PM
6 speed slips and lockup issue aberenz Allison OEM 4 09-21-2010 08:08 PM
slips in reverse jacques619 4L80/85E Transmissions. 6L90 Transmission 0 08-28-2010 12:51 PM
4l80e! no codes,no reverse or overdrive ivfd701 4L80/85E Transmissions. 6L90 Transmission 3 10-30-2009 05:46 AM
Rumble strip in Overdrive lockup throttlesteer 4L80/85E Transmissions. 6L90 Transmission 11 02-27-2009 04:59 PM


All times are GMT -4. The time now is 10:23 PM.


Shoutbox provided by vBShout v6.2.1 (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
© AutoGuide

SEO by vBSEO 3.6.0