4L80 no shift to 4th - Diesel Place : Chevrolet and GMC Diesel Truck Forums
 
Home Forum Market Place Garage Lounge (0) Tuning Library DTC Tool Register Vendors
Go Back   Diesel Place : Chevrolet and GMC Diesel Truck Forums > GM Transmissions > 4L80/85E Transmissions. 6L90 Transmission
Register FAQ Forum Rules My Replies My Threads Mark Forums Read Auto EscrowAuto LoansInsurance

4L80/85E Transmissions. 6L90 Transmission Discuss the 4L80/85E transmissions found in the 6.2/6.5L equipped vehicles and Duramax equipped vans. 6L90 discussion.

DieselPlace.com is the premier Duramax Diesel Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools
Old 04-19-2009, 10:47 PM   #1 (permalink)
Boothy
Diesel Head
 
Join Date: Jan 2007
Posts: 34
iTrader Score: 0 reviews

4L80 no shift to 4th

1. Fluid level okay while running, warm, level surface. YES
1a. Fluid color and smell RED/GOOD
2. Speedometer reading correctly YES
3. Shifting normal/hard NORMAL THROUGH 3RD
4. Shifting into OD okay? NO
5. Any service engine light: yes/no NO BUT ABS LIGHT IS ON
6. If SES light on, what codes do you have? HAVE CODE P1860
7. Model year: 1998 CHEV 3500 7.4L GAS 4X4
8. Describe symptoms: WONT SHIFT TO 4TH
9. Does the engine come up to full temperature? YES
10. Any service work recently done that may contribute to your issues. NONE
11. Does the TCC lock up (or how many "shifts" do you hear?) NOT SURE IF LOCKS BUT 2 SHIFTS
12. Are you experiencing any kind of slipping? NOT SURE
13. What type of rear do you have? (Check RPO codes) 4.10/ 3.73/ 3.42 or 3.08 NOT SURE
14. If you have an accurate tachometer, what is the RPM at 55 or 65? 3K @ 50 MPH


Basically the truck is good except the trans won't go into 4th. All other gears are fine. I have P1860 code but am not sure where to begin. Any help would be much appreciated.
Offline  
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 04-20-2009, 01:07 AM   #2 (permalink)
Boothy
Diesel Head
 
Join Date: Jan 2007
Posts: 34
iTrader Score: 0 reviews

Did some more digging on this site and found a post by GenBilstein on how to check the solenoids with a 9v battery. Did that and heard clicks on 1-2, 2-3 and TCC solenoids. Truck still wont shift to 4 though. Any ideas?
Offline   Reply With Quote Quick reply to this message
Old 04-20-2009, 04:56 PM   #3 (permalink)
Boothy
Diesel Head
 
Join Date: Jan 2007
Posts: 34
iTrader Score: 0 reviews

Any ideas?
Offline   Reply With Quote Quick reply to this message
Old 04-20-2009, 11:12 PM   #4 (permalink)
oldbrownsierra
Diesel Specialist
 
Join Date: Feb 2007
Location: Manitoba, Canada
Posts: 925
iTrader Score: 0 reviews

Is your Torque converter locking up in third? It should.

Also is there slack in your shift linkage.

The Transmission will not go into OD is the engine coolant is not put to temperature. I don't recall what temp, but if that sensor is bad, that could also cause that. I know there are threads on here about it.
__________________
2004 Silverado 2500 4x4 Ext Cab 6.0 4l80E - Daily Driver
1994 K2500 6.5L 4l80E Ext Cab 4x4 Sky Blue - Dad's
1980 GMC Sierra Grande 3500 CC LB 4x4 - The old workhorse

Member #15 of the 3500 CC LB club
Member #22 of the Young and Poor club

Buy Canadian Beef
Offline   Reply With Quote Quick reply to this message
Old 05-15-2009, 12:58 AM   #5 (permalink)
Boothy
Diesel Head
 
Join Date: Jan 2007
Posts: 34
iTrader Score: 0 reviews

Still having same problem with this tranny. I checked all grounds, found one to the back of engine block was broken. I replaced that and cleaned all other grounds but that didn't solve the problem. I get 4th gear only after the battery has been disconnected for awhile and then engine/trans is cold and then it only shifts once to 4th for a few seconds then shifts back to 3rd and never shifts up again. I was doing some research here on the site and found that maybe the VSS is the problem. I tested that out and according to the book it's bad...but what do you guys think? I get AC Voltage readings on it when I spin the wheels but not the minimum 0.5 volts. Meaning I start with 0.1 and it gets up to 0.7 but the wheels are spinning as fast as possible by hand. Could this be the culprit?
Offline   Reply With Quote Quick reply to this message
Old 05-15-2009, 01:06 AM   #6 (permalink)
oldbrownsierra
Diesel Specialist
 
Join Date: Feb 2007
Location: Manitoba, Canada
Posts: 925
iTrader Score: 0 reviews

Sounds like it to me, GenBilstein will hopefully chime in, he will know for sure
__________________
2004 Silverado 2500 4x4 Ext Cab 6.0 4l80E - Daily Driver
1994 K2500 6.5L 4l80E Ext Cab 4x4 Sky Blue - Dad's
1980 GMC Sierra Grande 3500 CC LB 4x4 - The old workhorse

Member #15 of the 3500 CC LB club
Member #22 of the Young and Poor club

Buy Canadian Beef
Offline   Reply With Quote Quick reply to this message
Old 05-15-2009, 02:07 AM   #7 (permalink)
bigblock72
Diesel Fanatic
 
Join Date: Nov 2008
Location: Utah
Posts: 73
iTrader Score: 0 reviews

I don't think the VSS is the problem in this case.

P1860 is an electrical problem with the TCC solenoid valve. When this code is set the trans will not be allowed to shift into OD. Check the TCC solenoid and wiring, once you get the problem fixed you'll get OD back.
__________________
94 GMC C3500 dually w/whippled 7.4l

09 Kodiak D-max C5500/Road Warrior motorhome

01 GMC Yukon XL 8.1

Just make it big, make it a GMC and it's all good
Offline   Reply With Quote Quick reply to this message
Old 05-15-2009, 02:10 AM   #8 (permalink)
Boothy
Diesel Head
 
Join Date: Jan 2007
Posts: 34
iTrader Score: 0 reviews

Just changed it out with a new one, it shifted better and smoother (on the plus side) even went right into 4th for a few seconds. Then right back into 3rd and wont go into 4th. I did notice oil on the pass through connector though. I read about that on this site. I'm going to clean it and replace the o-ring in the morning. GenBilt any ideas?
Offline   Reply With Quote Quick reply to this message
Old 05-15-2009, 02:19 AM   #9 (permalink)
bigblock72
Diesel Fanatic
 
Join Date: Nov 2008
Location: Utah
Posts: 73
iTrader Score: 0 reviews

Any electrical problem between the computer and the fuse will cause this code.

You should have power at pin 7 at connector C2 (red connector) until the computer commands lockup and grounds pin 7. If you don't have power at pin 7 with the key on then you need to trace that wire back to the connector at the trans and into the trans to the TCC solenoid and find where you're losing your connection at.
If you always have power at pin 7 even after the converter should be locked up then the problem is in the computer itself.
__________________
94 GMC C3500 dually w/whippled 7.4l

09 Kodiak D-max C5500/Road Warrior motorhome

01 GMC Yukon XL 8.1

Just make it big, make it a GMC and it's all good
Offline   Reply With Quote Quick reply to this message
Old 05-15-2009, 02:50 AM   #10 (permalink)
Boothy
Diesel Head
 
Join Date: Jan 2007
Posts: 34
iTrader Score: 0 reviews

Pin 7...stupid question but thats counting left to right on the top row correct?
Offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Diesel Place : Chevrolet and GMC Diesel Truck Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

PLEASE READ! You must check your email inbox for the confirmation link to complete registration. Please check your spam box if you do not see the email in your inbox.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
4L80 wont shift out of first michaeljp86 4L80/85E Transmissions. 6L90 Transmission 24 10-23-2008 01:18 PM
Transgo 4L80-E-HD2 shift kit GCncsuHD Closed / Archived Marketplace Ads 0 04-10-2008 01:41 AM
4l80 Shift kit dzlrig 4L80/85E Transmissions. 6L90 Transmission 2 03-30-2008 03:04 AM
4L80 ? wont shift out of first. Ryan11r 4L80/85E Transmissions. 6L90 Transmission 3 04-29-2006 09:31 PM
4L80 shift kit Steve93mustanglx 4L80/85E Transmissions. 6L90 Transmission 7 11-23-2005 10:00 PM


All times are GMT -4. The time now is 07:53 PM.


Shoutbox provided by vBShout v6.2.1 (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.
© AutoGuide

SEO by vBSEO 3.6.0